LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 12-13-2004, 07:30 PM   #1
aus9
LQ Addict
 
Registered: Oct 2003
Location: Australia
Distribution: MX 16
Posts: 5,291

Rep: Reputation: Disabled
howto nvidia driver and 10.1


After perusing this forum and the nvidia forum I installed my nv this way
First install the file bash completion if you have not already done so, it allows you type the first bits of a command then press tab to complete it or give you options
Also completes file names.

1) edit /etc/inittab to runlevel 3
2) edit /etc/X11/XF86Config to name driver as nvidia in lieu of nv everything else for me was ok
3) reboot
4) boot into root in console mode
5) cd /pathway to file download/your nvidia file likely to be intel/amd 32 x86 file if you are reading this
6) sh NV press TAB if you have bash completion installed and let file execute and accept agreement
7) still in console mode Mdk 10.1 has a bug apparently. So you need to add an entry to your /etc/modprobe.preload file called nvidia I use vi to edit then I can type startx.

If you do not like vi type startx and edit file in a graphical mode using a text editor

8) still in console mode reedit your inittab if you know vi or startx and edit it back to run level 5

If you want to try vi commands are
vi /etc/inittab
Press the key I for INsert
arrow down to the run level and type 5 for gui and delete the 3
Press Escape key to get back to command mode
Press :wq! to issue command WRITE/QUIT/QUIT WITHOUT warning
8) reboot to test

9) When in graphical mode open a console type nv Press TAB to see some nv commands like settings to play with

examples only below

BELOW are outputs of my modprobe file
# /etc/modprobe.preload: kernel modules to load at boot time.
#
# This file should contain the names of kernel modules that are
# to be loaded at boot time, one per line. Comments begin with
# a `#', and everything on the line after them are ignored.
# this file is for module-init-tools (kernel 2.5 and above) ONLY
# for old kernel use /etc/modules

amd64-agp
nvidia

BELOW is the line to find in inittab
id:5:initdefault:

########so 5 for gui and 3 for login for many users but without gui

Last edited by aus9; 12-13-2004 at 07:47 PM.
 
Old 12-13-2004, 09:46 PM   #2
Lakota
Member
 
Registered: Oct 2003
Location: London, ON, Canada
Distribution: Mandriva 2007 Free
Posts: 507

Rep: Reputation: 30
I hate to be a pessimist but....
I tried yesterday two intalls of the nvidia driver on my machine in morning and neither one was successful. Both barfed into the terminal login, and I uninstalled it and went back to nv driver. Looked at how you did it and thought that is strange, the only thing you did different was edit your files before the install, and I did them after. Anyway, I followed your guide, and to my surprise I have a graphical desktop. The stock Mandrake 10.1 install has rivafb module built into the kernel. The installer did warn of this, saying it was still able to compile and install nvidia driver but it was in conflict with rivafb and would not work without removing rivafb. Then I got to thinking, 10.1 uses xorg, not xf86. Mandrake 10.0 used XF86Config. So we are telling Mandrake to load nvidia driver in a file that is no longer used, but the file that 10.1 actually uses xorg.conf we did not edit, and still is calling the nv driver.

As a last note, did you see the full screen nvidia splash screen prior to your desktop loading?
I would like to know how to remove rivafb module (built into kernel), without building a new kernel.
 
Old 12-14-2004, 06:03 AM   #3
otish1000c
Member
 
Registered: May 2004
Location: Pennsylvania, USA
Distribution: dual boot.... Mandrake 10.0OE/10.xcooker
Posts: 611

Rep: Reputation: 30
Lakota.......

you can ignore the RIVAFB warning & proceed with the install. that only pertains to if you have a RIVA based card. it will do no harm.

i think your problem relates to what aus9 posted. there seems to be a bug/glitch/conflict with udev & Nvidia drivers in 10.1. after you install the drivers via the normal procedure & after you edit xorg.conf, if X still won't start use vim (or vi) and edit your /etc/modprobe.preload file to add a line simply saying nvidia. i don't have an example of mine at hand right now to show you, but it's just a matter of adding the word nvidia somewhere underneath the header text in that file. save it, reboot & X should start fine.

also, check the Nvidia link in my sig for install help if you need it.

otis
 
Old 12-14-2004, 03:48 PM   #4
jfi
Member
 
Registered: Sep 2003
Location: France
Distribution: Mandriva2007, Debian, OpenSuse, Slack10, FC6, PC-BSD, Solaris10
Posts: 65

Rep: Reputation: 15
It is a good idea to summerize the installation of the NVIDIA driver. Howerver, in my case an additional step was necessary (GeForce4 488 Go, kernel 2.6.8.1-12mdk, driver NVIDIA-Linux-x86-1.0-5336-pkg1.run, more recent drivers didn't work).

I followed more or less the steps you propose. All seemed okay, it was also possible to leave X and to restart X without problem. Unfortunately, after reboot, each times, I was obliged to reinstall the driver.

I solved this problem by adding two lines in a script executed at boot (/etc/rc.d/rc.local for example):
mknod /dev/nvidia0 c 195 0
mknod /dev/nvidiactl c 195 255

(also add nvidia at in /etc/modprobe.preload).

Hope it will help.
 
Old 12-14-2004, 03:58 PM   #5
Lakota
Member
 
Registered: Oct 2003
Location: London, ON, Canada
Distribution: Mandriva 2007 Free
Posts: 507

Rep: Reputation: 30
Ok, I am now sorted out.

My post is correct, if you follow the intructions by aus9, you will have the nvidia driver installed but be running the nv driver. If you look at #2 of his post, it tells you to edit /etc/X11/XF86Config which is not used in mandrake 10.1

Last night I did not bother editing /etc/X11/xorg.conf, as I had two failures the other morning. After reading your post otish100c, I figured I would edit xorg.conf and see what happens. Saw nvidia splash screen and now my openGL works. To figure out what was different from my failed attempts, the only thing different was the other morning when I added nvidia to the xorg.conf I also uncommented the load 3d layer line. So, did that and could not bring up my xserver like other morning. So commented out that line again and all is well.

So if aus9 reads this, maybe you could edit your post to tell newbs to add nvidia to /etc/X11/xorg.conf, not /etc/X11/XF86Config. And it would be a perfect install guide.

I had to add nvidia to /etc/modprobe.preload in Mandrake 10.0 as well after I had upgraded 10.0 to a newer kernel, or it would boot with nv driver. So that appears to be kernel related, not Mandrake.
 
Old 12-14-2004, 10:48 PM   #6
Hexane
LQ Newbie
 
Registered: Dec 2004
Posts: 27

Rep: Reputation: 15
Hmmm, I already did exactly what this article says to do and im still having problems.

Only thing differnt is when I did mine I just ctrl+alt+f1 and then did an "init 3" as root. and restarted X with startx -- :0 I don't know why mine still doesn't work. I stuck using the nv driver. I have nvidia in my modprobe.preload although it is after my intel-agp driver.
 
Old 12-14-2004, 10:56 PM   #7
raxxal
Member
 
Registered: Jul 2004
Location: Los Angeles
Distribution: Mandrake 2007
Posts: 109

Rep: Reputation: 15
Quote:
Originally posted by jfi
It is a good idea to summerize the installation of the NVIDIA driver. Howerver, in my case an additional step was necessary (GeForce4 488 Go, kernel 2.6.8.1-12mdk, driver NVIDIA-Linux-x86-1.0-5336-pkg1.run, more recent drivers didn't work).

I followed more or less the steps you propose. All seemed okay, it was also possible to leave X and to restart X without problem. Unfortunately, after reboot, each times, I was obliged to reinstall the driver.

I solved this problem by adding two lines in a script executed at boot (/etc/rc.d/rc.local for example):
mknod /dev/nvidia0 c 195 0
mknod /dev/nvidiactl c 195 255

(also add nvidia at in /etc/modprobe.preload).

Hope it will help.
Thanks a lot for this tip, this really solved my problem. I don't know what those parametters mean, but they worked just fine! I was having the same problem.

Raxxal
 
Old 12-15-2004, 02:48 AM   #8
Thorium
Member
 
Registered: Dec 2004
Location: USA
Distribution: Debian
Posts: 124

Rep: Reputation: 15
That also worked for me on reboot! I wish I knew what those commands did as well I am a super noob, but as long as it works, I'm happy. Thank you!
 
Old 12-15-2004, 06:28 AM   #9
aus9
LQ Addict
 
Registered: Oct 2003
Location: Australia
Distribution: MX 16
Posts: 5,291

Original Poster
Rep: Reputation: Disabled
to all that need to know

ls -l /etc/X11/xorg.conf gives output of
lrwxrwxrwx 1 root root 10 Dec 13 23:11 /etc/X11/xorg.conf -> XF86Config
= it is a link file to XF86Config.
I have hidden files on so dunno know if that is the issue.

2) Yes I get the splash screen....glxgears on my fx5200 gives me 1150 to 1193 with some minor tweaks with xvidtune and yes I am aware of the warnings thankyou.

3) thanks for the tip on mknod will check it out when I can jfi
 
Old 12-15-2004, 07:02 AM   #10
otish1000c
Member
 
Registered: May 2004
Location: Pennsylvania, USA
Distribution: dual boot.... Mandrake 10.0OE/10.xcooker
Posts: 611

Rep: Reputation: 30
Quote:
ls -l /etc/X11/xorg.conf gives output of
lrwxrwxrwx 1 root root 10 Dec 13 23:11 /etc/X11/xorg.conf -> XF86Config
= it is a link file to XF86Config.
that is an annoyingly weird quirk with Mandrake. i don't know why they retain the XF86Config file & symlink xorg.conf to it. sorta defeats the purpose of the xorg file, if ya ask me.

if you want to eliminate it, do the following........

open a terminal as root. type kwrite etc/X11/xorg.conf, to open the file with kwrite in root mode. (or, same method for any text editor of your choice.) then open a file manager as root (kdesu konqueror, for instance), go to /etc/X11/ & rename the XF86Config file to XF86Config~. (you could just delete it, too, but you might wanna keep it around as a backup/template) rename the xorg.conf file to something like xorg.conf~. now save the xorg.conf you have opened in kwrite as xorg.conf in that same directory.

you could also rename/delete the files in terminal with various commands, but the above is an easy gui way. restart X for the unlinked xorg.conf to be used exclusively.

otis
 
Old 12-15-2004, 10:11 AM   #11
raxxal
Member
 
Registered: Jul 2004
Location: Los Angeles
Distribution: Mandrake 2007
Posts: 109

Rep: Reputation: 15
Quote:
Originally posted by aus9
to all that need to know

ls -l /etc/X11/xorg.conf gives output of
lrwxrwxrwx 1 root root 10 Dec 13 23:11 /etc/X11/xorg.conf -> XF86Config
= it is a link file to XF86Config.
I have hidden files on so dunno know if that is the issue.

2) Yes I get the splash screen....glxgears on my fx5200 gives me 1150 to 1193 with some minor tweaks with xvidtune and yes I am aware of the warnings thankyou.

3) thanks for the tip on mknod will check it out when I can jfi
glxgears gives the following on a HP zd7260:

alex@localhost:~$ glxgears
14152 frames in 5.0 seconds = 2830.400 FPS
16432 frames in 5.0 seconds = 3286.400 FPS
16411 frames in 5.0 seconds = 3282.200 FPS
 
Old 12-15-2004, 03:32 PM   #12
Thorium
Member
 
Registered: Dec 2004
Location: USA
Distribution: Debian
Posts: 124

Rep: Reputation: 15
Hmm, after a reboot now, it starts up without actually loading KDE. I have a terminal window that is half off the screen, I can exit and log back in, and then startx brings kde up fine, I am very confused

Edit: just forgot to say, I do get the nvidia splash, then the messed up terminal view.

Last edited by Thorium; 12-15-2004 at 03:49 PM.
 
Old 12-15-2004, 04:16 PM   #13
raxxal
Member
 
Registered: Jul 2004
Location: Los Angeles
Distribution: Mandrake 2007
Posts: 109

Rep: Reputation: 15
Quote:
Originally posted by Thorium
Hmm, after a reboot now, it starts up without actually loading KDE. I have a terminal window that is half off the screen, I can exit and log back in, and then startx brings kde up fine, I am very confused

Edit: just forgot to say, I do get the nvidia splash, then the messed up terminal view.
To fix my nvidia, this is what I did. All these steps were found somewhere in this board.


Disable the X server: Alt+Ctrl+F1
Switch to run level 3: Init 3
Uninstall the nvidia driver: sh NVIDIA.... --uninstall
Find my kernel: uname -r
Install the nvidia driver using this parametter: sh NVIDIA... --kernel-name=2.6.8.1-12mdksmp
Did the hack wih mknod as listed on this thread.
Reboot.
Bingo!
Everything works just fine. By the way, I am using an HP laptop ZD7260.
 
Old 12-15-2004, 06:05 PM   #14
Thorium
Member
 
Registered: Dec 2004
Location: USA
Distribution: Debian
Posts: 124

Rep: Reputation: 15
Don't have a dual cpu (is that the smp is?) uninstalled the drivers and commented the xorg file back to nv, still giving me this terminal window even after removing, I think it is probably something else, I'll take a screen of it if I can.
 
Old 12-15-2004, 06:25 PM   #15
raxxal
Member
 
Registered: Jul 2004
Location: Los Angeles
Distribution: Mandrake 2007
Posts: 109

Rep: Reputation: 15
Quote:
Originally posted by Thorium
Don't have a dual cpu (is that the smp is?) uninstalled the drivers and commented the xorg file back to nv, still giving me this terminal window even after removing, I think it is probably something else, I'll take a screen of it if I can.
You're right, smp is for a dual or multiple cpus, I have the Pemtium 4 3.2 Ghz, this cpu has Hyper-Threading Technology , the kernel thinks there are two CPU.
uname -r will tell you what kind of kernel you are using. You can use either the standard or smp if you have more than one cpu, or a cpu with Hyper-Threading Technology, the standard kernel will not make sense in a dual cpu system or a cpu with Hyper-Threading Technology.
If you have a cpu without Hyper-Threading Technology, you cannot use the smp kernel.

Last edited by raxxal; 12-15-2004 at 06:29 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
howto use Nvidia 6269, NVIDIA 7174 is very buggy jery_wang2002 Arch 9 06-28-2005 02:54 PM
ATI & nVIDIA Video Driver HOWTO on the front page t3gah LQ Suggestions & Feedback 1 03-21-2005 06:28 AM
ATI driver update for SUSE LINUX 9.2..NVIDIA Installer HOWTO... RPM packages of X.Org coolbreeze7000 SUSE / openSUSE 17 02-08-2005 04:50 PM
nvidia fx5600 loads vesa driver instead of nvidia driver saburo62 Linux - Hardware 3 05-04-2004 03:59 PM
kernel 2.6.3--bk8 and NVIDIA-Linux-x86-1.0-5336 video driver from Nvidia zdenkod Linux - Hardware 2 03-09-2004 05:38 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 03:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration