LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-16-2017, 05:34 PM   #1
PatD
Member
 
Registered: Dec 2016
Posts: 44

Rep: Reputation: Disabled
Unhappy Dependencies


A bit fed up and discouraged here with Linux these days. Sorry about all the quotes, but I'm sinking here. The Interweb has been absolutely no help with this stuff.

I'm running Ubuntu mate 16.04 and really like it. But as with every distro, I'm having trouble installing software cuz "dependencies" and something wrong with dpkg.

Here are some errors:

From $ sudo apt update

Quote:
E: The method driver /usr/lib/apt/methods/https// could not be found.
W: http://archive.canonical.com/dists/precise/Release.gpg: Signature by key 630239CC130E1A7FD81A27B140976EAF437D05B5 uses weak digest algorithm (SHA1)
W: GPG error: http://download.opensuse.org/reposit.../xUbuntu_16.04 Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY E3757B8E0D988D6E
E: The repository 'http://download.opensuse.org/repositories/home:/colomboem/xUbuntu_16.04 Release' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
From $ sudo apt install openjdk-8-jdk

it ends with this error

Quote:
Connecting to download.oracle.com (download.oracle.com)|209.148.205.26|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2017-10-16 16:51:00 ERROR 404: Not Found.

download failed
Oracle JDK 6 is NOT installed.
dpkg: error processing package oracle-java6-installer (--configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of atunes:
atunes depends on sun-java6-jre | sun-java6-jdk | openjdk-6-jre | openjdk-6-jdk; however:
Package sun-java6-jre is not installed.
Package sun-java6-jdk is not installed.
Package openjdk-6-jre is not installed.
Package oracle-java6-installer which provides openjdk-6-jre is not configured yet.
Package openjdk-6-jdk is not installed.

dpkg: error processing package atunes (--configure):
dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
Errors were encountered while processing:
oracle-java6-installer
atunes
E: Sub-process /usr/bin/dpkg returned an error code (1)
And when I enter $ sudo aptitude update && sudo aptitude full-upgrade

I get this error at the end:

Quote:
E: The method driver /usr/lib/apt/methods/https// could not be found.
W: http://archive.canonical.com/dists/precise/Release.gpg: Signature by key 630239CC130E1A7FD81A27B140976EAF437D05B5 uses weak digest algorithm (SHA1)
W: GPG error: http://download.opensuse.org/reposit.../xUbuntu_16.04 Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY E3757B8E0D988D6E
W: The repository 'http://download.opensuse.org/repositories/home:/colomboem/xUbuntu_16.04 Release' is not signed.
W: Failed to fetch https//://deb.opera.com/opera-stable/dists/stable/InRelease:
E: Some index files failed to download. They have been ignored, or old ones used instead.
and $ sudo apt-get install -f ends like this:

Quote:
Connecting to download.oracle.com (download.oracle.com)|209.148.200.26|:80... connected.
HTTP request sent, awaiting response... 302 Moved Temporarily
Location: https://edelivery.oracle.com/otn-pub...-linux-x64.bin [following]
--2017-10-16 17:17:55-- https://edelivery.oracle.com/otn-pub...-linux-x64.bin
Resolving edelivery.oracle.com (edelivery.oracle.com)... 2600:1407:9:380::2d3e, 2600:1407:9:393::2d3e, 104.93.179.190
Connecting to edelivery.oracle.com (edelivery.oracle.com)|2600:1407:9:380::2d3e|:443... connected.
HTTP request sent, awaiting response... 302 Moved Temporarily
Location: http://download.oracle.com/otn-pub/j...d034f821997450 [following]
--2017-10-16 17:17:56-- http://download.oracle.com/otn-pub/j...d034f821997450
Connecting to download.oracle.com (download.oracle.com)|209.148.200.26|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2017-10-16 17:17:57 ERROR 404: Not Found.

download failed
Oracle JDK 6 is NOT installed.
dpkg: error processing package oracle-java6-installer (--configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of atunes:
atunes depends on sun-java6-jre | sun-java6-jdk | openjdk-6-jre | openjdk-6-jdk; however:
Package sun-java6-jre is not installed.
Package sun-java6-jdk is not installed.
Package openjdk-6-jre is not installed.
Package oracle-java6-installer which provides openjdk-6-jre is not configured yet.
Package openjdk-6-jdk is not installed.

dpkg: error processing package atunes (--configure):
dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
Errors were encountered while processing:
oracle-java6-installer
atunes
E: Sub-process /usr/bin/dpkg returned an error code (1)
devlin@MainBox:~$ sudo apt-get build-dep build-essentials
Reading package lists... Done
Can somebody tell me what is wrong here? Have I done something stupid?

Is there any way to load all these dependencies up so as to avoid these nonsensical issues?

Later:
I just tried to reinstall "dpkg" and got this error:

Quote:
E: oracle-java6-installer: subprocess installed post-installation script returned error exit status 1
E: atunes: dependency problems - leaving unconfigured
So if all these issues are about that damn Oracle stuff, what can I do about it? Anyone, please?

Last edited by PatD; 10-16-2017 at 05:50 PM.
 
Old 10-16-2017, 09:33 PM   #2
wpeckham
Senior Member
 
Registered: Apr 2010
Location: Continental USA
Distribution: Debian, Ubuntu, Fedora, RedHat, DSL, Puppy, CentOS, Knoppix, Mint-DE, Sparky, Vsido, tinycore, Q4OS
Posts: 2,386

Rep: Reputation: 961Reputation: 961Reputation: 961Reputation: 961Reputation: 961Reputation: 961Reputation: 961Reputation: 961
If I had to guess, I would say that it looks as if someone has corrupted your sources. Editing the sources.list and either using the wrong editor (one that adds characters or 'signals' that are not proper text), or manually editing and entering a typo are common causes of these messages.

The information provided is not adequate to be certain, but that is what it looks like.

Have you manually edited or added any source files to add or change any repos?

Have you made non-standard modifications to python or apt?
 
Old 10-17-2017, 12:46 PM   #3
PatD
Member
 
Registered: Dec 2016
Posts: 44

Original Poster
Rep: Reputation: Disabled
No editing of any kind on my part.
I had some weird problems with trying to install atunes with a deb, it was missing Oracle Java6 dependencies.
After I tried installing with gdebi it worked (I've lost the post that suggested that) but everything else is screwed.
Removing/purging atunes did nothing for this.

A bit lost here.
 
Old 10-17-2017, 01:38 PM   #4
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 6,791
Blog Entries: 3

Rep: Reputation: 1632Reputation: 1632Reputation: 1632Reputation: 1632Reputation: 1632Reputation: 1632Reputation: 1632Reputation: 1632Reputation: 1632Reputation: 1632Reputation: 1632
Quote:
Originally Posted by PatD View Post
No editing of any kind on my part.
hmmm...


anyhow, we need to see those sources:
Code:
cat /etc/apt/sources.list 
cat /etc/apt/sources.list.d/*
 
Old 10-17-2017, 06:15 PM   #5
PatD
Member
 
Registered: Dec 2016
Posts: 44

Original Poster
Rep: Reputation: Disabled
When I looked into the Software "Other Sources" I saw that everything was checked, including all the sources; I don't think I did that, not intentionally, anyway.
Would that be part of the problem?

Quote:
$ cat /etc/apt/sources.list
# deb cdrom:[Ubuntu-MATE 16.04.3 LTS _Xenial Xerus_ - Release amd64 (20170801)]/ xenial main multiverse restricted universe
# deb cdrom:[Ubuntu-MATE 16.04.3 LTS _Xenial Xerus_ - Release amd64 (20170801)]/ xenial main multiverse restricted universe

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://ca.archive.ubuntu.com/ubuntu/ xenial main restricted
# deb-src http://ca.archive.ubuntu.com/ubuntu/ xenial main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://ca.archive.ubuntu.com/ubuntu/ xenial-updates main restricted
# deb-src http://ca.archive.ubuntu.com/ubuntu/ xenial-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://ca.archive.ubuntu.com/ubuntu/ xenial universe
# deb-src http://ca.archive.ubuntu.com/ubuntu/ xenial universe
deb http://ca.archive.ubuntu.com/ubuntu/ xenial-updates universe
# deb-src http://ca.archive.ubuntu.com/ubuntu/ xenial-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://ca.archive.ubuntu.com/ubuntu/ xenial multiverse
# deb-src http://ca.archive.ubuntu.com/ubuntu/ xenial multiverse
deb http://ca.archive.ubuntu.com/ubuntu/ xenial-updates multiverse
# deb-src http://ca.archive.ubuntu.com/ubuntu/ xenial-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://ca.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse
# deb-src http://ca.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu xenial partner
deb-src http://archive.canonical.com/ubuntu xenial partner

deb http://security.ubuntu.com/ubuntu xenial-security main restricted
# deb-src http://security.ubuntu.com/ubuntu xenial-security main restricted
deb http://security.ubuntu.com/ubuntu xenial-security universe
# deb-src http://security.ubuntu.com/ubuntu xenial-security universe
deb http://security.ubuntu.com/ubuntu xenial-security multiverse
# deb-src http://security.ubuntu.com/ubuntu xenial-security multiverse

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
# deb-src http://ca.archive.ubuntu.com/ubuntu/ xenial main restricted

## Major bug fix updates produced after the final release of the
## distribution.
# deb-src http://ca.archive.ubuntu.com/ubuntu/ xenial-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
# deb-src http://ca.archive.ubuntu.com/ubuntu/ xenial universe
# deb-src http://ca.archive.ubuntu.com/ubuntu/ xenial-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
# deb-src http://ca.archive.ubuntu.com/ubuntu/ xenial multiverse
# deb-src http://ca.archive.ubuntu.com/ubuntu/ xenial-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb-src http://ca.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu xenial partner
deb-src http://archive.canonical.com/ubuntu xenial partner

# deb-src http://security.ubuntu.com/ubuntu xenial-security main restricted
# deb-src http://security.ubuntu.com/ubuntu xenial-security universe
# deb-src http://security.ubuntu.com/ubuntu xenial-security multiverse
deb http://archive.canonical.com/ precise partner
deb-src http://archive.canonical.com/ precise partner
Quote:
$ cat /etc/apt/sources.list.d/*
deb http://ppa.launchpad.net/costales/anoise/ubuntu xenial main
deb-src http://ppa.launchpad.net/costales/anoise/ubuntu xenial main
deb http://ppa.launchpad.net/costales/anoise/ubuntu xenial main
deb-src http://ppa.launchpad.net/costales/anoise/ubuntu xenial main
deb http://repo.sinew.in/ stable main
deb http://repo.sinew.in/ stable main
deb http://ppa.launchpad.net/gambas-team/gambas3/ubuntu xenial main
deb-src http://ppa.launchpad.net/gambas-team/gambas3/ubuntu xenial main
deb http://ppa.launchpad.net/gambas-team/gambas3/ubuntu xenial main
deb-src http://ppa.launchpad.net/gambas-team/gambas3/ubuntu xenial main
deb-src http://ppa.launchpad.net/jtaylor/keepass/ubuntu xenial main
deb http://ppa.launchpad.net/nemh/systemback/ubuntu xenial main
deb-src http://ppa.launchpad.net/nemh/systemback/ubuntu xenial main
deb-src http://ppa.launchpad.net/nemh/systemback/ubuntu xenial main
deb http://ppa.launchpad.net/nemh/systemback/ubuntu xenial main
deb-src http://ppa.launchpad.net/nemh/systemback/ubuntu xenial main
deb-src http://ppa.launchpad.net/nemh/systemback/ubuntu xenial main
deb [arch=i386,amd64] http://apt.nylas.com/ubuntu vivid main
deb [arch=i386,amd64] http://apt.nylas.com/ubuntu vivid main
# This file makes sure that Opera Browser is kept up-to-date
# as part of regular system upgrades

deb https//:deb.opera.com/opera-stable/ stable non-free #Opera Browser (final releases)
# This file makes sure that Opera Browser is kept up-to-date
# as part of regular system upgrades

deb https//:deb.opera.com/opera-stable/ stable non-free #Opera Browser (final releases)
deb http://ppa.launchpad.net/peterlevi/ppa/ubuntu xenial main
deb-src http://ppa.launchpad.net/peterlevi/ppa/ubuntu xenial main
deb http://ppa.launchpad.net/peterlevi/ppa/ubuntu xenial main
deb-src http://ppa.launchpad.net/peterlevi/ppa/ubuntu xenial main
deb http://ppa.launchpad.net/stellarium/...eleases/ubuntu xenial main
deb-src http://ppa.launchpad.net/stellarium/...eleases/ubuntu xenial main
deb http://ppa.launchpad.net/stellarium/...eleases/ubuntu xenial main
deb-src http://ppa.launchpad.net/stellarium/...eleases/ubuntu xenial main
deb http://ppa.launchpad.net/team-xbmc/ppa/ubuntu xenial main
deb-src http://ppa.launchpad.net/team-xbmc/ppa/ubuntu xenial main
deb http://ppa.launchpad.net/team-xbmc/ppa/ubuntu xenial main
deb-src http://ppa.launchpad.net/team-xbmc/ppa/ubuntu xenial main
deb http://ppa.launchpad.net/teejee2008/ppa/ubuntu xenial main
deb-src http://ppa.launchpad.net/teejee2008/ppa/ubuntu xenial main
deb http://ppa.launchpad.net/teejee2008/ppa/ubuntu xenial main
deb-src http://ppa.launchpad.net/teejee2008/ppa/ubuntu xenial main
deb http://ppa.launchpad.net/ubuntu-desk...tu-make/ubuntu xenial main
deb-src http://ppa.launchpad.net/ubuntu-desk...tu-make/ubuntu xenial main
deb http://ppa.launchpad.net/ubuntu-desk...tu-make/ubuntu xenial main
deb-src http://ppa.launchpad.net/ubuntu-desk...tu-make/ubuntu xenial main
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
deb http://repo.vivaldi.com/stable/deb/ stable main
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
deb http://repo.vivaldi.com/stable/deb/ stable main
deb http://ppa.launchpad.net/webupd8team/java/ubuntu xenial main
deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu xenial main
deb http://ppa.launchpad.net/webupd8team/java/ubuntu xenial main
deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu xenial main
 
Old 10-17-2017, 07:24 PM   #6
snowpine
Senior Member
 
Registered: Feb 2009
Posts: 4,244

Rep: Reputation: 1199Reputation: 1199Reputation: 1199Reputation: 1199Reputation: 1199Reputation: 1199Reputation: 1199Reputation: 1199Reputation: 1199
Your biggest problem is Java 6, totally unsupported in Ubuntu Xenial! Why??

Another error is caused by the repository http://download.opensuse.org/reposit.../xUbuntu_16.04 which, from what I can tell, provides the dukto package. Unless this software is mission-critical, I recommend to disable this repository and try the upgrade again.

There is, however, another potential big problem: I see that you have software sources for at least three different Ubuntu releases: xenial, vivid, and precise. This is like trying to fix a 2016 car with spare parts from a 2012 car--it might work (but it probably won't, and might make the car undrivable). A common way this situation happens is when a user follows random out-of-date tutorials without fully realizing the consequences to their system.

Therefore I recommend carefully trimming your software sources back to only the official Ubuntu Xenial repositories. Disable all third party repositories, as well as all repositories for the wrong Ubuntu release (vivid, precise, etc., anything except xenial). Abandon the thought of running Java 6. Then try your upgrade again. It is possible (but not guaranteed) that your Ubuntu OS will be able to recover from this mess.

Last edited by snowpine; 10-17-2017 at 07:59 PM.
 
Old 10-17-2017, 10:14 PM   #7
PatD
Member
 
Registered: Dec 2016
Posts: 44

Original Poster
Rep: Reputation: Disabled
Wonderful!

It seems you hit it. I went into sources.list and sources.list.d and edited out all the lines that showed as repeats in one of the error messages. I also, as you suggested, trimmed the sources right back, including removing the Opera one, as it would never update anyway.

All seems to be good there, but if I run the fix in the software boutique for interrupted packages, it throws up that java6 stuff again. (I figure that's a good way to find problems, right?)

Why is it doing that? And how do I get of it if it's an interrupted package?

Oh, my. I just figured it out - although I tried it a while ago and it didn't work. First I ran auto-remove to see what the package name was, then I ran "sudo apt purge oracle-java6-installer" and then "autoremove" worked, and everything is copacetic!

Huge Thanks! (and how to mark SOLVED?)

Last edited by PatD; 10-17-2017 at 11:08 PM. Reason: Figured it out
 
Old 10-18-2017, 02:30 AM   #8
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 6,791
Blog Entries: 3

Rep: Reputation: 1632Reputation: 1632Reputation: 1632Reputation: 1632Reputation: 1632Reputation: 1632Reputation: 1632Reputation: 1632Reputation: 1632Reputation: 1632Reputation: 1632
Quote:
Originally Posted by PatD View Post
(and how to mark SOLVED?)
http://dt.iki.fi/stuff/solved-lq.png
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Issues with dependencies when installing php70-fpm. I have newer versions of the dependencies installed, but php70-fpm requires older KurtisKewl *BSD 9 05-02-2017 02:23 PM
Dependencies Peter_APIIT Mandriva 5 04-13-2007 03:54 PM
dependencies biiiep Ubuntu 1 01-21-2007 12:02 PM
I recieve a failed dependencies error, but I have all required dependencies Laptop2250 Linux - Software 15 02-03-2004 08:58 PM
help about dependencies coldy Debian 2 10-19-2003 09:05 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration