LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux Mint
User Name
Password
Linux Mint This forum is for the discussion of Linux Mint.

Notices


Reply
  Search this Thread
Old 01-30-2018, 02:36 PM   #16
hydrurga
LQ Guru
 
Registered: Nov 2008
Location: Pictland
Distribution: Linux Mint 19 MATE
Posts: 5,253
Blog Entries: 2

Rep: Reputation: 1707Reputation: 1707Reputation: 1707Reputation: 1707Reputation: 1707Reputation: 1707Reputation: 1707Reputation: 1707Reputation: 1707Reputation: 1707Reputation: 1707

Quote:
Originally Posted by Thane View Post
I'm afraid the grub menu doesn't show up on reboots. I have tried holding down the shift key after Post and also rapidly tapping the shift key. Neither seems to have any effect.
Ok. Some people have reported more success with the Esc key, some with the right shift key (bizarrely).

But let's do it the other way around:

Enter the following command into the terminal:

Code:
gksudo xed /etc/default/grub
and (i) put a # before GRUB_HIDDEN_TIMEOUT=0

(ii) set GRUB_TIMEOUT to a reasonable number of seconds (I use 10 because I don't belong to the "It must boot instantly" school).

Then close xed, saving the file when requested, and run (to configure grub with the new settings):

Code:
sudo update-grub
After this has completed, restart your machine and hopefully the grub screen will show.
 
Old 01-30-2018, 03:00 PM   #17
Thane
Member
 
Registered: Aug 2006
Location: Ontario,Canada
Distribution: Linux Mint18 Cinnamon 64bit
Posts: 200

Original Poster
Rep: Reputation: Disabled
grub

Got it thanks. Grub menu came up on next reboot after using the xed method. Definitely running on the 4.13.0-31-generic kernel now. Will see if this fixes the problem.
 
Old 01-30-2018, 03:57 PM   #18
hydrurga
LQ Guru
 
Registered: Nov 2008
Location: Pictland
Distribution: Linux Mint 19 MATE
Posts: 5,253
Blog Entries: 2

Rep: Reputation: 1707Reputation: 1707Reputation: 1707Reputation: 1707Reputation: 1707Reputation: 1707Reputation: 1707Reputation: 1707Reputation: 1707Reputation: 1707Reputation: 1707
Quote:
Originally Posted by Thane View Post
Got it thanks. Grub menu came up on next reboot after using the xed method. Definitely running on the 4.13.0-31-generic kernel now. Will see if this fixes the problem.
Great. Give it a few days.

At the moment, due to Spectre and Meltdown, kernel updates are coming thick and fast, and the rush to fix those vulnerabilities (if possible) is causing occasional regressions in those updated kernels. It may be that in the end you can skip 4.13.0-32 and that 4.13.0-33 will have corrected any regression and will work well with your hardware. We'll just have to see how it pans out.
 
Old 01-30-2018, 04:03 PM   #19
Thane
Member
 
Registered: Aug 2006
Location: Ontario,Canada
Distribution: Linux Mint18 Cinnamon 64bit
Posts: 200

Original Poster
Rep: Reputation: Disabled
Thanks so much! Will report back in a few days with feedback. cheers
 
Old 02-05-2018, 07:33 AM   #20
Thane
Member
 
Registered: Aug 2006
Location: Ontario,Canada
Distribution: Linux Mint18 Cinnamon 64bit
Posts: 200

Original Poster
Rep: Reputation: Disabled
Lockups seem to be under control again with previous kernel

Your idea of utilizing the previous 4.13.0-31 kernel rather than what was the newer 4.13.0-32 kernel, appears to have done the trick over the last 6 days hydrurga. A number of reboots and no reoccurances of lockups. Over the first 4 days I didn't install any other updates, so as not to cloud the issue. For the last two days my desktop machine has been running continually with firefox, google chrome, thunderbird, libre office writer running and also win 10 running in virtualbox (just to give Mint a good chance to crash.) Also over the last two days all Win 10 updates have been installed and all non-kernal recommended updates for Mint 18.3 64bit. Fingers crossed, but it looks like the problem may have been solved again. Thank you.
 
Old 02-05-2018, 08:23 AM   #21
hydrurga
LQ Guru
 
Registered: Nov 2008
Location: Pictland
Distribution: Linux Mint 19 MATE
Posts: 5,253
Blog Entries: 2

Rep: Reputation: 1707Reputation: 1707Reputation: 1707Reputation: 1707Reputation: 1707Reputation: 1707Reputation: 1707Reputation: 1707Reputation: 1707Reputation: 1707Reputation: 1707
Great to hear, Thane. Hopefully it is indeed a regression in the kernel that will be sorted in a future version.
 
Old 02-13-2018, 06:18 PM   #22
Thane
Member
 
Registered: Aug 2006
Location: Ontario,Canada
Distribution: Linux Mint18 Cinnamon 64bit
Posts: 200

Original Poster
Rep: Reputation: Disabled
Looks like a fix on kernel

Now over a week and not one incidence of a lockup. Still using the 4.13.0-31 kernel. Looks good. Thanks again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to get latest version of the R language on Linux Mint 17.3 Cinnamon 64bit? grumpyskeptic Linux - Software 3 07-13-2016 03:34 AM
No GRUBbootloader to choose os when starting pc - linux mint cinnamon 64bit fresh install wiegetz Linux - Software 2 05-19-2016 10:32 PM
Kernel panic after installing Linux Mint 17.2 64bit Cinnamon etta Linux - Laptop and Netbook 14 12-04-2015 12:20 AM
Ultimate Linux MINT -Cinnamon- 64bit super_tux Linux Mint 1 09-03-2014 04:39 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux Mint

All times are GMT -5. The time now is 07:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration