LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 03-22-2019, 07:20 AM   #1
carlitoco
Member
 
Registered: Jan 2008
Location: Berlin
Distribution: Slackware / Arch
Posts: 142

Rep: Reputation: 15
Exclamation Apache: wordpress only avail with <Location />


Hey I've a strange issue, since I just changed my hardware to a new and configured arch server with wordpress, nextcloud, collabora online office-

there is a proxy for collabora office domain :
Everything else is as https://wiki.archlinux.org discribes LAMP php wordpress nextcloud etc..

now the issue Wordpress is only available with a:
Code:
<Location />
  require all granted
</Location>
on its VHost *:443 the problem is that the wordpress pages and post still not able to load (404 Error).
I guessed it has to be a problem of permissions but what can I do wrong on:

Code:
<Directory "/usr/share/webapps/wordpess">
        Options FollowSymlinks MultiViews
        AllowOverride All
        Require all granted
        php_admin_value open_basedir "/srv/:/tmp/:/usr/share/webapps/:/etc/webapps:$"
</Directory>
I read somewhere mod_Proxy needs a <Location /> but the wordpress domain I use is the first server domain...

Any Ideas?

Last edited by carlitoco; 03-22-2019 at 08:56 AM.
 
Old 03-22-2019, 09:23 AM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,505

Rep: Reputation: 1769Reputation: 1769Reputation: 1769Reputation: 1769Reputation: 1769Reputation: 1769Reputation: 1769Reputation: 1769Reputation: 1769Reputation: 1769Reputation: 1769
Quote:
the problem is that the wordpress pages and post still not able to load (404 Error).
You should check the apache error_log to see where is apache looking for the wordpress files and not finding them, thus giving the 404 error.

FYI the docroot in Arch is /srv/http. Are you sure you've installed wordpress under /usr/share/webapps/wordpess?
 
Old 03-22-2019, 09:31 AM   #3
carlitoco
Member
 
Registered: Jan 2008
Location: Berlin
Distribution: Slackware / Arch
Posts: 142

Original Poster
Rep: Reputation: 15
The location is "native" for the arch package yes... arch is installing webapps there aswell like nextcloud, matomo, phpmyadmin etc...

the log shows only:
Code:
xxx.xxx.xxx.xxx - - [22/Mar/2019:15:30:49 +0100] "GET /install-arch-linux/ HTTP/1.1" 404 1089
 
Old 03-22-2019, 09:45 AM   #4
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,505

Rep: Reputation: 1769Reputation: 1769Reputation: 1769Reputation: 1769Reputation: 1769Reputation: 1769Reputation: 1769Reputation: 1769Reputation: 1769Reputation: 1769Reputation: 1769
Quote:
Originally Posted by carlitoco View Post
The location is "native" for the arch package yes... arch is installing webapps there aswell like nextcloud, matomo, phpmyadmin etc...

the log shows only:
Code:
xxx.xxx.xxx.xxx - - [22/Mar/2019:15:30:49 +0100] "GET /install-arch-linux/ HTTP/1.1" 404 1089
This is apache accees_log.
You should look at the apache error_log, which contains the full path to the non existent page
 
Old 03-22-2019, 12:05 PM   #5
carlitoco
Member
 
Registered: Jan 2008
Location: Berlin
Distribution: Slackware / Arch
Posts: 142

Original Poster
Rep: Reputation: 15
Loglevel is warn but no error in error_log, was the first thing I checked...
 
Old 03-22-2019, 12:19 PM   #6
scasey
Senior Member
 
Registered: Feb 2013
Location: Tucson, AZ, USA
Distribution: CentOS 7.6
Posts: 3,292

Rep: Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109
What does
Code:
ls -l /usr/share/webapps/wordpess/install-arch-linux/
show. That is, what's in that directory?

Also, I don't find a VHost directive in the documentation...did you mean VirtualHost ?
 
Old 03-22-2019, 12:33 PM   #7
carlitoco
Member
 
Registered: Jan 2008
Location: Berlin
Distribution: Slackware / Arch
Posts: 142

Original Poster
Rep: Reputation: 15
loglevel on debug helps...
Code:
[Fri Mar 22 18:08:52.440818 2019] [core:info] [pid 3120] [client xxx] AH00128: File does not exist: /usr/share/webapps/wordpress/installing_archlinux/
Its a wordpress page with permalink option in wp.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache: Wordpress only avail with <Location /> carlitoco Linux - Server 1 03-22-2019 07:25 AM
LXer: Google I/O Android News: Location, Location, Location (Plus Cloud Messaging and Bluetooth) LXer Syndicated Linux News 0 06-05-2013 01:00 PM
[SOLVED] Ubuntu 11.10 has a read-only file system. Been trying to recover password to no avail xric Linux - Newbie 1 11-09-2012 06:58 PM
-clear-avail and --merge-avail meks-r Debian 0 04-28-2005 02:14 PM
location, location, location! mermxx LQ Suggestions & Feedback 9 09-25-2004 03:08 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 08:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration