LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > CentOS
User Name
Password
CentOS This forum is for the discussion of CentOS Linux. Note: This forum does not have any official participation.

Notices


Reply
  Search this Thread
Old 07-13-2019, 12:04 AM   #1
Turbocapitalist
Senior Member
 
Registered: Apr 2005
Distribution: Linux Mint, Devuan, OpenBSD
Posts: 4,012
Blog Entries: 3

Rep: Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914
Certbot installation fails on CentOS 7 due to broken dependencies


I'm looking at CentOS 7 and see that certbot is in the EPEL repository. However, when I go to install it, the installation fails because it is insisting on specific, outdated versions of several packages. Here is one:

Code:
Error: Package: policycoreutils-python-2.5-17.1.el7.x86_64 (base)
           Requires: policycoreutils = 2.5-17.1.el7
           Installed: policycoreutils-2.5-22.el7.x86_64 (@base)
I have not used CentOS or its predecessors very much over the decades due to this kind of thing. What is the best and/or easiest way to resolve the dependency conflict?
 
Old 07-13-2019, 07:34 PM   #2
scheidel21
Senior Member
 
Registered: Feb 2003
Location: CT
Distribution: Debian 6+, CentOS 5+
Posts: 1,323

Rep: Reputation: 99
Try installing the older version of the utilities by specifying the package name in yum https://linoxide.com/linux-how-to/in...rhel-centos-7/ it might install along side the new or you might have to uninstall the newer and install the older version
 
Old 07-13-2019, 09:42 PM   #3
Turbocapitalist
Senior Member
 
Registered: Apr 2005
Distribution: Linux Mint, Devuan, OpenBSD
Posts: 4,012

Original Poster
Blog Entries: 3

Rep: Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914
Quote:
Originally Posted by scheidel21 View Post
Try installing the older version of the utilities by specifying the package name in yum https://linoxide.com/linux-how-to/in...rhel-centos-7/ it might install along side the new
The old versions are rejected by the system, for example:

Code:
# yum install policycoreutils-2.5-17.1.el7
...
Package matching policycoreutils-2.5-17.1.el7.x86_64 already installed. Checking for update.
Nothing to do


# yum list policycoreutils
...
Installed Packages
policycoreutils.x86_64                     2.5-22.el7                      @base
So I'm not seeing a way to install the old versions side-by-side with the old ones.

Quote:
Originally Posted by scheidel21 View Post
or you might have to uninstall the newer and install the older version
Except that there are other packages present which depend on the newer versions. Time for an APT-based distro?

Last edited by Turbocapitalist; 07-13-2019 at 09:54 PM. Reason: yum list ...
 
Old 07-13-2019, 10:36 PM   #4
scasey
Senior Member
 
Registered: Feb 2013
Location: Tucson, AZ, USA
Distribution: CentOS 7.6
Posts: 3,215

Rep: Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104
Just to confirm: youíre getting the error in the OP when you ran
Code:
yum install certbot python2-certbot-apache
as root?
Can you tell which package is throwing the error?
 
Old 07-13-2019, 11:04 PM   #5
Turbocapitalist
Senior Member
 
Registered: Apr 2005
Distribution: Linux Mint, Devuan, OpenBSD
Posts: 4,012

Original Poster
Blog Entries: 3

Rep: Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914
Yes, as root.

Code:
# whoami 
root

# yum install certbot
. . .
Error: Package: policycoreutils-python-2.5-17.1.el7.x86_64 (base)
           Requires: policycoreutils = 2.5-17.1.el7
           Installed: policycoreutils-2.5-22.el7.x86_64 (@base)
               policycoreutils = 2.5-22.el7
           Available: policycoreutils-2.5-17.1.el7.x86_64 (base)
               policycoreutils = 2.5-17.1.el7
Error: Package: audit-libs-python-2.7.6-3.el7.x86_64 (base)
           Requires: audit-libs(x86-64) = 2.7.6-3.el7
           Installed: audit-libs-2.8.1-3.el7.x86_64 (@base)
               audit-libs(x86-64) = 2.8.1-3.el7
           Available: audit-libs-2.7.6-3.el7.x86_64 (base)
               audit-libs(x86-64) = 2.7.6-3.el7
. . .
 
Old 07-13-2019, 11:17 PM   #6
ehartman
Member
 
Registered: Jul 2007
Location: Delft, The Netherlands
Distribution: Slackware
Posts: 672

Rep: Reputation: 317Reputation: 317Reputation: 317Reputation: 317
Quote:
Originally Posted by Turbocapitalist View Post
I have not used CentOS or its predecessors very much over the decades due to this kind of thing. What is the best and/or easiest way to resolve the dependency conflict?
Get in contact with the author of the package, it seems the one in epel is for an older version of RHEL/CentOS 7, for which there have been 6 point-updates already (so the current one is 7.6 and does have minor version updates in its packages from the original release).
 
Old 07-13-2019, 11:59 PM   #7
scasey
Senior Member
 
Registered: Feb 2013
Location: Tucson, AZ, USA
Distribution: CentOS 7.6
Posts: 3,215

Rep: Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104
So certbot is throwing the error...what happens with
Code:
yum install python2-certbot-apache
??
 
Old 07-14-2019, 12:00 AM   #8
Turbocapitalist
Senior Member
 
Registered: Apr 2005
Distribution: Linux Mint, Devuan, OpenBSD
Posts: 4,012

Original Poster
Blog Entries: 3

Rep: Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914
More or less the same happens when running "yum install python2-certbot-apache"

Code:
Error: Package: policycoreutils-python-2.5-17.1.el7.x86_64 (base)
           Requires: policycoreutils = 2.5-17.1.el7
           Installed: policycoreutils-2.5-22.el7.x86_64 (@base)
               policycoreutils = 2.5-22.el7
           Available: policycoreutils-2.5-17.1.el7.x86_64 (base)
               policycoreutils = 2.5-17.1.el7
Error: Package: audit-libs-python-2.7.6-3.el7.x86_64 (base)
           Requires: audit-libs(x86-64) = 2.7.6-3.el7
           Installed: audit-libs-2.8.1-3.el7.x86_64 (@base)
               audit-libs(x86-64) = 2.8.1-3.el7
           Available: audit-libs-2.7.6-3.el7.x86_64 (base)
               audit-libs(x86-64) = 2.7.6-3.el7
 
Old 07-14-2019, 12:03 AM   #9
scasey
Senior Member
 
Registered: Feb 2013
Location: Tucson, AZ, USA
Distribution: CentOS 7.6
Posts: 3,215

Rep: Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104
OK
Then see #6 or maybe compile from source...sorry I canít help more.
 
  


Reply

Tags
certbot


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Letsencrypt certbot Panicked Linux - Server 4 06-13-2017 06:10 PM
LXer: Secure your webserver with improved Certbot LXer Syndicated Linux News 0 05-26-2017 10:01 AM
[SOLVED] Bundle SSL certificates with LetsEncrypt/Certbot? kikinovak Slackware 1 03-14-2017 07:58 AM
LXer: Using certbot to secure your personal site LXer Syndicated Linux News 0 02-23-2017 02:01 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > CentOS

All times are GMT -5. The time now is 09:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration