LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-05-2019, 12:50 AM   #1
sormazi
LQ Newbie
 
Registered: Jan 2019
Posts: 11

Rep: Reputation: Disabled
Can't boot OS from SSD


I installed Deepin 15.8 on my new SSD ( WD Green 120GB). When I try to boot it gives me the following:
Code:
error: attempt to read or write outside of disk hd0
error: please load kernel first
press any button to continue
pressing any button takes me back to the bootloader screen and the OS doesn't boot. I also have Deepin installed on my HDD ( Seagate 1TB) and it works perfectly fine on that. I have changed the bootloader order in my BIOS to boot the SSD first. I bought the SSD today. Please help!
 
Old 01-05-2019, 07:25 PM   #2
berndbausch
Senior Member
 
Registered: Nov 2013
Location: Tokyo
Distribution: A few
Posts: 4,957

Rep: Reputation: 1480Reputation: 1480Reputation: 1480Reputation: 1480Reputation: 1480Reputation: 1480Reputation: 1480Reputation: 1480Reputation: 1480Reputation: 1480
Did you search the error string(s)?

For example, this looks like it might be helpful: What to do when I get an “attempt to read or write outside of disk 'hd0'” error and Boot Repair does not solve the problem?. It's not the only search hit, though; other hits may fit your particular situation better.

Last edited by berndbausch; 01-05-2019 at 07:26 PM.
 
Old 01-06-2019, 01:35 PM   #3
sormazi
LQ Newbie
 
Registered: Jan 2019
Posts: 11

Original Poster
Rep: Reputation: Disabled
I did. Unfortunately, Deepin doesn't have a try Deepin option in the installer. I tried installing Manjaro Gnome too but that failed as well.
 
Old 01-06-2019, 04:23 PM   #4
berndbausch
Senior Member
 
Registered: Nov 2013
Location: Tokyo
Distribution: A few
Posts: 4,957

Rep: Reputation: 1480Reputation: 1480Reputation: 1480Reputation: 1480Reputation: 1480Reputation: 1480Reputation: 1480Reputation: 1480Reputation: 1480Reputation: 1480
Quote:
Originally Posted by sormazi View Post
I did. Unfortunately, Deepin doesn't have a try Deepin option in the installer.
The ask.ubuntu.com question has more than one answer. And there are more search hits.
Quote:
I tried installing Manjaro Gnome too but that failed as well.
It seems to me that the installers (or the human installer ) create partitions that don't fit the SSD. Have you tried manual partitioning?
 
Old 01-07-2019, 05:26 AM   #5
zeebra
Member
 
Registered: Dec 2011
Distribution: Mageia, Slackware
Posts: 848
Blog Entries: 9

Rep: Reputation: 210Reputation: 210Reputation: 210
Quote:
Originally Posted by berndbausch View Post
It seems to me that the installers (or the human installer ) create partitions that don't fit the SSD. Have you tried manual partitioning?
Always, always use custom/manual disk partitioning, unless:
- You are a newbie, and you know what you are doing by not using manual/custom partitioning
- You are a newbie and have never used GNU/Linux and you have no important data on any disks and can use all space on all disks

Anyways, threadstarter, there is nothing special about that disk, it should work easily and without any issues, unless there is something wrong with the disk itself, or the user of the disk is doing something wrong.

The issue you describe however seems to be a misconfigured boot loader. Don't change the boot order in the bios unless you know the consequence of doing so. GRUB needs correct configurations of hd0 and hd1. If you changed the boot order in the bios after configuring GRUB, this is probably the reason for the issue. It thinks hd1 is hd0 or something. If you changed the boot order prior to configuring grub, something is misconfigured.

In any case, you can solve this issue by reconfiguring GRUB. If you want more help, you need to be more specific.. What version grub do you have? How did you install it? Why/when did you change the disk boot order? What type of computer is it? On which sata port is disk 1 and disk 2 connected etc etc.
 
Old 01-07-2019, 05:09 PM   #6
jefro
Moderator
 
Registered: Mar 2008
Posts: 20,018

Rep: Reputation: 3145Reputation: 3145Reputation: 3145Reputation: 3145Reputation: 3145Reputation: 3145Reputation: 3145Reputation: 3145Reputation: 3145Reputation: 3145Reputation: 3145
Suggestion maybe.

Remove all drives other than ssd. Boot to bios and verify that the ssd is listed in hard drive.

Then try install again.

When finished and hopefully it works you can then return any other drives.
 
Old 01-09-2019, 07:24 AM   #7
sormazi
LQ Newbie
 
Registered: Jan 2019
Posts: 11

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by zeebra View Post
Always, always use custom/manual disk partitioning, unless:
- You are a newbie, and you know what you are doing by not using manual/custom partitioning
- You are a newbie and have never used GNU/Linux and you have no important data on any disks and can use all space on all disks

Anyways, threadstarter, there is nothing special about that disk, it should work easily and without any issues, unless there is something wrong with the disk itself, or the user of the disk is doing something wrong.

The issue you describe however seems to be a misconfigured boot loader. Don't change the boot order in the bios unless you know the consequence of doing so. GRUB needs correct configurations of hd0 and hd1. If you changed the boot order in the bios after configuring GRUB, this is probably the reason for the issue. It thinks hd1 is hd0 or something. If you changed the boot order prior to configuring grub, something is misconfigured.

In any case, you can solve this issue by reconfiguring GRUB. If you want more help, you need to be more specific.. What version grub do you have? How did you install it? Why/when did you change the disk boot order? What type of computer is it? On which sata port is disk 1 and disk 2 connected etc etc.
I changed the boot order to my SSD first and then my HDD. It didn't boot up and I got a blinking cursor on a black screen.
I tried installing an OS other than Deepin on the SSD. (In this case, Ubuntu Budgie 18.10)
I rearranged my boot order to my HDD first and then my SSD. On booting, it gave the grub rescue screen. I located the disk using ls and used insmod normal>normal which led me to the bootloader with the following options:
Ubuntu 18.10
Advanced options for Ubuntu 18.10
memsafe test
Deepin 15.8 (on /dev/sda)
Advanced options on Deepin 15.8

I went to advanced options for Ubuntu 18.10 and launched recovery mode. It gave me this screen and did not continue further.
https://imgur.com/a/JGBjEgS

sda is the Seagate HDD
sdb is the WD SSD

I have Deepin installed on sda which works fine. As for grub version, I installed the one that came with the Deepin update, I'm guessing grub2. (How do I check my version of grub?)
The computer is a Lenovo Ideapad-100. I don't have any valuable data on the computer
 
Old 01-09-2019, 07:25 AM   #8
sormazi
LQ Newbie
 
Registered: Jan 2019
Posts: 11

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by berndbausch View Post
The ask.ubuntu.com question has more than one answer. And there are more search hits.

It seems to me that the installers (or the human installer ) create partitions that don't fit the SSD. Have you tried manual partitioning?
I tried manual partitioning on the Deepin installer but the installer fails when I do that.
 
Old 01-09-2019, 07:26 AM   #9
sormazi
LQ Newbie
 
Registered: Jan 2019
Posts: 11

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by jefro View Post
Suggestion maybe.

Remove all drives other than ssd. Boot to bios and verify that the ssd is listed in hard drive.

Then try install again.

When finished and hopefully it works you can then return any other drives.
I will try that, thank you for your suggestion.
 
Old 01-09-2019, 08:27 AM   #10
sormazi
LQ Newbie
 
Registered: Jan 2019
Posts: 11

Original Poster
Rep: Reputation: Disabled
UPDATE:

I installed Deepin again onto my SSD, this time, using partitioning. I booted it up and it booted successfully from the SSD. I went to gparted and deleted the OS installed on my HDD and formated it to fat 32. Then I opened the terminal and configured grub using these commands:

</CODE>sudo grub-install --recheck /dev/sda
sudo grub-install --recheck /dev/sdb
sudo grub-mkconfig -o /boot/grub/grub.cfg</CODE>

Then I restarted my computer and recieved the same error as I did earlier:
</CODE>error: attempt to read or write outside of disk hd1
error: please load kernel first</CODE>
 
Old 01-09-2019, 09:00 AM   #11
zeebra
Member
 
Registered: Dec 2011
Distribution: Mageia, Slackware
Posts: 848
Blog Entries: 9

Rep: Reputation: 210Reputation: 210Reputation: 210
Quote:
Originally Posted by sormazi View Post
I changed the boot order to my SSD first and then my HDD. It didn't boot up and I got a blinking cursor on a black screen.
I tried installing an OS other than Deepin on the SSD. (In this case, Ubuntu Budgie 18.10)
I rearranged my boot order to my HDD first and then my SSD. On booting, it gave the grub rescue screen. I located the disk using ls and used insmod normal>normal which led me to the bootloader with the following options:
Ubuntu 18.10
Advanced options for Ubuntu 18.10
memsafe test
Deepin 15.8 (on /dev/sda)
Advanced options on Deepin 15.8

I went to advanced options for Ubuntu 18.10 and launched recovery mode. It gave me this screen and did not continue further.
https://imgur.com/a/JGBjEgS

sda is the Seagate HDD
sdb is the WD SSD

I have Deepin installed on sda which works fine. As for grub version, I installed the one that came with the Deepin update, I'm guessing grub2. (How do I check my version of grub?)
The computer is a Lenovo Ideapad-100. I don't have any valuable data on the computer
Alright, so, to get you right, you have two disks inside your laptop? One that came with the laptop and one that you put in yourself?

Or is it a fact that the second disk (ssd?) is connected through USB?

1. Stop changing around the boot order in the bios, this will mess up the bootloader and give you such issues that you experience. Keep it the way it is. If you want to boot of another disk (unless you have two disks inside), then do this with the F12 boot option menu instead.

The grub version should display before booting, but only briefly. It should probably also say if you press "e" when you are in the bootloader, or even in the headline of the bootloader without pressing anything.

Without the correct info, and with you messing around with boot orders and disk orders etc, it will be very difficult to solve this issue at all. So don't panic! Just keep things a bit stable, and then deal with that. Bootloaders and disk orders can be a bit tricky, and any changes in that can have a dramatic effect (not being able to boot, no bootloader etc).

So, let's take it one step at a time.

How exactly are the disks set up, how are they connected, and what disk order is the bios in currently?

Where have you installed your bootloader? (which disk)
What bootloader and version is it? Through which distro did you install it?
You say BIOS, but does that mean bios or is it in fact UEFI?
If it is UEFI, are you using legacy BIOS option?
If using UEFI but not legacy BIOS, what UEFI settings do you have on/off?

Is there a specific reason you want to install "Deepin" as your distro?
 
Old 01-09-2019, 10:27 AM   #12
sormazi
LQ Newbie
 
Registered: Jan 2019
Posts: 11

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by zeebra View Post
Alright, so, to get you right, you have two disks inside your laptop? One that came with the laptop and one that you put in yourself?

Or is it a fact that the second disk (ssd?) is connected through USB?

1. Stop changing around the boot order in the bios, this will mess up the bootloader and give you such issues that you experience. Keep it the way it is. If you want to boot of another disk (unless you have two disks inside), then do this with the F12 boot option menu instead.

The grub version should display before booting, but only briefly. It should probably also say if you press "e" when you are in the bootloader, or even in the headline of the bootloader without pressing anything.

Without the correct info, and with you messing around with boot orders and disk orders etc, it will be very difficult to solve this issue at all. So don't panic! Just keep things a bit stable, and then deal with that. Bootloaders and disk orders can be a bit tricky, and any changes in that can have a dramatic effect (not being able to boot, no bootloader etc).

So, let's take it one step at a time.

How exactly are the disks set up, how are they connected, and what disk order is the bios in currently?

Where have you installed your bootloader? (which disk)
What bootloader and version is it? Through which distro did you install it?
You say BIOS, but does that mean bios or is it in fact UEFI?
If it is UEFI, are you using legacy BIOS option?
If using UEFI but not legacy BIOS, what UEFI settings do you have on/off?

Is there a specific reason you want to install "Deepin" as your distro?
Hi, thanks for replying,
1. No. of disks: 2 disks are set up, a Seagate 1TB HDD (sda) that came with the laptop and a WD Green 128GB SSD which I replaced the DVD drive with.
2. Bootloader location: The bootloader is set up in /dev/sdb
3. BIOS or UEFI: Please check the adjoint link, I'm not really familiar in distinguishing the UEFI from the BIOS
https://imgur.com/a/ROKRwEu
4. Legacy BIOS option: Yes, I'm using the legacy BIOS option. Also, please refer to the above link so that you can double-check.
5. UEFI settings: How do I check the UEFI settings?

Not really, I was using Manjaro with the Deepin Desktop Environment earlier, and though I'd just switch the original distro. Really liked it, but I'm willing to switch, if I can just install ANY OS into this SSD.

My current boot order is:
HDD
SSD

UPDATE: I'm currently running e2fsck -a /dev/sdb1 to repair my boot partition using a Manjaro live disc

Last edited by sormazi; 01-09-2019 at 10:32 AM.
 
Old 01-09-2019, 02:04 PM   #13
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida panhandle
Distribution: slackware64-current, fedora,Xubuntu, others
Posts: 4,491

Rep: Reputation: 800Reputation: 800Reputation: 800Reputation: 800Reputation: 800Reputation: 800Reputation: 800
Quote:
UEFI settings: How do I check the UEFI settings?
If your booting in efi mode you will have a /sys/firmware/efi folder.
are the disk partition tables msdos or gpt? to install the grub bootloader on a gpt disk legacy mode you need a 1-2 mb partition flagged as bios-grub. For efi mode need about 300mb partition formatted as fat32 flagged as esp for both msdos and gpt.

Last edited by colorpurple21859; 01-09-2019 at 02:09 PM.
 
Old 01-10-2019, 05:03 AM   #14
sormazi
LQ Newbie
 
Registered: Jan 2019
Posts: 11

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by colorpurple21859 View Post
If your booting in efi mode you will have a /sys/firmware/efi folder.
are the disk partition tables msdos or gpt? to install the grub bootloader on a gpt disk legacy mode you need a 1-2 mb partition flagged as bios-grub. For efi mode need about 300mb partition formatted as fat32 flagged as esp for both msdos and gpt.
The disk partition tables are msdos. I already have Grub 2.022 beta installed.
 
Old 01-10-2019, 07:16 AM   #15
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida panhandle
Distribution: slackware64-current, fedora,Xubuntu, others
Posts: 4,491

Rep: Reputation: 800Reputation: 800Reputation: 800Reputation: 800Reputation: 800Reputation: 800Reputation: 800
what is the output of
Code:
parted -l
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Install Linux in Toshiba u940 series with 32gb ssd and 750gb hdd I would like to have boot code in ssd only cvkchary Linux - Laptop and Netbook 4 08-31-2016 04:26 PM
[SOLVED] I have a SSD a 500GB drive and a 2TB drive and want to move Ubuntu from 500GB to SSD greatormesby Linux - Newbie 12 07-06-2015 09:58 AM
To SSD or not to SSD jlinkels Linux - Hardware 14 10-02-2012 07:36 AM
SSD raid1 vs SSD raid10 advice ? wonker Linux - Hardware 8 05-23-2012 01:46 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration