LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   kernel 2.6: slow internet (https://www.linuxquestions.org/questions/linux-networking-3/kernel-2-6-slow-internet-151050/)

cidrolin 08-31-2004 08:40 AM

Have a look to my last contribution to
this post and check which sub-version your 2.6 kernel is...

alberto2498 08-31-2004 03:03 PM

The final way for me to actually turn the darn thing back to IPv4 was by changing the line:

alias net-pf-10 IPv6 ----> alias net-pf-10 IPv4

The file in wich you find that is "modules.alias", usually located in:

/lib/modules/2.6.something/

If you cant find it just locate the file.

dkroft 09-15-2004 03:57 PM

i have been seeing this for a long time -
posted several times, but no good answer yet.

i disabled ipv6 altogether:

/etc/modprobe.conf
alias ipv6 off
alias net-pf-10 off

use both lines - you'll need them

alberto2498 09-16-2004 01:01 PM

Go to post # 47
 
Quote:

Originally posted by dkroft
i have been seeing this for a long time -
posted several times, but no good answer yet.

i disabled ipv6 altogether:

/etc/modprobe.conf
alias ipv6 off
alias net-pf-10 off

use both lines - you'll need them

http://www.linuxquestions.org/questi...47#post1146047

littleking 09-16-2004 03:35 PM

The quick fix is to su to root and do two things:

#echo "net.ipv4.tcp_moderate_rcvbuf=0" >> /etc/sysctl.conf
#echo "net.ipv4.tcp_default_win_scale=0" >> /etc/sysctl.con

dkroft 09-16-2004 04:30 PM

TCP Window size
 
If I include the sysctl statements, will that allow me to undo the /etc/modprobe additions, . . .

So . . . ( I am hesitant to ask ) . . . will I have IPv6 access?

emeskay 09-16-2004 05:27 PM

I just installed SuSE 9.1 yesterday (as a stand alone system). I used it for a while and I did notice that web page downloads were discernably slower than I was used to on my Windows NT installation. (I have a cable connection (through a hardware router), so I'm used to virtually instantaneous downloads).

The more interesting thing is - when I rebooted into NT and started up a browser, I found that download speeds were distinctly slower even there. This happens with any browser - Opera, Mozilla, IE. It is also the case with Outlook Express. Moreover the download is not as smooth as it used to be - a lot more jerky. It also seems to affect mouse movement when downloading - it is almost as if the mouse is getting a very low priority - with all the processor cycles being taken up by the data transfer. If I try to move the mouse while any transfer is taking place, the movement is very jumpy - a very unnerving effect.

Since this started happening soon after the Linux install, I can only conclude that it was caused by it. Could it have anything to do with some BIOS setting (or maybe a setting on the router?) - changed by the Linux Kernel during installation - because those are the only two connections I can think of between the two OS's.

emeskay 09-17-2004 03:03 AM

Turned out that it was the ACPI (Advanced Configuration and Power Interface - which presumably had been enabled during installation) that was causing the problem. For whatever reason, when ACPI is enabled, some IRQ's need to be re-routed via PCI bus (not that I really understand what that means - that was what was recorded in the Linux Startup Log. I assume NT needed to do the same). I think that was causing the mouse, keyboard, network card and video card to compete for resources which was causing the behaviour I described in NT.

Turning off ACPI in the BIOS solved the problem. Now I need to find a way to get Linux to turn it on when booting up and turn it off while shutting down. Any way to accomplish this? Thanks.

Cybersurfer 11-13-2004 05:47 PM

Possible solution
 
I was experiencing similar problems.

In my case I found that when using kernel 2.4, I had the Network Configuration set to Automatically obtain DNS information from provider and that was all that was required.

However I found with kernel 2.6 it is not quite that simple, I had to input the following info into the Network Configuration , as obtained from my ISP:

Primary DNS
Secondary DNS
Tertiary DNS

After doing the above, I had speed again :)

I am using Fedora Core 2

Ensure that Automatically obtain DNS information from provider is not selected
To do this go to
> System Settings
> Network
> select Device
> Edit
> General tab

Hope this helps

exvor 11-13-2004 06:05 PM

Yes indeed I have had the internet slow down bull S$it in fadora.

Its cool to see someone figured it out I gave up real soon on it tho. and went to slack where i had to make a kernel my self and never had this issue.



Like I say now that I know better " If it dont work right remake the kernel your self" :)

qwijibow 11-13-2004 08:15 PM

it seems they went back to the old TCP/IP window size in the latest (2.6.9) kernel.


All times are GMT -5. The time now is 05:13 PM.