LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   kernel 2.6: slow internet (https://www.linuxquestions.org/questions/linux-networking-3/kernel-2-6-slow-internet-151050/)

alxdotnet 04-06-2004 11:35 PM

Quote:

Originally Posted by janW
I do have a firewall set up. And knowing next to nothing about firewall configuration I can easily believe that something's wrong there. Other than that, I'm not using a router on my end. I don't know if my ISP has maybe troubles with IPv6?

Whether you're using a router is unimportant...some firewalls throw away the IPv6 packet, probably because they don't know what the heck it is. It's also very logical that your ISP's firewall might be behind things, though I would expect they would have upgraded long ago.

Quote:

Originally Posted by dePOLL
Btw, a "ipv6" module is loaded: 'ipv6 232352 10'
Dunno if this is important..

I think it is important...

As far as I can recall this is what I did:
1) Added "alias" line to /etc/modules.conf
2) Rebooted. I remember this didn't help
3) Changed DHCP client several times
4) Rebooted again. Blazing fast.

Anyway, this is a strange problem and should probably be submitted as a kernel bug if it already hasn't been taken care of (in 2.6.5, if I recall correctly).

dePOLL 04-07-2004 08:02 AM

Just returned to my 2.4 Kernel. I don't really need any of the newer features so this is no big deal.. Anyway, somehow it bugs me, but I'm just too lazy to invest hours in solving this problem. Thanks anyway.

techmetal 04-07-2004 08:32 AM

I have the same DNS problems but only with Lynx (I want to use Lynx!). I haven't checked with Firefox if it does IPv6 DNS requests but it seems to work fine and fast.

Someone in my local Linux user group suggested commenting out all IPv6 lines in /etc/hosts file. It didn't work for me but it could be worth trying out for the others.

Among the things I have tried unsuccessfully:
- alias net-pf-10 off in /etc/modules.conf
- disabling IPv6 support in the kernel

I'll try greping the 2.6.5 kernel changelog file to see if this is a resolved (no pun intended) issue. And maybe compile it. Anybody have other suggestions ?

moosedaddy 04-07-2004 09:33 AM

I fixed my problem, I checked the router and the firmware was set to limit the wan port to 10Mbit. I upgraded the firmware and enabled ipv6, I can now surf as fast as I was with the 2.4.X kernel.

alxdotnet 04-09-2004 02:30 AM

Problem - Solved!

Hey all, found the fix. Add:
Code:

alias net-pf-10 off
to /etc/modprobe.conf, which replaces /etc/modules.conf in 2.6 kernel.
Cheers!
-Alex

Concillian 04-09-2004 01:20 PM

For what it's worth, I just saw this thread and I never had any problems like this with Mandrake 10.0 rc2 or 10.0 community running the 2.6 kernel.

My configuration:
10.0 community running 2.6.3
on board 10/100 3c905 for connection to DSL modem
Intel gigabit card for my home network
Used the Mandrake Control Center ICS 'wizard' to provide IP forwarding and firewall with the linux box.

Static IPs both to my ISP and on the home network.

I didn't have to do any manual configuations at all for the TCP/IP networking, just used the GUI tools available in harddrake and the MCC.

I never noticed any delays on DNS lookups from either the linux box, or any of the Windows boxes connected through the linux box.

alxdotnet 04-09-2004 06:26 PM

Quote:

Originally Posted by Concillian
I never noticed any delays on DNS lookups from either the linux box, or any of the Windows boxes connected through the linux box.

Yes, you have an IPv6-aware ISP and IPv6 aware clients, you wouldn't notice anything. The problem is that some routers/firewalls/stoneage ISPs block v6 packets from ever reaching the public internet, so DNS lookups have to time-out on v6 before the v4 packet is sent.

alberto2498 04-11-2004 03:26 AM

Quote:

Originally posted by alxdotnet
Problem - Solved!

Hey all, found the fix. Add:
Code:

alias net-pf-10 off
to /etc/modprobe.conf, which replaces /etc/modules.conf in 2.6 kernel.
Cheers!
-Alex

I just did this, although I did changes for /etc/modules.conf as well as /etc/modprobe.conf and everything is working as before.

Thank you to you all, this is just great.

Alberto

Rnd227 04-11-2004 12:48 PM

Did this too, and although it greatly improved the situation, (I don't wait 20 secs anymore), I still wait around 5 seconds just for resolution...

So it's only a partial solution for me. Any ideas ?

silvercastle 04-14-2004 10:39 PM

Quote:

Originally posted by alxdotnet
Problem - Solved!

Hey all, found the fix. Add:
Code:

alias net-pf-10 off
to /etc/modprobe.conf, which replaces /etc/modules.conf in 2.6 kernel.
Cheers!
-Alex

...cool...thanx for that...I did this, and I changed modules.conf the same way...adsl faster now...:cool: :Pengy:

humbabba 04-22-2004 06:47 PM

adding the line to modprobe.conf really helped me with this problem. It had been driving me up the wall!

for some reason I am not sure if browsing speed is what it should be, but there is a definate improvement.

peterchao 08-08-2004 03:40 PM

I modify the /etc/modprobe.conf and the browser now faster, but please try this....
Ping an url (Ex. "ping www.apache.org" very slow), ping the ip of the url (Ex. 209.237.227.195) very fast..
Is any same as me....

Dinabandhu 08-16-2004 12:29 AM

Quote:

Originally posted by Stevetgn
I have a problem with very slow browser reaction.
Click a link and it takes for ever to go to that page let alone load the page. Its the same problem with Konqueror, Mozilla 1.7.1, Firefox 0.9.1.

I'm using Mandrake 10 which appart from this very slow annoying problem has been superb.

I also have the same problem on my laptop with the same distro/browsers

I tried a test with both my PC & Laptop plugged into my netgear ADSL/Router. I booted into WinXP on the PC and MDK 10 on the laptop put the same ULR into both and winxp instantly loaded the page while MDK10 on the laptop took for ever. I then booted the other way around... same result. This is obviously a Linux problem not ISP or browser based.

I'm still a bit of a :newbie: can anyone shed any light on this?

If I can sort this out I'm pretty much on my way to dumping xp 'cause everything else is mega with this distro!

Thanks in advance

Steve

:newbie: :Pengy:

SAME DUDE !!!
Except that I am using a D-Link 504 router Modem, But everything is the same.
i am also having trouble getting the internet connection to initialize on boot.
And my nVidia GForce FX 5200 128mg video card is also extremely slow.
HELP ! HElP !!

:D :D :D :D ;) :p
OOOOOOHHHHHH!! YEAH
I have been a member of this forum for ten minutes and am elated that the answer I found here works great. Still canīt initialise internet on boot, but very happy for now, thanks to all.

Answer : open Gedit as root and browse to /etc/modprobe.conf
add these two lines:
alias net-pf-10 ipv4
install ipv4 /bin/true
Save and reboot.

On reboot run terminal as SU
# type the following
# ifup eth0
# type Enter

Run Konquerer

Boy that was fun, (yeah I know, īget a lifeī )

x_mcmunt 08-17-2004 05:23 PM

Same problem happens for those with fedora rc2. From fedorafaq.org (which worked for me) . . .

Quote:

The problem is: Mozilla tries to use IPv6 before it uses IPv4 (IPv4 is the old version). When your Internet connection doesn't support IPv6, Mozilla fails to connect on the first try. In the current version of Mozilla, you can't change this, because of a bug.

So, we have to turn off IPv6 in Fedora:

1. Open a Terminal.
2. Become root:

su -
3. Open the file /etc/modprobe.conf:

gedit /etc/modprobe.conf
4. Add these lines to the end of the file:

# Turn off IPv6
alias net-pf-10 off
alias ipv6 off
5. Now, reboot the machine and sites should load faster!

(Thanks to Jonathan Baron and Chris Hubick for this great tip!)

qwijibow 08-31-2004 08:31 AM

This is a Bug in the latest 2.6 kernel tree... some1 confused a variable with a pointer, as a result, sume funtion designed to report on how much spare bandwidth you have always returns zero... you kernel thinks your connection is maxed out...

this seems to only be a problem when browsing webpages on NON Unix/Linux servers.
you have 2 options.... there is a (non official) patch.. cant remember the link, but google for it...

OR go back to a 2.4 kernel.


All times are GMT -5. The time now is 02:05 AM.