LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   kernel 2.6: slow internet (https://www.linuxquestions.org/questions/linux-networking-3/kernel-2-6-slow-internet-151050/)

janW 02-27-2004 02:47 AM

kernel 2.6: slow internet
 
Hi all,

I am running Mandrake 10.0 beta 2, Kernel 2.6.2rc3 on a new linux box (athlon 2500+).

Now here's the problem:
When running the kernel 2.6 internet is waaay slow. I am on a highspeed ADSL line, and long downloads are fast (300kB/s), but viewing internet pages takes forever. I'll wait seconds for Mozilla "Looking up host www google com"...
The puzzling thing is, if I run the kernel 2.4.25pre7, Internet is blazingly fast (well, I just moved from a K6-2/266...). The reason I don't want to go with the 2.4 kernel is my serial ATA controller. Disk access is slower by a factor of two with kernel 2.4.

All kernels are out of the box as compiled by Mandrake.
I'm using pppoe to connect, have a basic firewall installed. I'm connecting using the on-board gigabit ethernet adapter on my ASUS A7N8X-E Deluxe, driven by sk98lin. I know this is overkill, but the second fast ethernet port was not recognized, and I didn't bother to investigate.

So I'm stuck with either a slow hard drive or a slow internet connection. Any thoughts?

JanW

tcaptain 02-27-2004 09:40 AM

First off...you shouldn't double post. One thread should be enough.

Now to your problem...I don't have an accurate answer for you unfortunately...but here's a few thoughts.

1) Are you sure its the kernel? I mean are you using the same install and booting 2 different kernels with lilo? Or are you talking about 2 different systems (either 2 different machines or 2 completely separate installs on the hard drive)

2) If its two installs...then first I'd compare the config files you have setup. If not, mmmmm run top and see which system is using up more resources...although that's a long shot since you say both kernels are stock Mandrake kernels.

Let me know more about your setup and machine(s)...hopefully we can work on getting an answer for you (either myself or someone else)

janW 02-27-2004 12:02 PM

Thank you for offering to help! Sorry for double-posting. It was just after I posted to Distributions>Mandrake when I thought that this should really go to Networking...

Im am running a single box with Mandrake 10.0, booting either Kernel 2.4 or 2.6, both included in the distribution, using Grub. This makes me think it's the Kernel.

It is not a problem of resources, the system is essentially idle. I'm not sure it's the network interface either, since I can easily achieve the maximum transfer rate for sustained downloads. At least part of the reason seems to be that DNS requests are slow (at least that's how I interpret the long waits on the "resoving www...." status message in Mozilla). So I'm suspecting problems in the comunication with my ISP. At first I blamed their nameservers, until I tried the Kernel 2.4 (for different reasons).

I am happy to provide more info, but don't know much about networking. What information would be helpful? I can attach extracts from my /var/log/messages using both kernels, but I have to include them in this body - that quickly gets out of hand. Here are very short snippets:

Kernel 2.6
==============================================================================
Feb 27 08:36:46 localhost kernel: NET: Registered protocol family 2
Feb 27 08:36:46 localhost kernel: IP: routing cache hash table of 8192 buckets, 64Kbytes
Feb 27 08:36:46 localhost kernel: TCP: Hash tables configured (established 262144 bind 65536)
Feb 27 08:36:46 localhost kernel: NET: Registered protocol family 1
....
Feb 27 08:36:57 localhost adsl: Bringing up ADSL link
Feb 27 08:36:57 localhost kernel: CSLIP: code copyright 1989 Regents of the University of California
Feb 27 08:36:57 localhost kernel: PPP generic driver version 2.4.2
Feb 27 08:36:57 localhost adsl: .
Feb 27 08:36:57 localhost pppd[3973]: pppd 2.4.1 started by root, uid 0
Feb 27 08:36:57 localhost pppd[3973]: Using interface ppp0
Feb 27 08:36:57 localhost pppd[3973]: Connect: ppp0 <--> /dev/pts/0
Feb 27 08:36:59 localhost adsl: .
Feb 27 08:36:59 localhost kernel: eth0: network connection up using port A
Feb 27 08:36:59 localhost kernel: speed: 10
Feb 27 08:36:59 localhost kernel: autonegotiation: yes
Feb 27 08:36:59 localhost kernel: duplex mode: half
Feb 27 08:36:59 localhost kernel: flowctrl: none
Feb 27 08:36:59 localhost kernel: irq moderation: disabled
Feb 27 08:36:59 localhost kernel: scatter-gather: enabled
Feb 27 08:36:59 localhost pppoe[3974]: PPP session is 52465
Feb 27 08:37:00 localhost pppd[3973]: Couldn't set pass-filter in kernel: Invalid argument
Feb 27 08:37:00 localhost pppd[3973]: local IP address 65.92.104.124
Feb 27 08:37:00 localhost pppd[3973]: remote IP address 65.92.104.1
Feb 27 08:37:01 localhost adsl: Connected!
Feb 27 08:37:01 localhost adsl: ^[[65G[^[[1;32m
Feb 27 08:37:01 localhost adsl: OK
Feb 27 08:37:01 localhost adsl:
Feb 27 08:37:01 localhost rc: Starting adsl: succeeded
.....
Feb 27 08:36:51 localhost kernel: NET: Registered protocol family 10
Feb 27 08:36:51 localhost kernel: Disabled Privacy Extensions on device c0358fe0(lo)
Feb 27 08:36:51 localhost kernel: IPv6 over IPv4 tunneling driver


Kernel 2.4:
================================================================================

Feb 27 03:00:22 localhost kernel: NET4: Linux TCP/IP 1.0 for NET4.0
Feb 27 03:00:22 localhost kernel: IP Protocols: ICMP, UDP, TCP, IGMP
Feb 27 03:00:22 localhost kernel: IP: routing cache hash table of 8192 buckets, 64Kbytes
Feb 27 03:00:22 localhost kernel: TCP: Hash tables configured (established 262144 bind 65536)
Feb 27 03:00:22 localhost kernel: Linux IP multicast router 0.06 plus PIM-SM
Feb 27 03:00:22 localhost kernel: NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
........
Feb 27 03:00:31 localhost adsl: Bringing up ADSL link
Feb 27 03:00:31 localhost kernel: CSLIP: code copyright 1989 Regents of the University of California
Feb 27 03:00:31 localhost kernel: PPP generic driver version 2.4.2
Feb 27 03:00:31 localhost adsl: .
Feb 27 03:00:32 localhost pppd[2514]: pppd 2.4.1 started by root, uid 0
Feb 27 03:00:32 localhost pppd[2514]: Using interface ppp0
Feb 27 03:00:32 localhost pppd[2514]: Connect: ppp0 <--> /dev/pts/0
Feb 27 03:00:33 localhost adsl: .
Feb 27 03:00:33 localhost kernel: eth0: network connection up using port A
Feb 27 03:00:33 localhost kernel: speed: 10
Feb 27 03:00:33 localhost kernel: autonegotiation: yes
Feb 27 03:00:33 localhost kernel: duplex mode: half
Feb 27 03:00:33 localhost kernel: flowctrl: none
Feb 27 03:00:33 localhost kernel: irq moderation: disabled
Feb 27 03:00:33 localhost kernel: scatter-gather: enabled
Feb 27 03:00:34 localhost pppoe[2515]: PPP session is 50021
Feb 27 03:00:35 localhost pppd[2514]: local IP address 65.95.49.55
Feb 27 03:00:35 localhost pppd[2514]: remote IP address 65.95.49.1
Feb 27 03:00:36 localhost adsl: Connected!
Feb 27 03:00:36 localhost adsl:
Feb 27 03:00:36 localhost rc: Starting adsl: succeeded

The only difference is the "Couldn't set pass-filter in kernel: Invalid argument" in the Kernel 2.6 - which I don't know what it means.

Finally, there are messages from the firewall that chaught my attention. There seem to be more of them, when running kernel 2.6...

Kernel 2.4
================================================================================

Feb 27 03:12:51 localhost kernel: Shorewall:net2all:DROP:IN=ppp0 OUT= MAC= SRC=61.253.165.57 DST=65.95.49.55 LEN=838 TOS=0x00 PREC=0x00 TTL=116 ID=50211 PROTO=UDP SPT=18069 DPT=1028 LEN=818

Feb 27 03:18:27 localhost kernel: Shorewall:net2all:DROP:IN=ppp0 OUT= MAC= SRC=24.129.123.225 DST=65.95.49.55 LEN=52 TOS=0x00 PREC=0x00 TTL=42 ID=46501 DF PROTO=TCP SPT=4082 DPT=17300 WINDOW=60352 RES=0x00 SYN URGP=0

Feb 27 03:21:43 localhost kernel: Shorewall:net2all:DROP:IN=ppp0 OUT= MAC= SRC=62.238.227.238 DST=65.95.49.55 LEN=838 TOS=0x00 PREC=0x00 TTL=116 ID=41859 PROTO=UDP SPT=25195 DPT=1029 LEN=818

Feb 27 03:23:51 localhost kernel: Shorewall:net2all:DROP:IN=ppp0 OUT= MAC= SRC=64.52.113.150 DST=65.95.49.55 LEN=48 TOS=0x00 PREC=0x00 TTL=114 ID=19048 DF PROTO=TCP SPT=2583 DPT=80 WINDOW=16384 RES=0x00 SYN URGP=0

Feb 27 03:23:54 localhost kernel: Shorewall:net2all:DROP:IN=ppp0 OUT= MAC= SRC=64.52.113.150 DST=65.95.49.55 LEN=48 TOS=0x00 PREC=0x00 TTL=114 ID=19306 DF PROTO=TCP SPT=2583 DPT=80 WINDOW=16384 RES=0x00 SYN URGP=0

Feb 27 03:24:01 localhost kernel: Shorewall:net2all:DROP:IN=ppp0 OUT= MAC= SRC=64.52.113.150 DST=65.95.49.55 LEN=48 TOS=0x00 PREC=0x00 TTL=114 ID=19906 DF PROTO=TCP SPT=2583 DPT=80 WINDOW=16384 RES=0x00 SYN URGP=0

Feb 27 03:25:26 localhost kernel: Shorewall:net2all:DROP:IN=ppp0 OUT= MAC= SRC=24.244.144.94 DST=65.95.49.55 LEN=48 TOS=0x00 PREC=0x00 TTL=114 ID=32303 DF PROTO=TCP SPT=1749 DPT=80 WINDOW=16384 RES=0x00 SYN URGP=0

Feb 27 03:25:29 localhost kernel: Shorewall:net2all:DROP:IN=ppp0 OUT= MAC= SRC=24.244.144.94 DST=65.95.49.55 LEN=48 TOS=0x00 PREC=0x00 TTL=114 ID=32591 DF PROTO=TCP SPT=1749 DPT=80 WINDOW=16384 RES=0x00 SYN URGP=0

Feb 27 03:25:36 localhost kernel: Shorewall:net2all:DROP:IN=ppp0 OUT= MAC= SRC=24.244.144.94 DST=65.95.49.55 LEN=48 TOS=0x00 PREC=0x00 TTL=114 ID=33170 DF PROTO=TCP SPT=1749 DPT=80 WINDOW=16384 RES=0x00 SYN URGP=0

Feb 27 03:25:48 localhost kernel: Shorewall:net2all:DROP:IN=ppp0 OUT= MAC= SRC=69.93.198.72 DST=65.95.49.55 LEN=1077 TOS=0x00 PREC=0x00 TTL=116 ID=23497 PROTO=UDP SPT=18660 DPT=1026 LEN=1057

Feb 27 03:27:37 localhost kernel: Shorewall:net2all:DROP:IN=ppp0 OUT= MAC= SRC=210.56.22.189 DST=65.95.49.55 LEN=404 TOS=0x00 PREC=0x00 TTL=109 ID=9345 PROTO=UDP SPT=5103 DPT=1434 LEN=384

Feb 27 03:29:01 localhost kernel: Shorewall:newnotsyn:DROP:IN=ppp0 OUT= MAC= SRC=64.52.113.150 DST=65.95.49.55 LEN=43 TOS=0x00 PREC=0x00 TTL=18 ID=0 PROTO=TCP SPT=2583 DPT=80 WINDOW=0 RES=0x00 ACK RST URGP=0

Feb 27 03:31:31 localhost kernel: Shorewall:net2all:DROP:IN=ppp0 OUT= MAC= SRC=62.231.144.18 DST=65.95.49.55 LEN=44 TOS=0x00 PREC=0x00 TTL=48 ID=53488 PROTO=TCP SPT=6409 DPT=80 WINDOW=512 RES=0x00 SYN URGP=0

Feb 27 03:31:34 localhost kernel: Shorewall:net2all:DROP:IN=ppp0 OUT= MAC= SRC=62.231.144.18 DST=65.95.49.55 LEN=44 TOS=0x00 PREC=0x00 TTL=48 ID=53815 PROTO=TCP SPT=6409 DPT=80 WINDOW=7300 RES=0x00 SYN URGP=0

Kernel 2.6
=================================================================================
Feb 27 08:37:24 localhost kernel: Shorewall:net2all:DROP:IN=ppp0 OUT= MAC= SRC=80.53.76.234 DST=65.92.104.124 LEN=48 TOS=0x00 PREC=0x00 TTL=109 ID=11880 DF PROTO=TCP SPT=1465 DPT=3643 WINDOW=64240 RES=0x00 SYN URGP=0

Feb 27 08:37:27 localhost kernel: Shorewall:net2all:DROP:IN=ppp0 OUT= MAC= SRC=80.53.76.234 DST=65.92.104.124 LEN=48 TOS=0x00 PREC=0x00 TTL=109 ID=11902 DF PROTO=TCP SPT=1465 DPT=3643 WINDOW=64240 RES=0x00 SYN URGP=0

Feb 27 08:37:33 localhost kernel: Shorewall:net2all:DROP:IN=ppp0 OUT= MAC= SRC=80.53.76.234 DST=65.92.104.124 LEN=48 TOS=0x00 PREC=0x00 TTL=109 ID=11949 DF PROTO=TCP SPT=1465 DPT=3643 WINDOW=64240 RES=0x00 SYN URGP=0

Feb 27 08:38:01 localhost kernel: Shorewall:net2all:DROP:IN=ppp0 OUT= MAC= SRC=134.102.9.73 DST=65.92.104.124 LEN=48 TOS=0x00 PREC=0x00 TTL=112 ID=50909 DF PROTO=TCP SPT=2859 DPT=27966 WINDOW=64240 RES=0x00 SYN URGP=0

Feb 27 08:38:04 localhost kernel: Shorewall:net2all:DROP:IN=ppp0 OUT= MAC= SRC=134.102.9.73 DST=65.92.104.124 LEN=48 TOS=0x00 PREC=0x00 TTL=112 ID=51124 DF PROTO=TCP SPT=2859 DPT=27966 WINDOW=64240 RES=0x00 SYN URGP=0

Feb 27 08:38:10 localhost kernel: Shorewall:net2all:DROP:IN=ppp0 OUT= MAC= SRC=134.102.9.73 DST=65.92.104.124 LEN=48 TOS=0x00 PREC=0x00 TTL=112 ID=51394 DF PROTO=TCP SPT=2859 DPT=27966 WINDOW=64240 RES=0x00 SYN URGP=0

Feb 27 08:38:11 localhost kernel: Shorewall:net2all:DROP:IN=ppp0 OUT= MAC= SRC=213.54.104.45 DST=65.92.104.124 LEN=48 TOS=0x00 PREC=0x00 TTL=114 ID=63196 DF PROTO=TCP SPT=2551 DPT=27966 WINDOW=16384 RES=0x00 SYN URGP=0

Feb 27 08:38:20 localhost kernel: Shorewall:net2all:DROP:IN=ppp0 OUT= MAC= SRC=213.54.104.45 DST=65.92.104.124 LEN=48 TOS=0x00 PREC=0x00 TTL=114 ID=63988 DF PROTO=TCP SPT=2551 DPT=27966 WINDOW=16384 RES=0x00 SYN URGP=0

Feb 27 08:38:21 localhost kernel: Shorewall:net2all:DROP:IN=ppp0 OUT= MAC= SRC=213.54.104.45 DST=65.92.104.124 LEN=48 TOS=0x00 PREC=0x00 TTL=114 ID=64145 DF PROTO=TCP SPT=2551 DPT=27966 WINDOW=16384 RES=0x00 SYN URGP=0

Feb 27 08:38:24 localhost kernel: Shorewall:net2all:DROP:IN=ppp0 OUT= MAC= SRC=213.54.104.45 DST=65.92.104.124 LEN=48 TOS=0x00 PREC=0x00 TTL=114 ID=64391 DF PROTO=TCP SPT=2551 DPT=27966 WINDOW=16384 RES=0x00 SYN URGP=0

Feb 27 08:38:55 localhost kernel: Shorewall:net2all:DROP:IN=ppp0 OUT= MAC= SRC=217.72.82.177 DST=65.92.104.124 LEN=48 TOS=0x00 PREC=0x00 TTL=109 ID=58667 DF PROTO=TCP SPT=4106 DPT=27966 WINDOW=64240 RES=0x00 SYN URGP=0

Feb 27 08:38:58 localhost kernel: Shorewall:net2all:DROP:IN=ppp0 OUT= MAC= SRC=217.72.82.177 DST=65.92.104.124 LEN=48 TOS=0x00 PREC=0x00 TTL=109 ID=58748 DF PROTO=TCP SPT=4106 DPT=27966 WINDOW=64240 RES=0x00 SYN URGP=0

Feb 27 08:39:04 localhost kernel: Shorewall:net2all:DROP:IN=ppp0 OUT= MAC= SRC=217.72.82.177 DST=65.92.104.124 LEN=48 TOS=0x00 PREC=0x00 TTL=109 ID=58853 DF PROTO=TCP SPT=4106 DPT=27966 WINDOW=64240 RES=0x00 SYN URGP=0

I'll stop shooting in the dark now. I hope some of this info is pertinent...

tcaptain 02-27-2004 12:44 PM

I'll be honest with you. I hate letting you down but personally...I'm stumped.

I was kinda hoping you'd be talking about 2 systems :(

So if someone who's a lot better at this is reading this...jump in :D

Ok..in the meantime...What's your network card? I'm grasping at straws...maybe its the way a driver was compiled.

since its the same system...I'm assuming that you have the SAME services running right? I mean, you don't have some sort of DNS cache running with 2.4 that doesn't get loaded with 2.6 somehow?

janW 02-27-2004 01:23 PM

The network cark is an onboard Marvell 88E8001 Gigabit LAN. I googled to know what the status of Linux support for my MOBO is (ASUS A7N8X-E Deluxe) - _after I bought it_ - and support for this network card is indeed an issue. But the sk98lin driver _does_ support it. The reason I found problems with the network card unlikely, is that maximum transfer speeds are fine.

Yes, I do have the exact same services running. - At least, I didn't change any of the boot setup / init scripts.

Where in the system logs would I find details about the talk that is going on between my machine and my ISP, for example when connecting? The exerpts of the /var/log/messages are all I have found so far, and are not very verbose.

I might just try to recompile the latest version of the kernel - even though I hate doing that without a better reason than not knowing what else to do.

Thanks a lot for your time!!

tcaptain 02-27-2004 01:42 PM

I'm hoping someone can join in here besides me :)

For errors...no idea where you would look other than in the messages file and I wouldn't know what to look for....unless there's a blatant error.

Here's something to try...from the command line (you might need to be root, not sure) try something like:

ping www.google.com

using both kernels...you mentionned before you suspected the problem was around the lag in DNS responses...this might confirm it better than a status bar in a browser... check the time values too.

As for recompiling a kernel...its worth doing just so you dont have a lot of useless stuff loaded in memory for nothing...making your machine more efficient.

janW 02-27-2004 03:43 PM

That seemed like a good idea. The results are meager, however. First I should state that I am no longer able to run X with the kernel 2.4 since I installed the NVidia drivers, compiled for 2.6 (I could recompile...). While it does prevent me from gathering more quantitative data on internet speed, it doesn't prevent me from running ping. In both configurations, I ran
ping www.google.com >> some_file five times for exactly 10s each (stopwatch). Note that it sometimes takes over 5sec for the first line ("PING www....") to appear. I don't see a difference between 2.4 and 2.6.

I guess the next step is, as you suggested, a Kernel recompile. Not today.

Thank you for your help!

Here are the results:

Kernel 2.6
===============================================================================
===============================================================================
PING www.google.akadns.net (216.239.37.99) 56(84) bytes of data.
64 bytes from 216.239.37.99: icmp_seq=1 ttl=243 time=32.5 ms
64 bytes from 216.239.37.99: icmp_seq=2 ttl=243 time=19.6 ms
64 bytes from 216.239.37.99: icmp_seq=3 ttl=243 time=20.0 ms
64 bytes from 216.239.37.99: icmp_seq=4 ttl=243 time=19.5 ms
64 bytes from 216.239.37.99: icmp_seq=5 ttl=243 time=33.4 ms
64 bytes from 216.239.37.99: icmp_seq=6 ttl=243 time=19.7 ms
64 bytes from 216.239.37.99: icmp_seq=7 ttl=243 time=20.1 ms
64 bytes from 216.239.37.99: icmp_seq=8 ttl=243 time=19.6 ms
64 bytes from 216.239.37.99: icmp_seq=9 ttl=243 time=19.3 ms

--- www.google.akadns.net ping statistics ---
9 packets transmitted, 9 received, 0% packet loss, time 8645ms
rtt min/avg/max/mdev = 19.391/22.687/33.487/5.534 ms

==================================================================

PING www.google.akadns.net (216.239.41.99) 56(84) bytes of data.
64 bytes from 216.239.41.99: icmp_seq=1 ttl=245 time=37.3 ms
64 bytes from 216.239.41.99: icmp_seq=2 ttl=245 time=34.3 ms
64 bytes from 216.239.41.99: icmp_seq=3 ttl=245 time=19.8 ms
64 bytes from 216.239.41.99: icmp_seq=4 ttl=245 time=20.9 ms
64 bytes from 216.239.41.99: icmp_seq=5 ttl=245 time=32.9 ms
64 bytes from 216.239.41.99: icmp_seq=6 ttl=245 time=31.3 ms
64 bytes from 216.239.41.99: icmp_seq=7 ttl=245 time=30.3 ms

--- www.google.akadns.net ping statistics ---
7 packets transmitted, 7 received, 0% packet loss, time 8331ms
rtt min/avg/max/mdev = 19.854/29.602/37.380/6.204 ms

=================================================================

PING www.google.akadns.net (216.239.41.99) 56(84) bytes of data.
64 bytes from 216.239.41.99: icmp_seq=1 ttl=245 time=32.3 ms
64 bytes from 216.239.41.99: icmp_seq=2 ttl=245 time=20.2 ms
64 bytes from 216.239.41.99: icmp_seq=3 ttl=245 time=20.9 ms
64 bytes from 216.239.41.99: icmp_seq=4 ttl=245 time=20.2 ms
64 bytes from 216.239.41.99: icmp_seq=5 ttl=245 time=20.5 ms

--- www.google.akadns.net ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4003ms
rtt min/avg/max/mdev = 20.225/22.871/32.324/4.738 ms

=================================================================

PING www.google.akadns.net (216.239.41.104) 56(84) bytes of data.
64 bytes from 216.239.41.104: icmp_seq=1 ttl=245 time=32.0 ms
64 bytes from 216.239.41.104: icmp_seq=2 ttl=245 time=20.0 ms
64 bytes from 216.239.41.104: icmp_seq=3 ttl=245 time=33.1 ms
64 bytes from 216.239.41.104: icmp_seq=4 ttl=245 time=20.9 ms
64 bytes from 216.239.41.104: icmp_seq=5 ttl=245 time=20.2 ms
64 bytes from 216.239.41.104: icmp_seq=6 ttl=245 time=20.1 ms
64 bytes from 216.239.41.104: icmp_seq=7 ttl=245 time=19.6 ms
64 bytes from 216.239.41.104: icmp_seq=8 ttl=245 time=33.8 ms
64 bytes from 216.239.41.104: icmp_seq=9 ttl=245 time=32.7 ms

--- www.google.akadns.net ping statistics ---
9 packets transmitted, 9 received, 0% packet loss, time 9556ms
rtt min/avg/max/mdev = 19.614/25.870/33.886/6.365 ms

=================================================================

PING www.google.akadns.net (216.239.41.104) 56(84) bytes of data.
64 bytes from 216.239.41.104: icmp_seq=1 ttl=245 time=31.8 ms
64 bytes from 216.239.41.104: icmp_seq=2 ttl=245 time=20.0 ms
64 bytes from 216.239.41.104: icmp_seq=3 ttl=245 time=33.9 ms
64 bytes from 216.239.41.104: icmp_seq=4 ttl=245 time=20.0 ms
64 bytes from 216.239.41.104: icmp_seq=5 ttl=245 time=20.3 ms
64 bytes from 216.239.41.104: icmp_seq=6 ttl=245 time=20.2 ms
64 bytes from 216.239.41.104: icmp_seq=7 ttl=245 time=20.2 ms
64 bytes from 216.239.41.104: icmp_seq=8 ttl=245 time=19.7 ms
64 bytes from 216.239.41.104: icmp_seq=9 ttl=245 time=20.2 ms
64 bytes from 216.239.41.104: icmp_seq=10 ttl=245 time=19.8 ms

--- www.google.akadns.net ping statistics ---
10 packets transmitted, 10 received, 0% packet loss, time 9757ms
rtt min/avg/max/mdev = 19.743/22.643/33.982/5.157 ms


Kernel 2.4
===================================================================
===================================================================

PING www.google.akadns.net (216.239.37.147) 56(84) bytes of data.
64 bytes from 216.239.37.147: icmp_seq=1 ttl=243 time=20.8 ms
64 bytes from 216.239.37.147: icmp_seq=2 ttl=243 time=20.5 ms
64 bytes from 216.239.37.147: icmp_seq=3 ttl=243 time=20.4 ms
64 bytes from 216.239.37.147: icmp_seq=4 ttl=243 time=20.3 ms
64 bytes from 216.239.37.147: icmp_seq=5 ttl=243 time=20.8 ms
64 bytes from 216.239.37.147: icmp_seq=6 ttl=243 time=20.8 ms

--- www.google.akadns.net ping statistics ---
6 packets transmitted, 6 received, 0% packet loss, time 7667ms
rtt min/avg/max/mdev = 20.319/20.669/20.897/0.292 ms

==================================================================

PING www.google.akadns.net (216.239.39.99) 56(84) bytes of data.
64 bytes from 216.239.39.99: icmp_seq=1 ttl=244 time=24.3 ms
64 bytes from 216.239.39.99: icmp_seq=2 ttl=244 time=20.3 ms
64 bytes from 216.239.39.99: icmp_seq=3 ttl=244 time=21.0 ms
64 bytes from 216.239.39.99: icmp_seq=4 ttl=244 time=19.9 ms
64 bytes from 216.239.39.99: icmp_seq=5 ttl=244 time=34.4 ms
64 bytes from 216.239.39.99: icmp_seq=6 ttl=244 time=20.9 ms
64 bytes from 216.239.39.99: icmp_seq=7 ttl=244 time=24.8 ms
64 bytes from 216.239.39.99: icmp_seq=8 ttl=244 time=20.7 ms
64 bytes from 216.239.39.99: icmp_seq=9 ttl=244 time=20.7 ms
64 bytes from 216.239.39.99: icmp_seq=10 ttl=244 time=23.8 ms

--- www.google.akadns.net ping statistics ---
10 packets transmitted, 10 received, 0% packet loss, time 9068ms
rtt min/avg/max/mdev = 19.982/23.129/34.428/4.132 ms

==================================================================

PING www.google.akadns.net (216.239.39.147) 56(84) bytes of data.
64 bytes from 216.239.39.147: icmp_seq=1 ttl=244 time=23.0 ms
64 bytes from 216.239.39.147: icmp_seq=2 ttl=244 time=20.6 ms
64 bytes from 216.239.39.147: icmp_seq=3 ttl=244 time=19.7 ms
64 bytes from 216.239.39.147: icmp_seq=4 ttl=244 time=30.4 ms
64 bytes from 216.239.39.147: icmp_seq=5 ttl=244 time=21.1 ms

--- www.google.akadns.net ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 8302ms
rtt min/avg/max/mdev = 19.700/23.018/30.465/3.882 ms

=================================================================

PING www.google.akadns.net (216.239.39.147) 56(84) bytes of data.
64 bytes from 216.239.39.147: icmp_seq=1 ttl=244 time=19.9 ms
64 bytes from 216.239.39.147: icmp_seq=2 ttl=244 time=19.3 ms
64 bytes from 216.239.39.147: icmp_seq=3 ttl=244 time=19.9 ms
64 bytes from 216.239.39.147: icmp_seq=4 ttl=244 time=20.1 ms
64 bytes from 216.239.39.147: icmp_seq=5 ttl=244 time=19.9 ms
64 bytes from 216.239.39.147: icmp_seq=6 ttl=244 time=20.1 ms
64 bytes from 216.239.39.147: icmp_seq=7 ttl=244 time=19.9 ms
64 bytes from 216.239.39.147: icmp_seq=8 ttl=244 time=20.1 ms

--- www.google.akadns.net ping statistics ---
8 packets transmitted, 8 received, 0% packet loss, time 8896ms
rtt min/avg/max/mdev = 19.395/19.951/20.187/0.262 ms

==================================================================

PING www.google.akadns.net (216.239.39.147) 56(84) bytes of data.
64 bytes from 216.239.39.147: icmp_seq=1 ttl=244 time=20.3 ms
64 bytes from 216.239.39.147: icmp_seq=2 ttl=244 time=19.7 ms
64 bytes from 216.239.39.147: icmp_seq=3 ttl=244 time=22.1 ms
64 bytes from 216.239.39.147: icmp_seq=4 ttl=244 time=21.0 ms
64 bytes from 216.239.39.147: icmp_seq=5 ttl=244 time=20.5 ms
64 bytes from 216.239.39.147: icmp_seq=6 ttl=244 time=24.8 ms
64 bytes from 216.239.39.147: icmp_seq=7 ttl=244 time=21.1 ms
64 bytes from 216.239.39.147: icmp_seq=8 ttl=244 time=20.5 ms
64 bytes from 216.239.39.147: icmp_seq=9 ttl=244 time=20.5 ms

--- www.google.akadns.net ping statistics ---
9 packets transmitted, 9 received, 0% packet loss, time 8962ms
rtt min/avg/max/mdev = 19.786/21.213/24.837/1.418 ms

soloist 03-11-2004 10:54 PM

Not to confuse the issue, but when I was researching a poorly supported NIC (3Com 3C940 on Asus P4P800 Deluxe) I was steered by the community to also use the sk98lin driver. Under Mandy 9.2, users using sk98lin with 3C940 reported variable performance (1. very slow connection setup time, 2. connection fails on some websites !?), and users who compiled the drivers from the ASUS web site were happy.

And now that I've loaded Mandrake 10 Community, I see that the auto configuration now recognizes my NIC and assigns it the sk98lin driver. Based on what I read when I had 9.2, I'm not sure if that is a good thing or a bad thing. :)

Long story short: maybe ASUS has a better driver for you.

soloist 03-12-2004 12:49 AM

My post above is not quite accurate. I was not able to find a consesus solution in this
very long thread on the 3C940 and sk98lin driver
http://www.linuxquestions.org/questi...ghlight=P4P800

good luck

janW 03-12-2004 10:36 AM

thank you soloist!

I had put this issue to rest, temporarily, since I _can_ access all websites (just some are painfully slow), and since I don't really have much time right now to investigate. But I'll definately try to get a new driver version, and I'll report my experiences. The thread you reference looks like it has some great hints.

JanW

alxdotnet 03-13-2004 05:51 PM

This is _not_ a driver/device specific problem...I've noticed it in Mandrake 10.0 as well as in Debian. I have 3com etherlink. Again, kernel 2.4 works great!
Furthermore, I believe I've isolated the problem to the DNS lookup before the actual HTTP request is sent.

janW 03-13-2004 09:22 PM

That's what it looks like to me, however, I don't know how to really establish that it's a DNS problem. What did you do to isolate this? As I mentioned, I had the impression that kernel 2.6.3 was ok. Any clue as to what "feature" in the kernel makes the difference?

s34n 03-13-2004 09:48 PM

This may be a real stab in the dark, but have you tried another web browser other than Mozilla?

moosedaddy 03-14-2004 12:13 AM

I am having the exact same problems 2.4 lighting fast 2.6 extremely slow. Konqueror does seem a little better than Mozilla and alot better than Firefox.

I am using the pre-compiled acx100 driver, I am working on recompiling the kernel to see if the latest driver will be better.

alxdotnet 03-14-2004 05:08 PM

As another stab in the dark:
I remember reading somewhen somewhere that experimental IPv6 support wreaks havoc on inet speeds...perhaps this is enabled in 2.6 by default? If so, can someone tell us noobs how to turn it off?
Mandrake 10.0/3com Etherlink/2.6.3

janW 03-15-2004 03:01 AM

s34n: yes I have. while konqueror (sometimes) seems marginally faster than mozilla, that does not at all solve the issue of >30sec waits for contacting some sites.

alxdotnet: I will definately check this out. there are options to turn IPv6 support on/off when compiling a kernel. IIRC it is recommendet to turn it on, which is why I didn't think this should have a major impact on performance (at least not negative ;) ).

alxdotnet 03-15-2004 09:27 AM

Thanks janW! I just remember hearing something about IPv6 and performance before, and I know you can configure it in the kernel setup, so I'd be interested in knowing if turning it off fixes the problem. It'd make sense, since from what I've read it's off in 2.4 by default.
-Alex

*edit* does anyone have 2.6 with fast internet?

alxdotnet 03-16-2004 12:19 PM

Quote:

Originally Posted by janW
while konqueror (sometimes) seems marginally faster than mozilla, that does not at all solve the issue of >30sec waits for contacting some sites.

Interesting...I installed Mozilla and it's doing much better. While it takes 20 seconds or so to establish initial contact, loading pages within that domain is near instantaneous. Still, it doesn't beat 2.4.

alxdotnet 03-17-2004 10:49 PM

Come on pplz, let's solve this!
On my Mandrake 10.0, the shell command "lynx linuxquestions.org" takes 20 seconds to execute and display a page.
The command "ping linuxquestions.org" responds like this:
[alxdotnet@ALEX alxdotnet]$ ping linuxquestions.org
PING linuxquestions.org (64.179.4.146) 56(84) bytes of data.
64 bytes from linuxquestions.org (64.179.4.146): icmp_seq=1 ttl=45 time=71.9 ms
64 bytes from linuxquestions.org (64.179.4.146): icmp_seq=2 ttl=45 time=67.7 ms
64 bytes from linuxquestions.org (64.179.4.146): icmp_seq=3 ttl=45 time=66.7 ms
64 bytes from linuxquestions.org (64.179.4.146): icmp_seq=4 ttl=45 time=67.2 ms

The response is instantaneous. However, if i "lynx 64.179.4.146", lynx responds instantaneously! This is confusing me!
Apparently the DNS lookup is causing the problem, but how come ping is able to do it instantly and lynx takes forever? What's the difference? Come on, let's solve this thing!

moosedaddy 03-18-2004 09:48 AM

Have you tried to turn off IPv6? I am fighting the same problem with Mandrake 10, ping times are good download speeds are good, surfing speeds are horible. I am willing to try about anything.

moosedaddy 03-18-2004 09:51 AM

After further research I found this http://www.linuxquestions.org/questi...hreadid=158683 I will try it tonight.

vi0lat0r 03-18-2004 10:58 PM

Quote:

Originally posted by fuzzbucket
Problem solved. It seems having IPv6 enabled can slow down certain apps (I assume only IPv6 aware ones) so I simply disabled it (inserted "alias net-pf-10 off" in /etc/modules.conf)
This line reduced the time for me from about 20 seconds to 3~7 (at any given site).

EDIT:

I just went to Mandrake Control Center, Network / Internet, Manage Connections. I found that my connection was set to static, and I have DHCP... this confused me so I changed it to DHCP. Sites load -MUCH- faster now....

EDIT 2:

Don't do it though because now I can't even load my control panel, lol. Great...

EDIT 3:

Restarted, works great and everything is awesome like 2.4!

alxdotnet 03-19-2004 05:59 PM

Weird. Problem fixed itself.
Actually, strange as it may sound I think it had something to do with the KDE theme I was using. I switched to Keramik and response time fell to zero. Oh well, at least it works now...

janW 03-25-2004 10:12 PM

It doesn't seem to fix itself on my box. And the "alias net-pf-10 off" in /etc/modules.conf didn't fix it either.

As mentioned before, I have the choice of recompiling a kernel (2.4 or 2.6) and having fast internet but a slow SATA harddrive, or use the Mandrake kernel and have a fast harddrive and slow internet. I just switched to the former (deactivating IPv6 support). I'll see what I can do about the SATA driver.

Anyway, the bottom line is that recompiling the kernel without IPv6 support fixes my problem with the slow internet (2.4 or 2.6, both work).

JanW

alxdotnet 03-26-2004 05:40 PM

The only other thing I recall doing is changing my DHCP client....

dePOLL 03-30-2004 03:36 PM

same here :/
 
Hello everybody.

I have the same problems using Mandrake 10.0 with the 2.6.3-4 Kernel:
- Incredibly slooooooooow surfing, despite DSL-connection (1,5MB/s down, 256kb/s up)
- Faaaast downloads (up to 150kb/s)

What seems to slow the process down is the DNS-resolving which of course doesn't occur during a longer Download. I have a Realtek PCI Ethernet card and use the standard rtl8139 driver. I DON'T think it's a device/driver issue. Besides I noticed an actual 'flood' of shorewall-messages in my syslogs. I don't know wheater this is just some kind of a debugging feature in the pre-version of 10.0, but anyhow I'm interested in turning this off :D Guess I'll have to change the iptables? Oo

-- syslog-excerpt:
Mar 30 22:28:08 dorsch kernel: Shorewall:net2all:DROP:IN=eth0 OUT= MAC= SRC=192.168.0.11 DST=192.168.0.255 LEN=139 TOS=0x00 PREC=0x00 TTL=64 ID=338 DF PROTO=UDP SPT=631 DPT=631 LEN=119
Mar 30 22:28:39 dorsch kernel: Shorewall:net2all:DROP:IN=eth0 OUT= MAC= SRC=192.168.0.11 DST=192.168.0.255 LEN=139 TOS=0x00 PREC=0x00 TTL=64 ID=340 DF PROTO=UDP SPT=631 DPT=631 LEN=119
Mar 30 22:29:10 dorsch kernel: Shorewall:net2all:DROP:IN=eth0 OUT= MAC= SRC=192.168.0.11 DST=192.168.0.255 LEN=139 TOS=0x00 PREC=0x00 TTL=64 ID=342 DF PROTO=UDP SPT=631 DPT=631 LEN=119
Mar 30 22:29:41 dorsch kernel: Shorewall:net2all:DROP:IN=eth0 OUT= MAC= SRC=192.168.0.11 DST=192.168.0.255 LEN=139 TOS=0x00 PREC=0x00 TTL=64 ID=344 DF PROTO=UDP SPT=631 DPT=631 LEN=119
Mar 30 22:30:12 dorsch kernel: Shorewall:net2all:DROP:IN=eth0 OUT= MAC= SRC=192.168.0.11 DST=192.168.0.255 LEN=139 TOS=0x00 PREC=0x00 TTL=64 ID=346 DF PROTO=UDP SPT=631 DPT=631 LEN=119
Mar 30 22:30:43 dorsch kernel: Shorewall:net2all:DROP:IN=eth0 OUT= MAC= SRC=192.168.0.11 DST=192.168.0.255 LEN=139 TOS=0x00 PREC=0x00 TTL=64 ID=348 DF PROTO=UDP SPT=631 DPT=631 LEN=119
Mar 30 22:31:14 dorsch kernel: Shorewall:net2all:DROP:IN=eth0 OUT= MAC= SRC=192.168.0.11 DST=192.168.0.255 LEN=139 TOS=0x00 PREC=0x00 TTL=64 ID=350 DF PROTO=UDP SPT=631 DPT=631 LEN=119
Mar 30 22:31:45 dorsch kernel: Shorewall:net2all:DROP:IN=eth0 OUT= MAC= SRC=192.168.0.11 DST=192.168.0.255 LEN=139 TOS=0x00 PREC=0x00 TTL=64 ID=352 DF PROTO=UDP SPT=631 DPT=631 LEN=119
Mar 30 22:32:16 dorsch kernel: Shorewall:net2all:DROP:IN=eth0 OUT= MAC= SRC=192.168.0.11 DST=192.168.0.255 LEN=139 TOS=0x00 PREC=0x00 TTL=64 ID=354 DF PROTO=UDP SPT=631 DPT=631 LEN=119
Mar 30 22:32:47 dorsch kernel: Shorewall:net2all:DROP:IN=eth0 OUT= MAC= SRC=192.168.0.11 DST=192.168.0.255 LEN=139 TOS=0x00 PREC=0x00 TTL=64 ID=356 DF PROTO=UDP SPT=631 DPT=631 LEN=119
Mar 30 22:33:18 dorsch kernel: Shorewall:net2all:DROP:IN=eth0 OUT= MAC= SRC=192.168.0.11 DST=192.168.0.255 LEN=139 TOS=0x00 PREC=0x00 TTL=64 ID=358 DF PROTO=UDP SPT=631 DPT=631 LEN=119
(yep, just 5 minutes... my logs are flooded with this shi*)

-- iptables -L excerpt:
Chain net2all (1 references)
target prot opt source destination
ACCEPT all -- anywhere anywhere state RELATED,ESTABLISHED
newnotsyn tcp -- anywhere anywhere state NEW tcp flags:!SYN,RST,ACK/SYN
common all -- anywhere anywhere
LOG all -- anywhere anywhere LOG level info prefix `Shorewall:net2all:DROP:'
DROP all -- anywhere anywhere

Aaaaany hint would be appreciated :)

Greets from Cologne, Germany
- Niels 'dePOLL'

Oh, and by the way: Ping times are good, but resolving the IP when pingin bla.bla is horribly slow anyway
(or at least there is a laaag between "PING bla.bla (x.x.x.x) 56(84) bytes of data." and the first row of results)

alxdotnet 04-01-2004 11:01 AM

Hey, if anyone's still following this thread...
Are you accessing the internet from behind a router? From what i've gathered, the slowness is because some router/proxy/firewall is not allowing v6 packets through, and it takes 20 secs or so for the operation to time out and the DNS resolve to start again with IPv4. I am using a Dell Truemobile 2300 router.

Adding the disable v6 line above to /etc/modules.conf solved it for me.

janW 04-01-2004 11:46 AM

I do have a firewall set up. And knowing next to nothing about firewall configuration I can easily believe that something's wrong there. Other than that, I'm not using a router on my end. I don't know if my ISP has maybe troubles with IPv6?

JanW

disciple061 04-02-2004 01:57 AM

im pretty sure i have ipv6 disabled, but im having the same problem described in this thread. im using kernel 2.6.1, and access the internet from my school, which i know is a fast connection. any suggestions are GREATLY appreciated.

dePOLL 04-02-2004 09:32 AM

First thanks to everybody who tries to help us. Unfortunately the problem still isn't solved.. I added 'alias net-pf-10 off' to my modules.conf and the situation may have increased a bit, but surfing the web still is incredibly slow..

Btw, a "ipv6" module is loaded: 'ipv6 232352 10'
Dunno if this is important..

alxdotnet 04-06-2004 11:35 PM

Quote:

Originally Posted by janW
I do have a firewall set up. And knowing next to nothing about firewall configuration I can easily believe that something's wrong there. Other than that, I'm not using a router on my end. I don't know if my ISP has maybe troubles with IPv6?

Whether you're using a router is unimportant...some firewalls throw away the IPv6 packet, probably because they don't know what the heck it is. It's also very logical that your ISP's firewall might be behind things, though I would expect they would have upgraded long ago.

Quote:

Originally Posted by dePOLL
Btw, a "ipv6" module is loaded: 'ipv6 232352 10'
Dunno if this is important..

I think it is important...

As far as I can recall this is what I did:
1) Added "alias" line to /etc/modules.conf
2) Rebooted. I remember this didn't help
3) Changed DHCP client several times
4) Rebooted again. Blazing fast.

Anyway, this is a strange problem and should probably be submitted as a kernel bug if it already hasn't been taken care of (in 2.6.5, if I recall correctly).

dePOLL 04-07-2004 08:02 AM

Just returned to my 2.4 Kernel. I don't really need any of the newer features so this is no big deal.. Anyway, somehow it bugs me, but I'm just too lazy to invest hours in solving this problem. Thanks anyway.

techmetal 04-07-2004 08:32 AM

I have the same DNS problems but only with Lynx (I want to use Lynx!). I haven't checked with Firefox if it does IPv6 DNS requests but it seems to work fine and fast.

Someone in my local Linux user group suggested commenting out all IPv6 lines in /etc/hosts file. It didn't work for me but it could be worth trying out for the others.

Among the things I have tried unsuccessfully:
- alias net-pf-10 off in /etc/modules.conf
- disabling IPv6 support in the kernel

I'll try greping the 2.6.5 kernel changelog file to see if this is a resolved (no pun intended) issue. And maybe compile it. Anybody have other suggestions ?

moosedaddy 04-07-2004 09:33 AM

I fixed my problem, I checked the router and the firmware was set to limit the wan port to 10Mbit. I upgraded the firmware and enabled ipv6, I can now surf as fast as I was with the 2.4.X kernel.

alxdotnet 04-09-2004 02:30 AM

Problem - Solved!

Hey all, found the fix. Add:
Code:

alias net-pf-10 off
to /etc/modprobe.conf, which replaces /etc/modules.conf in 2.6 kernel.
Cheers!
-Alex

Concillian 04-09-2004 01:20 PM

For what it's worth, I just saw this thread and I never had any problems like this with Mandrake 10.0 rc2 or 10.0 community running the 2.6 kernel.

My configuration:
10.0 community running 2.6.3
on board 10/100 3c905 for connection to DSL modem
Intel gigabit card for my home network
Used the Mandrake Control Center ICS 'wizard' to provide IP forwarding and firewall with the linux box.

Static IPs both to my ISP and on the home network.

I didn't have to do any manual configuations at all for the TCP/IP networking, just used the GUI tools available in harddrake and the MCC.

I never noticed any delays on DNS lookups from either the linux box, or any of the Windows boxes connected through the linux box.

alxdotnet 04-09-2004 06:26 PM

Quote:

Originally Posted by Concillian
I never noticed any delays on DNS lookups from either the linux box, or any of the Windows boxes connected through the linux box.

Yes, you have an IPv6-aware ISP and IPv6 aware clients, you wouldn't notice anything. The problem is that some routers/firewalls/stoneage ISPs block v6 packets from ever reaching the public internet, so DNS lookups have to time-out on v6 before the v4 packet is sent.

alberto2498 04-11-2004 03:26 AM

Quote:

Originally posted by alxdotnet
Problem - Solved!

Hey all, found the fix. Add:
Code:

alias net-pf-10 off
to /etc/modprobe.conf, which replaces /etc/modules.conf in 2.6 kernel.
Cheers!
-Alex

I just did this, although I did changes for /etc/modules.conf as well as /etc/modprobe.conf and everything is working as before.

Thank you to you all, this is just great.

Alberto

Rnd227 04-11-2004 12:48 PM

Did this too, and although it greatly improved the situation, (I don't wait 20 secs anymore), I still wait around 5 seconds just for resolution...

So it's only a partial solution for me. Any ideas ?

silvercastle 04-14-2004 10:39 PM

Quote:

Originally posted by alxdotnet
Problem - Solved!

Hey all, found the fix. Add:
Code:

alias net-pf-10 off
to /etc/modprobe.conf, which replaces /etc/modules.conf in 2.6 kernel.
Cheers!
-Alex

...cool...thanx for that...I did this, and I changed modules.conf the same way...adsl faster now...:cool: :Pengy:

humbabba 04-22-2004 06:47 PM

adding the line to modprobe.conf really helped me with this problem. It had been driving me up the wall!

for some reason I am not sure if browsing speed is what it should be, but there is a definate improvement.

peterchao 08-08-2004 03:40 PM

I modify the /etc/modprobe.conf and the browser now faster, but please try this....
Ping an url (Ex. "ping www.apache.org" very slow), ping the ip of the url (Ex. 209.237.227.195) very fast..
Is any same as me....

Dinabandhu 08-16-2004 12:29 AM

Quote:

Originally posted by Stevetgn
I have a problem with very slow browser reaction.
Click a link and it takes for ever to go to that page let alone load the page. Its the same problem with Konqueror, Mozilla 1.7.1, Firefox 0.9.1.

I'm using Mandrake 10 which appart from this very slow annoying problem has been superb.

I also have the same problem on my laptop with the same distro/browsers

I tried a test with both my PC & Laptop plugged into my netgear ADSL/Router. I booted into WinXP on the PC and MDK 10 on the laptop put the same ULR into both and winxp instantly loaded the page while MDK10 on the laptop took for ever. I then booted the other way around... same result. This is obviously a Linux problem not ISP or browser based.

I'm still a bit of a :newbie: can anyone shed any light on this?

If I can sort this out I'm pretty much on my way to dumping xp 'cause everything else is mega with this distro!

Thanks in advance

Steve

:newbie: :Pengy:

SAME DUDE !!!
Except that I am using a D-Link 504 router Modem, But everything is the same.
i am also having trouble getting the internet connection to initialize on boot.
And my nVidia GForce FX 5200 128mg video card is also extremely slow.
HELP ! HElP !!

:D :D :D :D ;) :p
OOOOOOHHHHHH!! YEAH
I have been a member of this forum for ten minutes and am elated that the answer I found here works great. Still canīt initialise internet on boot, but very happy for now, thanks to all.

Answer : open Gedit as root and browse to /etc/modprobe.conf
add these two lines:
alias net-pf-10 ipv4
install ipv4 /bin/true
Save and reboot.

On reboot run terminal as SU
# type the following
# ifup eth0
# type Enter

Run Konquerer

Boy that was fun, (yeah I know, īget a lifeī )

x_mcmunt 08-17-2004 05:23 PM

Same problem happens for those with fedora rc2. From fedorafaq.org (which worked for me) . . .

Quote:

The problem is: Mozilla tries to use IPv6 before it uses IPv4 (IPv4 is the old version). When your Internet connection doesn't support IPv6, Mozilla fails to connect on the first try. In the current version of Mozilla, you can't change this, because of a bug.

So, we have to turn off IPv6 in Fedora:

1. Open a Terminal.
2. Become root:

su -
3. Open the file /etc/modprobe.conf:

gedit /etc/modprobe.conf
4. Add these lines to the end of the file:

# Turn off IPv6
alias net-pf-10 off
alias ipv6 off
5. Now, reboot the machine and sites should load faster!

(Thanks to Jonathan Baron and Chris Hubick for this great tip!)

qwijibow 08-31-2004 08:31 AM

This is a Bug in the latest 2.6 kernel tree... some1 confused a variable with a pointer, as a result, sume funtion designed to report on how much spare bandwidth you have always returns zero... you kernel thinks your connection is maxed out...

this seems to only be a problem when browsing webpages on NON Unix/Linux servers.
you have 2 options.... there is a (non official) patch.. cant remember the link, but google for it...

OR go back to a 2.4 kernel.

cidrolin 08-31-2004 08:40 AM

Have a look to my last contribution to
this post and check which sub-version your 2.6 kernel is...

alberto2498 08-31-2004 03:03 PM

The final way for me to actually turn the darn thing back to IPv4 was by changing the line:

alias net-pf-10 IPv6 ----> alias net-pf-10 IPv4

The file in wich you find that is "modules.alias", usually located in:

/lib/modules/2.6.something/

If you cant find it just locate the file.

dkroft 09-15-2004 03:57 PM

i have been seeing this for a long time -
posted several times, but no good answer yet.

i disabled ipv6 altogether:

/etc/modprobe.conf
alias ipv6 off
alias net-pf-10 off

use both lines - you'll need them

alberto2498 09-16-2004 01:01 PM

Go to post # 47
 
Quote:

Originally posted by dkroft
i have been seeing this for a long time -
posted several times, but no good answer yet.

i disabled ipv6 altogether:

/etc/modprobe.conf
alias ipv6 off
alias net-pf-10 off

use both lines - you'll need them

http://www.linuxquestions.org/questi...47#post1146047

littleking 09-16-2004 03:35 PM

The quick fix is to su to root and do two things:

#echo "net.ipv4.tcp_moderate_rcvbuf=0" >> /etc/sysctl.conf
#echo "net.ipv4.tcp_default_win_scale=0" >> /etc/sysctl.con


All times are GMT -5. The time now is 05:35 PM.