LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 01-15-2004, 09:09 PM   #1
degraffenried13
Member
 
Registered: Sep 2003
Posts: 228

Rep: Reputation: 30
lexmark z13 printer can't get driver


Is there another tool to use to add printers? From the command prompt I started redhat-config-printer and tried to add my lexmark z13 printer. The drivers weren't there so i downloaded the tar file from lexmarks site and ran the *.sh file. It supposedly installed everything. It put 20files in /usr/local/lexmark/ folder.

I noticed that all of the other drivers were .xml files and they were in /usr/share/foomatic/db/source/driver, but none of the z13 files were .xml files so I couldn't just move them into there.

So in the config the z13 doesn't show up. Is there a way to force foomatic to find the z13 drivers or is there a shell prompt config for printers that would be good to use.
 
Old 01-15-2004, 09:15 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 914Reputation: 914Reputation: 914Reputation: 914Reputation: 914Reputation: 914Reputation: 914Reputation: 914
Have a look there ...

http://www.linuxprinting.org/show_pr...um=Lexmark-Z13

linuxprinting.org is the most authoritative
source of info on printers ...




Cheers,
Tink
 
Old 01-15-2004, 09:41 PM   #3
degraffenried13
Member
 
Registered: Sep 2003
Posts: 228

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by Tinkster
Have a look there ...

http://www.linuxprinting.org/show_pr...um=Lexmark-Z13

linuxprinting.org is the most authoritative
source of info on printers ...




Cheers,
Tink
Thanks I will try that, I found that site once before, but got side-tracked on the lexmark site and forgot about it.

thanks again
 
Old 01-15-2004, 10:17 PM   #4
IBall
Senior Member
 
Registered: Nov 2003
Location: Perth, Western Australia
Distribution: Ubuntu, Debian, Various using VMWare
Posts: 2,088

Rep: Reputation: 62
linuxprinting.org lists this printer as a PaperWeight.

I used to own one, it worked fine with windows, but not with linux, even though I had a distro that Lexmark claim is supported, so I ended up chucking it out

I don't think that Lexmark should be able to claim to support linux, when clearly they dont. I suppose you could actually call it false advertising or something. What does anyone else think.

From Ian
 
Old 01-16-2004, 08:30 AM   #5
degraffenried13
Member
 
Registered: Sep 2003
Posts: 228

Original Poster
Rep: Reputation: 30
If I can't get this thing to work, I will agree with you because they are getting my hopes up that I will have a working printer soon with my computer.
 
Old 01-16-2004, 11:50 PM   #6
degraffenried13
Member
 
Registered: Sep 2003
Posts: 228

Original Poster
Rep: Reputation: 30
I posted this at linuxprinting.org, but I haven't gotten any response over there so I thought I would try here. Any ideas?

>
> In article <bu7lnv$b4e$1@poblano.linuxprinting.org>, degraffenried13@yahoo.com
> (Shaun Upjohn) writes:
> >
> > I downloaded and ran the foomatic program that I found on this site for the
> > lexmark z13, and got all the way to the point in the program where it asks if
> I
> > use CUPS, I said both yes and no and received the error:
> > "Could not install your printer with Foomatic! at /usr/sbin/lexmark install
> > line 237, <STDIN> line 4."
> >
> > Any ideas?
>
> The above may be a symptom of what I am experiencing now. I found the z13
> driver when I went to add the printer, but the cpu won't communicate with the
> printer (ie it won't send anything to it to print) It finds the printer okay,
> but won't do anything after that.
>
> the printer is attached to dev/usb/lp0

After deleting the printer out of printer configuration in redhat, I then re_ran the footmatic lexmarkinstall file and it installed the file fine using cups. But the computer won't print a test page or print through lp.
 
Old 01-17-2004, 09:51 AM   #7
degraffenried13
Member
 
Registered: Sep 2003
Posts: 228

Original Poster
Rep: Reputation: 30
I upgraded cups to 1.1.20 and upgraded redhat-config-printer to 0.6.47, and now I can se the errors that show up. Here is what is processed by config-printer:

I [17/Jan/2004:10:47:51 -0500] Adding start banner page "none" to job 19.
I [17/Jan/2004:10:47:51 -0500] Adding end banner page "none" to job 19.
I [17/Jan/2004:10:47:51 -0500] Job 19 queued on 'printer' by 'root'.
I [17/Jan/2004:10:47:51 -0500] Started filter /usr/lib/cups/filter/pstops (PID 1878) for job 19.
I [17/Jan/2004:10:47:51 -0500] Started filter /usr/lib/cups/filter/cupsomatic (PID 1879) for job 19.
I [17/Jan/2004:10:47:51 -0500] Started backend /usr/lib/cups/backend/usb (PID 1880) for job 19.
W [17/Jan/2004:10:47:51 -0500] [Job 19] Media tray empty!

Thanks for any thoughts. I am running out of ideas to try.
 
Old 01-17-2004, 11:25 AM   #8
jsmarshall85
Member
 
Registered: Aug 2003
Posts: 386

Rep: Reputation: 30
i agree. i have a lexmark z605 and the only driver they have for it is a hedhat 9 driver. cant seem to get it to work on my slack9.1 box

to be honest though, im not sure what printing system i have running. i think it is the unix LPD print system. my printer is USB and USB is enabled in the kernel and other things like my keyboard that use usb work fine, but i cant get my printer installed.

any help would be appreciated
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
lexmark z13 install problems. townhallpaul Linux - Hardware 0 10-04-2004 11:10 AM
Using Lexmark Printer Driver mgunkel58 Linux - Newbie 7 09-04-2004 07:30 PM
Lexmark Printer Driver Ralph M Linux - Software 1 06-02-2004 01:18 AM
Lexmark 63 printer driver swamiji Linux - Software 1 01-02-2004 12:47 PM
Cannot install Lexmark printer driver jayelitumbiolo Linux - Newbie 2 10-28-2003 12:26 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 05:34 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration