Help answer threads with 0 replies.
Go Back > Linux Answers > Networking
User Name


By tp11235 at 2005-06-03 10:13
After a lot of trial and error I have got my system connected to the web and working - I thought these notes might help others.

My system is: SuSE 9.1 on a old Pentium III-450 machine. I upgraded the kernel to 2.6.11 a few days ago. Today, since my last post, I also added all the various DHCP rpms from the SuSE FTP site. I don't know if any of that is relevant, but you never know. My broadband connection is Wanadoo 1Mb using their wireless modem/router from Inventel. But don't get your hopes up I connect my Linux machine via an ethernet cable to the Wanadoo modem.

I installed my new ethernet card on the PC, plugged it in to my modem and booted the PC. YaST found the card automatically and configured it as best it could without errors. However, at this stage when I opened the browser and tried to navigate to a website I got the error "Hostname not found".

Next I opened YaST and switched off the firewall in Security and Users then I went to Network Devices. Mostly I left the settings as I found them, but this is the setup that finally worked:

Auto setup via DHCP

Click on "Host Name and Name Servers"
Left Host Name and Domain Name as "Linux" and "Site" - I may change these to nicer names later.
Changed Name Server 1 to "" (I think this is pretty universal for UK broadband users) and Domain Search 1 to "Wanadoo-nnnn"

That last one was probably the vital change. nnnn is a number on my system that I do not think I should broadcast - look on your own hardware for yours. The name was printed on the bottom of my modem. On other systems this might be the name Windows gives the network when it configures it.

Click on Routing and set the default gateway to

No changes to the Advanced settings.

I then went to Network Services and clicked on DNS and Host Names. I checked that the Name Server and Domain search were as above. I think it is carried over by the system, but worth a check.

Finally I rebooted, then restarted the firewall - DON'T FORGET.

Opened the browser and navigated straight to this site!

Good luck - it is worth the perseverance . Which is more than can be said for wireless networking. If anybody has got the wireless side to work let me know.

by 1Randall on Thu, 2005-10-27 20:28
Anybody know if this would work if the modem is connected via USB?


All times are GMT -5. The time now is 09:51 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration