LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   Samba problem: Unable to browse/access Windows network (http://www.linuxquestions.org/questions/ubuntu-63/samba-problem-unable-to-browse-access-windows-network-531829/)

cdrom600 02-23-2007 06:06 PM

Samba problem: Unable to browse/access Windows network
 
I have Samba installed on my Ubuntu 6.10 machine. It is on a network with several Windows computers. I have finally configured Samba, with the help of the swat tool, to enable the Windows computers to see and access my shared files.

However, I am unable to browse or access any of the Windows computers from my Ubuntu computer using the Nautilus file browser. I've not tried any command-line Samba tool (I will try this ASAP, though).

(I think this is probably the cause of my printing issue, too.)

I'm not sure where to start troubleshooting. Can somebody please help me?

cdrom600 02-23-2007 07:13 PM

I am going to try the information from this thread to see if it will help. The symptoms it describes are exactly the same as mine; I can access the computers by IP address, but not by name.

Output from smbtree is as follows:
Code:

user@maindesktop-ub:~$ smbtree
Password:
MSHOME
        \\COMPA       
timeout connecting to 208.67.219.40:445
timeout connecting to 208.67.219.40:139
Error connecting to 208.67.219.40 (Operation already in progress)
cli_start_connection: failed to connect to COMPA<20> (208.67.219.40)
        \\COMPB         
timeout connecting to 208.67.219.40:445
timeout connecting to 208.67.219.40:139
Error connecting to 208.67.219.40 (Operation already in progress)
cli_start_connection: failed to connect to COMPB<20> (208.67.219.40)
        \\COMP3                        COMP3 server (Samba 3.0.14a-Debian)
timeout connecting to 208.67.219.40:445
timeout connecting to 208.67.219.40:139
Error connecting to 208.67.219.40 (Operation already in progress)
cli_start_connection: failed to connect to COMP3<20> (208.67.219.40)
        \\COMP4                    Living Room
timeout connecting to 208.67.219.41:445
timeout connecting to 208.67.219.41:139
Error connecting to 208.67.219.41 (Operation already in progress)
cli_start_connection: failed to connect to COMP4<20> (208.67.219.41)
        \\MAINDESKTOP              maindesktop-ub (Samba 3.0.22, Ubuntu 6
timeout connecting to 208.67.219.41:445
timeout connecting to 208.67.219.41:139
Error connecting to 208.67.219.41 (Operation already in progress)
cli_start_connection: failed to connect to MAINDESKTOP<20> (208.67.219.41)


camorri 02-23-2007 07:16 PM

Have you got the samba-client installed? Take a look with Synaptic package manager to see if it is installed. If not, install it and try again.

cdrom600 02-23-2007 07:26 PM

Code:

user@maindesktop-ub:~$ sudo apt-get install samba-client
Password:
Reading package lists... Done
Building dependency tree     
Reading state information... Done
Package samba-client is a virtual package provided by:
  smbclient 3.0.22-1ubuntu4.1
You should explicitly select one to install.
E: Package samba-client has no installation candidate

user@maindesktop-ub:~$ sudo apt-get install smbclient
Reading package lists... Done
Building dependency tree     
Reading state information... Done
smbclient is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

It looks like samba-client is associated with smbclient, which is already installed. A search in Synaptic for 'samba-client' yields no results.

Brian1 02-23-2007 07:27 PM

Have you define the IP address to hostname in /etc/hosts?

This is the only way linux will now what a hostname is equal to an IP. It does not work like Windows Networking.

Brian

inspiron_Droid 02-23-2007 07:29 PM

set the following veriable in the /etc/samba/smb.conf file.

workgroup= MSHOME

not the work group name must be Capitalized or you will no be able to vie, read or write to the windows machines.

PTrenholme 02-23-2007 07:31 PM

Check to see if the nmbd service is running. If it's not, you should

1) See if you can get it running
2) If you can't (and, on my system, for some reason it can't find the url of the network), then change the method Nautilus uses to search for shares to be smbclient instead of the default method (sorry, forgot its name) that requires a running nmbd service. (There should be an option for setting the search method in the Nautilus configuration screens. I say "should" because I use KDE, and there is such a setting for konqueror, but I don't know for sure if there is one for Nautilus.)

cdrom600 02-23-2007 07:47 PM

Quote:

Originally Posted by Brian1
Have you define the IP address to hostname in /etc/hosts?

This is the only way linux will now what a hostname is equal to an IP. It does not work like Windows Networking.

No, I haven't. This would not work for very long anyway; this home network uses DHCP to assign IP addresses.
From most of what I've read, it is possible to get Ubuntu to resolve netbois names.

Quote:

Originally Posted by flanksteak
set the following veriable in the /etc/samba/smb.conf file.

workgroup=...

My workgroup is set correctly.

Quote:

Originally Posted by PTrenholme
Check to see if the nmbd service is running.

Code:

$ ps -e | grep nmbd
 5158 ?        00:00:00 nmbd


cdrom600 02-23-2007 07:56 PM

From what I've read, I gather the winbindd service must be running to resolve WINS/Netbios names. I've installed winbind:
Code:

$ sudo apt-get install winbind
Reading package lists... Done
Building dependency tree     
Reading state information... Done
winbind is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

But it isn't running (ps -e | grep winbindd finds nothing).

I've restarted the machine.

If I try to run it, it either doesn't start or starts and then stops; I cannot tell:
Code:

$ sudo winbindd
$ ps -e | grep winbindd


cdrom600 02-23-2007 08:03 PM

Never mind this post

cdrom600 02-23-2007 08:08 PM

Apparently, rebooting the machine and manually running 'sudo /etc/init.d/winbind start' fixes this issue. Let me do some testing; I'll be back later tonight or tomorrow with details.

redwing57 02-26-2007 10:55 AM

I will be interested to see how this is resolved. I haven't heard of winbind, and I had this same problem.

On my own network, I set each linux machine to a fixed IP address. The router still uses DHCP, but happily assigns the chosen IP address for each machine. Once the IPs and hostnames are entered in the hosts file, the samba network works well.

Rob

cdrom600 02-27-2007 08:22 PM

I haven't had much time to research this, but as far as I can tell, installing winbind is what solved this. There are a few guides on the Ubuntu forums - try looking there. I don't think that winbindd is still running constantly, but using the command I mentioned above to run it ('sudo /etc/init.d/winbind start') might help.
Other than this, I'm really not sure exactly what would help.


All times are GMT -5. The time now is 11:12 AM.