LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 02-23-2007, 06:06 PM   #1
cdrom600
Member
 
Registered: Oct 2003
Location: MI, USA
Distribution: Fedora, Ubuntu, Debian
Posts: 63

Rep: Reputation: 15
Samba problem: Unable to browse/access Windows network


I have Samba installed on my Ubuntu 6.10 machine. It is on a network with several Windows computers. I have finally configured Samba, with the help of the swat tool, to enable the Windows computers to see and access my shared files.

However, I am unable to browse or access any of the Windows computers from my Ubuntu computer using the Nautilus file browser. I've not tried any command-line Samba tool (I will try this ASAP, though).

(I think this is probably the cause of my printing issue, too.)

I'm not sure where to start troubleshooting. Can somebody please help me?

Last edited by cdrom600; 02-23-2007 at 06:14 PM.
 
Old 02-23-2007, 07:13 PM   #2
cdrom600
Member
 
Registered: Oct 2003
Location: MI, USA
Distribution: Fedora, Ubuntu, Debian
Posts: 63

Original Poster
Rep: Reputation: 15
I am going to try the information from this thread to see if it will help. The symptoms it describes are exactly the same as mine; I can access the computers by IP address, but not by name.

Output from smbtree is as follows:
Code:
user@maindesktop-ub:~$ smbtree
Password: 
MSHOME
        \\COMPA        
timeout connecting to 208.67.219.40:445
timeout connecting to 208.67.219.40:139
Error connecting to 208.67.219.40 (Operation already in progress)
cli_start_connection: failed to connect to COMPA<20> (208.67.219.40)
        \\COMPB          
timeout connecting to 208.67.219.40:445
timeout connecting to 208.67.219.40:139
Error connecting to 208.67.219.40 (Operation already in progress)
cli_start_connection: failed to connect to COMPB<20> (208.67.219.40)
        \\COMP3                        COMP3 server (Samba 3.0.14a-Debian)
timeout connecting to 208.67.219.40:445
timeout connecting to 208.67.219.40:139
Error connecting to 208.67.219.40 (Operation already in progress)
cli_start_connection: failed to connect to COMP3<20> (208.67.219.40)
        \\COMP4                    Living Room
timeout connecting to 208.67.219.41:445
timeout connecting to 208.67.219.41:139
Error connecting to 208.67.219.41 (Operation already in progress)
cli_start_connection: failed to connect to COMP4<20> (208.67.219.41)
        \\MAINDESKTOP               maindesktop-ub (Samba 3.0.22, Ubuntu 6
timeout connecting to 208.67.219.41:445
timeout connecting to 208.67.219.41:139
Error connecting to 208.67.219.41 (Operation already in progress)
cli_start_connection: failed to connect to MAINDESKTOP<20> (208.67.219.41)

Last edited by cdrom600; 02-23-2007 at 07:23 PM.
 
Old 02-23-2007, 07:16 PM   #3
camorri
Senior Member
 
Registered: Nov 2002
Location: Toronto Canada
Distribution: Slackware 14.0 + 14.1
Posts: 4,781

Rep: Reputation: 415Reputation: 415Reputation: 415Reputation: 415Reputation: 415
Have you got the samba-client installed? Take a look with Synaptic package manager to see if it is installed. If not, install it and try again.
 
Old 02-23-2007, 07:26 PM   #4
cdrom600
Member
 
Registered: Oct 2003
Location: MI, USA
Distribution: Fedora, Ubuntu, Debian
Posts: 63

Original Poster
Rep: Reputation: 15
Code:
user@maindesktop-ub:~$ sudo apt-get install samba-client
Password:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package samba-client is a virtual package provided by:
  smbclient 3.0.22-1ubuntu4.1
You should explicitly select one to install.
E: Package samba-client has no installation candidate

user@maindesktop-ub:~$ sudo apt-get install smbclient
Reading package lists... Done
Building dependency tree       
Reading state information... Done
smbclient is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
It looks like samba-client is associated with smbclient, which is already installed. A search in Synaptic for 'samba-client' yields no results.
 
Old 02-23-2007, 07:27 PM   #5
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,697

Rep: Reputation: 61
Have you define the IP address to hostname in /etc/hosts?

This is the only way linux will now what a hostname is equal to an IP. It does not work like Windows Networking.

Brian
 
Old 02-23-2007, 07:29 PM   #6
inspiron_Droid
Member
 
Registered: Dec 2006
Distribution: Debian (Wheeze)
Posts: 391

Rep: Reputation: Disabled
set the following veriable in the /etc/samba/smb.conf file.

workgroup= MSHOME

not the work group name must be Capitalized or you will no be able to vie, read or write to the windows machines.
 
Old 02-23-2007, 07:31 PM   #7
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,141

Rep: Reputation: 329Reputation: 329Reputation: 329Reputation: 329
Check to see if the nmbd service is running. If it's not, you should

1) See if you can get it running
2) If you can't (and, on my system, for some reason it can't find the url of the network), then change the method Nautilus uses to search for shares to be smbclient instead of the default method (sorry, forgot its name) that requires a running nmbd service. (There should be an option for setting the search method in the Nautilus configuration screens. I say "should" because I use KDE, and there is such a setting for konqueror, but I don't know for sure if there is one for Nautilus.)
 
Old 02-23-2007, 07:47 PM   #8
cdrom600
Member
 
Registered: Oct 2003
Location: MI, USA
Distribution: Fedora, Ubuntu, Debian
Posts: 63

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Brian1
Have you define the IP address to hostname in /etc/hosts?

This is the only way linux will now what a hostname is equal to an IP. It does not work like Windows Networking.
No, I haven't. This would not work for very long anyway; this home network uses DHCP to assign IP addresses.
From most of what I've read, it is possible to get Ubuntu to resolve netbois names.

Quote:
Originally Posted by flanksteak
set the following veriable in the /etc/samba/smb.conf file.

workgroup=...
My workgroup is set correctly.

Quote:
Originally Posted by PTrenholme
Check to see if the nmbd service is running.
Code:
$ ps -e | grep nmbd
 5158 ?        00:00:00 nmbd

Last edited by cdrom600; 02-23-2007 at 07:50 PM.
 
Old 02-23-2007, 07:56 PM   #9
cdrom600
Member
 
Registered: Oct 2003
Location: MI, USA
Distribution: Fedora, Ubuntu, Debian
Posts: 63

Original Poster
Rep: Reputation: 15
From what I've read, I gather the winbindd service must be running to resolve WINS/Netbios names. I've installed winbind:
Code:
$ sudo apt-get install winbind
Reading package lists... Done
Building dependency tree       
Reading state information... Done
winbind is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
But it isn't running (ps -e | grep winbindd finds nothing).

I've restarted the machine.

If I try to run it, it either doesn't start or starts and then stops; I cannot tell:
Code:
$ sudo winbindd
$ ps -e | grep winbindd
 
Old 02-23-2007, 08:03 PM   #10
cdrom600
Member
 
Registered: Oct 2003
Location: MI, USA
Distribution: Fedora, Ubuntu, Debian
Posts: 63

Original Poster
Rep: Reputation: 15
Never mind this post

Last edited by cdrom600; 02-23-2007 at 08:05 PM.
 
Old 02-23-2007, 08:08 PM   #11
cdrom600
Member
 
Registered: Oct 2003
Location: MI, USA
Distribution: Fedora, Ubuntu, Debian
Posts: 63

Original Poster
Rep: Reputation: 15
Apparently, rebooting the machine and manually running 'sudo /etc/init.d/winbind start' fixes this issue. Let me do some testing; I'll be back later tonight or tomorrow with details.
 
Old 02-26-2007, 10:55 AM   #12
redwing57
Member
 
Registered: Jan 2005
Location: Yorktown, VA
Distribution: CentOS, Ubuntu, MEPIS
Posts: 30

Rep: Reputation: 15
I will be interested to see how this is resolved. I haven't heard of winbind, and I had this same problem.

On my own network, I set each linux machine to a fixed IP address. The router still uses DHCP, but happily assigns the chosen IP address for each machine. Once the IPs and hostnames are entered in the hosts file, the samba network works well.

Rob
 
Old 02-27-2007, 08:22 PM   #13
cdrom600
Member
 
Registered: Oct 2003
Location: MI, USA
Distribution: Fedora, Ubuntu, Debian
Posts: 63

Original Poster
Rep: Reputation: 15
I haven't had much time to research this, but as far as I can tell, installing winbind is what solved this. There are a few guides on the Ubuntu forums - try looking there. I don't think that winbindd is still running constantly, but using the command I mentioned above to run it ('sudo /etc/init.d/winbind start') might help.
Other than this, I'm really not sure exactly what would help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Suse 10 - Samba - Windows/Linux can't browse local network MadCowDzz Suse/Novell 26 07-09-2008 11:19 AM
Samba - unable to sync browse lists MikeAtVillage Linux - Networking 6 06-29-2005 03:04 AM
Unable to browse WORKGROUP when samba running mariusak Linux - Networking 10 05-30-2005 06:44 AM
can browse samba network with windows but not linux tuxkwb Linux - Networking 0 12-01-2004 04:52 PM
unable to browse samba share from windows 2003 kfloda Linux - Software 1 08-16-2003 07:14 AM


All times are GMT -5. The time now is 09:06 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration