LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 02-18-2006, 12:22 AM   #1
delamatrix
Member
 
Registered: Nov 2004
Posts: 43

Rep: Reputation: 15
Upgrading Samba from ver-3.0.4 to current ver-3.0.21b


Hello,

I'm running SLES 9 with samba installed as a PDC. The version of samba installed by default is version 3.0.4. I would like to be running the current stable verion 3.0.21b. How would I go about upgrading cleanly to the latest version, without interrupting my current configuration?

- Delamatrix
 
Old 02-20-2006, 07:38 AM   #2
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
You could try to use the precompiled rpm packages from this source:
ftp://ftp.gwdg.de/linux/suse/project...3.0/i386/sles9
You probably need to adjust your configuration to the new capabilities of the newer version. If I remember correctly, the newer config files will be saved as rpm.new-something.
 
Old 02-20-2006, 10:42 AM   #3
delamatrix
Member
 
Registered: Nov 2004
Posts: 43

Original Poster
Rep: Reputation: 15
abisko00, thanks for the reply. I guess what I was really trying to ask was do I have to uninstall all the samba packages through yast and then the install the new samba through yast also. Or, is there a way to just upgrade the existing packages with the new one?

- Delamatrix
 
Old 02-20-2006, 10:56 AM   #4
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
I'd recommend to update the packages with the new one. This way you shouldn't lose the configuration. I have never done this, though.
To do the update, download the packages to an empty directory and install with rpm -Uhv *.rpm. Run /sbin/SuSEconfig after the installation to update some system scripts.

Anyway, I recommend to backup your current configuration files first.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ver 2 Compiler With Ver 3. Kernel wat to do? cam34 Linux - Software 3 08-31-2003 06:15 PM
Ver. 2 @ Ver. 3 Compiler / WinModem Prob. cam34 Linux - Software 1 08-31-2003 03:55 PM
Redhat Ver 7 vs Ver 7.1 mullapudy Linux - Newbie 2 10-18-2001 01:01 PM
Problems upgrading XFree86 to ver. 4.0.2 froycard Linux - Software 2 05-18-2001 05:08 PM
Upgrading XFree86 to ver. 4.03 with RED HAT 6.1 froycard Linux - Software 2 05-12-2001 01:47 PM


All times are GMT -5. The time now is 10:17 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration