LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 07-13-2005, 11:34 PM   #1
RoaCh Of DisCor
Member
 
Registered: Apr 2004
Location: Washington State
Distribution: SuSE 9.3 / Slackware-Current
Posts: 701

Rep: Reputation: 30
modprobe.conf -- not working.


Ok, so I upgraded to a new kernel *compiled it myself*. Afterward, I noticed my network card, usb harddrive, and subfs were all not working. No problem..if I probe them by hand, all is fine. However, I want them to start at boot. I added this to my modprobe.conf:

Code:
alias eth0 8139too
alias ehci_hcd ehci-hcd
alias sub-fs subfs
Oddly enough, I still need to probe them manually. I wasn't exactly sure on how to do this...but tried my best.

Suggestions?

-RoaCh

Last edited by RoaCh Of DisCor; 07-13-2005 at 11:56 PM.
 
Old 07-14-2005, 03:02 AM   #2
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
Try a different approach:

add those modules to /etc/sysconfig/kernel

Code:
## Path:		System/Kernel
## Description:		Modules to load after initial boot
## Type:		string
## ServiceRestart:	boot.loadmodules
#
# This variable contains the list of modules to be loaded
# once the main filesystem is active
#
MODULES_LOADED_ON_BOOT="8139too ehci-hcd subfs"
 
Old 07-14-2005, 06:25 AM   #3
Looking_Lost
Senior Member
 
Registered: Apr 2003
Location: Eire
Distribution: Slackware 12.0, OpenSuse 10.3
Posts: 1,120

Rep: Reputation: 45
I don't think Suse 9.3 rely's particulary upon aliases in modprobe.conf for network interfaces anymore.

Have a look in /etc/sysconfig/hardware

cat each of the hwcfg-bus-pci files to see if any of them contain something like

MODULE='8139too'
MODULE_OPTIONS=''
STARTMODE='auto'

You should be able to get the last part of bus pci for eth0 when it's runing by doing

getcfg eth0

and looking at the line like this (from mine)

HWD_DEVICEPATH=/sys/devices/pci0000:00/0000:00:0a.0/0000:02:01.0;

so on my system it's the file:

/etc/sysconfig/hardware/hwcfg-bus-pci-0000:02:01.0
 
Old 07-14-2005, 06:38 AM   #4
broch
Member
 
Registered: Feb 2005
Distribution: Arch current, SuSe 10.1 32-bit, FreeBSD current, OpenBSD 4.0
Posts: 453

Rep: Reputation: 30
Did you compile submount?
This is not a part of vanilla kernel, so I don't know what are you expecting? Sort of miracle? In your previous tread I have explained that you need to compile submount separately.

EHCI is compiled in the kernel, not as a module by default. Have you changed it? Also Realtek is compiled into kernel. 2.6.12 (at least on SuSE) will have problems with NICs compiled as a modules, so if you have changed it you may need to recompile kernel with build-in NIC, and EHCI. As I explained before submount is not a part of the kernel.
 
Old 07-14-2005, 08:43 AM   #5
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
Quote:
EHCI is compiled in the kernel, not as a module by default. Have you changed it? Also Realtek is compiled into kernel. 2.6.12 (at least on SuSE)
In the standard kernel of 9.3, both ehci-hcd and the realtek drivers are compiled as modules in the default configuration.
Code:
/lib/modules/2.6.11.4-20a-default/kernel/drivers/usb/host/ehci-hcd.ko
/lib/modules/2.6.11.4-20a-default/kernel/drivers/net/8139cp.ko
/lib/modules/2.6.11.4-20a-default/kernel/drivers/net/8139too.ko
Code:
user@linux:/usr/src/linux-2.6.12> cat .config | grep EHCI
CONFIG_USB_EHCI_HCD=m
Since he told us that the manual loading of the drivers works, one must assume that the modules are present.
Quote:
In your previous tread I have explained that you need to compile submount separately.
So he may has taken your advice.
 
Old 07-14-2005, 08:50 AM   #6
broch
Member
 
Registered: Feb 2005
Distribution: Arch current, SuSe 10.1 32-bit, FreeBSD current, OpenBSD 4.0
Posts: 453

Rep: Reputation: 30
Quote:
In the standard kernel of 9.3
He kompiled 2.6.12 (read his previous tread). This is not SuSE kernel this is vanilla. So your examples are rather useless. I know how default SuSE kernel is configured.

In 2.6.12 SuSE has problems with NIC kompilad as modules (and this is not the case for 2.6.11.x)
 
Old 07-14-2005, 08:53 AM   #7
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
Read my post, I quoted the default config of 2.6.12 for the ehci module.

BTW: did I mention that I really don't like your style?

Last edited by abisko00; 07-14-2005 at 08:55 AM.
 
Old 07-14-2005, 11:49 AM   #8
broch
Member
 
Registered: Feb 2005
Distribution: Arch current, SuSe 10.1 32-bit, FreeBSD current, OpenBSD 4.0
Posts: 453

Rep: Reputation: 30
Nope this is not a default config. Probably you have copied config of 2.6.11.4-20a-default to the new kernel and started from there.

That is not a default config of 2.6.12

default (not edited) portion of 2.6.12 config looks different:
#
# USB Host Controller Drivers
#
CONFIG_USB_EHCI_HCD=y <-
# CONFIG_USB_EHCI_SPLIT_ISO is not set
# CONFIG_USB_EHCI_ROOT_HUB_TT is not set
CONFIG_USB_OHCI_HCD=y
# CONFIG_USB_OHCI_BIG_ENDIAN is not set
CONFIG_USB_OHCI_LITTLE_ENDIAN=y
CONFIG_USB_UHCI_HCD=y
# CONFIG_USB_SL811_HCD is not set

and default Realtek looks like this:
CONFIG_8139CP=y <-
CONFIG_8139TOO=y <-
# CONFIG_8139TOO_PIO is not set
# CONFIG_8139TOO_TUNE_TWISTER is not set
# CONFIG_8139TOO_8129 is not set
# CONFIG_8139_OLD_RX_RESET is not set


In other words your "default" kernel is not really default.
loading all the crap from default SuSE kernel really makes no sense.

Last edited by broch; 07-14-2005 at 11:51 AM.
 
Old 07-14-2005, 11:59 AM   #9
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
I can tell you what I did:

download and unpack linux-2.6.12.tar.gz from kernel.org
make config
answer all questions with the default setting.

The result is shown above.

EDIT: Maybe we should open another thread for this type of discussion. I feel a little bad about hijacking another thread.

Last edited by abisko00; 07-14-2005 at 12:00 PM.
 
Old 07-14-2005, 12:25 PM   #10
broch
Member
 
Registered: Feb 2005
Distribution: Arch current, SuSe 10.1 32-bit, FreeBSD current, OpenBSD 4.0
Posts: 453

Rep: Reputation: 30
yes, I did. The above part of config is taken from 2.6.12.

however command
#make config
will not show default options. It only allow to select one of tree (N/m/y) choices. so what defaults you see there? If I run
make config
and save it without any changes I still get
EHCI in the kenel, not module, same goes with Realtek. So whatever you do it is not default.

Last edited by broch; 07-14-2005 at 12:52 PM.
 
Old 07-14-2005, 02:19 PM   #11
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
...so we have to think about what 'make config' does. Two people seem to do the same thing and get different results. I simply be as ignorant as you are and ignore that you claim I must have done something wrong. I end this discussion (hey, chance of last word again!), because this has nothing to do with the original thread.
 
Old 07-14-2005, 10:39 PM   #12
RoaCh Of DisCor
Member
 
Registered: Apr 2004
Location: Washington State
Distribution: SuSE 9.3 / Slackware-Current
Posts: 701

Original Poster
Rep: Reputation: 30
Thanks for all the suggestions. Sadly my nvidia drivers didn't work with the newest kernel yet anyway...so I reinstalled SuSE's latest stable kernel with yast. All is well now. I'll try again, once the nvidia driver's can be built with a 2.6.12 kernel.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
rc.modules, modprobe.conf????? nostromo Slackware 7 10-04-2005 09:53 AM
modprobe.conf from modules.conf Vaxon Linux - Hardware 1 09-22-2004 05:22 AM
[FC2] How to write a modprobe.conf from a module.conf??? Coume Fedora 0 05-31-2004 03:40 AM
modprobe.conf 2.6.2 DIY Tanguy Linux - Software 2 02-10-2004 10:17 AM
modprobe.conf howto demmylls Linux - General 1 01-21-2004 10:11 AM


All times are GMT -5. The time now is 10:38 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration