LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 08-28-2006, 12:11 PM   #1
gbport
LQ Newbie
 
Registered: Aug 2006
Posts: 6

Rep: Reputation: 0
Migrating from OnBoard Video to PCI


I have an HPPavilion a1040n, with an onboard Intel 915g video chip. I put a GeForce 6200 PCI card in. I'm running Suse 10.0.
I changed the bios to disable onboard video. Suse hangs in the splash. It also hangs on safe mode. The relevent message is agpgart: detected an Intel 915g chipset. I re-enabled to the oboard video. I plug the monitor in, and it worked. I got Sax2 to recognize the new card. Tried it again, same result. Then, keeping the onboard video re-enabled, I plugged the monitor into the GeForce. Naturally, the screen was blank until the log in screen. Then the screen came to life. After that, the video worked fine (albeit in 2-d, I still haven't been able to install nvidia drivers. But that is another issue).
I go into YAST, and then to hardware. Selecting video card gets me to Sax2. I uncheck display one, the 915g, and check display 2. I have the proper Nvidia drivers and the 3d is working fine. But, when I set the BIOS to PCI, Linux still hangs up after grub but before login. The Nvidia board will work if the BIOS is set to onboard, at the login. The Hardware information module reports the 915g
I believe that the problem is Suse, on boot, won't recognize the GeForce. It is expecting the onboard and if it is disabled, the system hangs. If the on board is enabled, then when X windows starts, control shifts to the GeForce. How do I get Suse to recognize the GeForce before X Windows starts?
 
Old 08-28-2006, 12:35 PM   #2
ramram29
Member
 
Registered: Jul 2003
Location: Miami, Florida, USA
Distribution: Debian
Posts: 848
Blog Entries: 1

Rep: Reputation: 47
Try running the kudzu service upon restart. You may also want to raise or lower your resolution. At the boot prompt type: linux vga=791

That's 1024x768 resolution. It should be good for most modern monitors else try vga=788.
 
Old 08-28-2006, 06:41 PM   #3
gbport
LQ Newbie
 
Registered: Aug 2006
Posts: 6

Original Poster
Rep: Reputation: 0
Kuduz is not implemented in Suse. Is there another way to force Suse to ignore the onboard video chips?
 
Old 08-29-2006, 12:44 AM   #4
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Milwaukee, WI
Distribution: Mint
Posts: 6,642

Rep: Reputation: 69
What kinds of problems are you having with the nVidia driver installation? The process only takes about 2 minutes total, and only requires downloading them and then issuing a couple of CLI commands (note: skip trying to install these through YaST, and instead, just to to the nVidia site, download them, then read the instructions. Pay particular attention to the 'SuSE user' subsection) Good luck with it. I'm relatively confident that if you install the drivers, everything will work peachy
 
Old 08-29-2006, 05:00 PM   #5
gbport
LQ Newbie
 
Registered: Aug 2006
Posts: 6

Original Poster
Rep: Reputation: 0
The Nvidia card works fine. The problem is Suse won't boot past the splash if the BIOS is set to PCI. This wouldn't be a problem except that I'm running a dual boot. It's my son's computer and he needs windows to run his games, otherwise he lives in linux. It's a real pain to constantly change the bios and move the plug around. Is there anyway to make Suse not even recognize that the intel 915g is even installed? Since the X windows works fine, the problem is not in the X conf.
 
Old 04-26-2007, 02:02 AM   #6
uruway2000
LQ Newbie
 
Registered: Apr 2007
Distribution: Simply Mepis/PC Linux OS
Posts: 2

Rep: Reputation: 0
ĻSame Problem with motherboard ASRock P4i45gv and Nvidia GeForce FX 5200

Quote:
Originally Posted by gbport
The Nvidia card works fine. The problem is Suse won't boot past the splash if the BIOS is set to PCI. This wouldn't be a problem except that I'm running a dual boot. It's my son's computer and he needs windows to run his games, otherwise he lives in linux. It's a real pain to constantly change the bios and move the plug around. Is there anyway to make Suse not even recognize that the intel 915g is even installed? Since the X windows works fine, the problem is not in the X conf.
Hi, is not imposible to fix this problem, but is annoying, I had tried many times ask support from ASRock, and nothing....
In my case the irq 11 is used by both, the AGP Geforce FX 5200 and the internal intel extreme graphics agp, and windoze can manage this point without any trouble, but in all linux distros, happen this.
I had used SuSe for years and always was a great experience, with the same hardware, (read on-board intel video card), but the day my little son buy the Nvidia GeForce, wow..."party is over", SuSE never boot again, yes grub works fine, but SuSE freezes.

Try this:
These are some of the steps.
1- You connect the monitor to the internal intel agp video card, and select in the BIOS screen, internal agp video card.
2 - You can boot as root with no panic issues), with the integrated video intel agp.
3 - You need to exit x-window/x-server, and always as root, go to init 2 mode and modify you etc/modprobe.d/, for blacklisting "intel_agp"
4 - You need to modify your etc/X11/xorg.conf, in Devices to change "nv" to"nvidia"
add option "NvAGP" "1",
coment BusID line
5 - At this point if you try to install the nvidia drivers, a system error appears and tells you there is no nvidia card connected, (and is true),so ...you need to shut down the system.
6 - Connect the monitor to the Nvidia agp video graphics card
7 - Turn on, enter in BIOS and select AGI(or AGP) video instead of internal agp
8 - If you are lucky, and have "no blackscreen", then install the nvidia drivers, and reboot. But 3D acel. and glx etc. probably donīt work Ok.

Good luck, and please ,donīt take the above description as "the perfect manual", take it as a research guide, (it comes with no warranty) because I had done this some time ago, and really donīt remember exactly if all the steps are with SuSE distro.
Best Regards
Uruway2000
 
Old 04-30-2007, 01:10 AM   #7
uruway2000
LQ Newbie
 
Registered: Apr 2007
Distribution: Simply Mepis/PC Linux OS
Posts: 2

Rep: Reputation: 0
Lightbulb Intel chipsets, with on-board video agp extreme graphics.(845 & 915)

Quote:
Originally Posted by gbport
I have an HPPavilion a1040n, with an onboard Intel 915g video chip. I put a GeForce 6200 PCI card in. I'm running Suse 10.0.
I changed the bios to disable onboard video. Suse hangs in the splash. It also hangs on safe mode. The relevent message is agpgart: detected an Intel 915g chipset. I re-enabled to the oboard video. I plug the monitor in, and it worked. I got Sax2 to recognize the new card. Tried it again, same result. Then, keeping the onboard video re-enabled, I plugged the monitor into the GeForce. Naturally, the screen was blank until the log in screen. Then the screen came to life. After that, the video worked fine (albeit in 2-d, I still haven't been able to install nvidia drivers. But that is another issue).
I go into YAST, and then to hardware. Selecting video card gets me to Sax2. I uncheck display one, the 915g, and check display 2. I have the proper Nvidia drivers and the 3d is working fine. But, when I set the BIOS to PCI, Linux still hangs up after grub but before login. The Nvidia board will work if the BIOS is set to onboard, at the login. The Hardware information module reports the 915g
I believe that the problem is Suse, on boot, won't recognize the GeForce. It is expecting the onboard and if it is disabled, the system hangs. If the on board is enabled, then when X windows starts, control shifts to the GeForce. How do I get Suse to recognize the GeForce before X Windows starts?
Dear friend:
Many people in the forums have reported the same problem with this motherboards, the issue is:
Even if you select at the BIOS the option "PCI" or "AGI"(my case, because my Nvidia Geforce Fx5200 is AGP), when any Linux distro included SuSE, INSTALLS and configure the X-window system, seems to detect always as primary video graphics card, the ON-BOARD one, and xorg configures it properly, and after install when the system reboot it hangs up because finds the two video cards. (I still donīt understand how windoze, an OS inferior in many aspects, can handle this issue and in Linux is still pending the solution since the year 2004). Yes probably these chipsets from intel are not very popular..., and the problem only appears when you add a second video card, but if anyone take a look in the forums, a lot of people reports the problem.
As I tried many many linux distros, and each one is a little diferent, I explain in my previous post, you need to BLACKLIST the intel_agp card, but the mistake is that in SuSE the file you need to modify for that is /etc/modprobe.d.conf.local
after all the lines there, write:
blacklist intel_agp
this prevents xorg from detect and configure the on-board video.
I think you will be closer to fix the problem, but still need to modify the xorg.conf file in devices and modules.
Best regards and hope the above will help you.
Uruway2000
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
intel i820 agpgart xorg.conf onboard pci video card problem x crashes flayzernax Fedora 4 08-10-2006 12:09 PM
PCI/Onboard video conflict joshuamink Linux - Newbie 5 02-26-2006 02:21 AM
PCI/Onboard video conflict joshuamink Linux - Hardware 2 02-24-2006 03:44 PM
Dual Head Video Card and onboard Video basketkase999 Linux - Hardware 1 08-23-2005 01:54 PM


All times are GMT -5. The time now is 01:43 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration