LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 11-06-2007, 04:24 PM   #1
stevec
LQ Newbie
 
Registered: Mar 2004
Location: Bloomington, IN
Posts: 21

Rep: Reputation: 15
Installing PHP5 and mod_php5 on SuSE 9.3 via terminal


I'm trying to install PHP5 and mod_php5 on a production SuSE 9.3 server. The server does not have X so my only access to yast (or anything) is via the terminal.

When I use the terminal yast I can see php5 version 5.1.2 and apache2-mod_php5 version 5.1.2 both as available.

When I attempt to install them though, I get an error: "Package php5-5.1.2-3.1.20060127.i586 was not found on the medium." and a similar error if I try to continue with the mod_php5 install.

Source of installation is: ftp://chuck.ucs.indiana.edu/linux/suse/suse/i386/9.3 and there are no CDs/DVDs even listed as options.

If I just try to do updates through the same server with you they work fine, so I'm sure it's not a problem connecting to the server. This is probably the most perplexing part.


I've also tried downloading and installing RPMs from the internet and installing via:
Code:
rpm -ivh php-5.2.4-3.i386.rpm
Now the downloaded RPM is obviously a different (newer) version than the one in yast. But it gives me a bunch of dependency errors.
Code:
warning: php-5.2.4-3.i386.rpm: V3 DSA signature: NOKEY, key ID 4f2a6fd2
error: Failed dependencies:
        httpd-mmn = 20051115 is needed by php-5.2.4-3
        libaspell.so.15 is needed by php-5.2.4-3
        libc.so.6(GLIBC_2.4) is needed by php-5.2.4-3
        libc.so.6(GLIBC_2.7) is needed by php-5.2.4-3
        libcrypto.so.6 is needed by php-5.2.4-3
        libcurl.so.4 is needed by php-5.2.4-3
        libgmp.so.3 is needed by php-5.2.4-3
        libpspell.so.15 is needed by php-5.2.4-3
        libssl.so.6 is needed by php-5.2.4-3
        php-cli = 5.2.4-3 is needed by php-5.2.4-3
        php-common = 5.2.4-3 is needed by php-5.2.4-3
        rtld(GNU_HASH) is needed by php-5.2.4-3
If I can get either of these versions to work that would be wonderful, I just need something. I'd really like to figure out the top one at some point since it's probably going to prevent me from installing *any* software through yast.

Any help is greatly appreciated. Let me know if there are additional details I can give that might be helpful. Thanks in advance.
 
Old 11-08-2007, 04:38 AM   #2
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 4
Posts: 4,297

Rep: Reputation: 205Reputation: 205Reputation: 205
You could always install apt4suse. Details are here: http://susewiki.org/index.php?title=Install-apt4suse
 
  


Reply

Tags
found, install, package, yast


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
installing src php5 or tar php5 step by step jatender Linux - Software 2 06-28-2007 10:29 AM
installing php5 on apache2 resnostyle Suse/Novell 1 08-18-2006 02:45 PM
help installing PHP5 for Apache blizunt7 Fedora 6 11-03-2005 10:59 AM
Installing PHP5 varunbihani Linux - Software 0 01-07-2005 06:45 AM
Installing Apache2 and PHP5 biglaz Linux - General 1 10-15-2004 10:42 PM


All times are GMT -5. The time now is 01:29 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration