LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   xauth: file /home/semoi/.serverauth.2263 does not exist (http://www.linuxquestions.org/questions/slackware-14/xauth-file-home-semoi-serverauth-2263-does-not-exist-4175446072/)

stf92 01-17-2013 04:25 PM

xauth: file /home/semoi/.serverauth.2263 does not exist
 
Slackware 14.0

Code:

xauth:  file /home/semoi/.serverauth.2263 does not exist
This is the first line output to console when I start X (startx). What can I do?
'touch .serverauth.2263'? Who creates this file?

gnashley 01-19-2013 04:01 AM

That file is created by startx.

stf92 01-19-2013 04:44 AM

But the message says it does not exist, gnashley.

phenixia2003 01-19-2013 05:32 AM

Hello,

Quote:

Originally Posted by stf92 (Post 4872458)
Slackware 14.0

Code:

xauth:  file /home/semoi/.serverauth.2263 does not exist
This is the first line output to console when I start X (startx). What can I do?
'touch .serverauth.2263'? Who creates this file?

Do you have another message(s) following this, if so, can you post them ? Or at least,
post the content of /var/log/Xorg.0.log

--
SeB

GazL 01-19-2013 08:08 AM

It is just "noise".

The run of xauth in the /usr/bin/startx script throws out that message if the file doesn't exist before it creates it. The -q really ought to stop it complaining, but apparently it doesn't. if it really bothers you then you could modify startx to create it with touch just before the xauth command that writes to it, but IMO it is not worth the trouble.

stormtracknole 01-19-2013 09:48 AM

I recently just had this same problem. Is the user account brand new or did you migrate it from a previous installation? That was my problem, I kept the same account from a previous install. I tried to hunt down what was causing the issue, but gave up. What I ended up doing was backup the original account home directory, create a new one and move my files and folder one by one. Your Xorg.log should provided you some clues of what is going on.

H_TeXMeX_H 01-19-2013 09:55 AM

Try:

Code:

chmod 4755 /usr/bin/Xorg
as root.

stf92 01-19-2013 10:43 AM

I must be honest. I have tried to modify the screen saver behavior (from within the GUI, DE= xfce 4.10) several times, and each time with disastrous results: the windows cannot be moved, the windows top bars disappear, etc. Once I chose 'black screen saver'. The next session, what I discribed happened. Another I chose 'Disable screen saver'. Result: the same. So I was forced to erase all hidden files in the home directory. I no longer care about that message, for now. Truly, I would like to be able to disable the screen saver without these side effects.

xfce4-session manager, the xfce session manager, is running. Pehaps running the DE without it?


All times are GMT -5. The time now is 09:10 PM.