LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 01-17-2013, 03:25 PM   #1
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 3,484

Rep: Reputation: 51
xauth: file /home/semoi/.serverauth.2263 does not exist


Slackware 14.0

Code:
xauth:  file /home/semoi/.serverauth.2263 does not exist
This is the first line output to console when I start X (startx). What can I do?
'touch .serverauth.2263'? Who creates this file?
 
Old 01-19-2013, 03:01 AM   #2
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,832

Rep: Reputation: 511Reputation: 511Reputation: 511Reputation: 511Reputation: 511Reputation: 511
That file is created by startx.
 
Old 01-19-2013, 03:44 AM   #3
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 3,484

Original Poster
Rep: Reputation: 51
But the message says it does not exist, gnashley.
 
Old 01-19-2013, 04:32 AM   #4
phenixia2003
Member
 
Registered: May 2006
Location: France
Distribution: Slackware
Posts: 525

Rep: Reputation: 304Reputation: 304Reputation: 304Reputation: 304
Hello,

Quote:
Originally Posted by stf92 View Post
Slackware 14.0

Code:
xauth:  file /home/semoi/.serverauth.2263 does not exist
This is the first line output to console when I start X (startx). What can I do?
'touch .serverauth.2263'? Who creates this file?
Do you have another message(s) following this, if so, can you post them ? Or at least,
post the content of /var/log/Xorg.0.log

--
SeB
 
Old 01-19-2013, 07:08 AM   #5
GazL
Senior Member
 
Registered: May 2008
Posts: 3,974
Blog Entries: 1

Rep: Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380
It is just "noise".

The run of xauth in the /usr/bin/startx script throws out that message if the file doesn't exist before it creates it. The -q really ought to stop it complaining, but apparently it doesn't. if it really bothers you then you could modify startx to create it with touch just before the xauth command that writes to it, but IMO it is not worth the trouble.
 
Old 01-19-2013, 08:48 AM   #6
stormtracknole
Member
 
Registered: Aug 2005
Location: The Big Easy
Distribution: Slackware, RHEL
Posts: 923

Rep: Reputation: 111Reputation: 111
I recently just had this same problem. Is the user account brand new or did you migrate it from a previous installation? That was my problem, I kept the same account from a previous install. I tried to hunt down what was causing the issue, but gave up. What I ended up doing was backup the original account home directory, create a new one and move my files and folder one by one. Your Xorg.log should provided you some clues of what is going on.
 
Old 01-19-2013, 08:55 AM   #7
H_TeXMeX_H
LQ Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285
Try:

Code:
chmod 4755 /usr/bin/Xorg
as root.
 
1 members found this post helpful.
Old 01-19-2013, 09:43 AM   #8
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 3,484

Original Poster
Rep: Reputation: 51
I must be honest. I have tried to modify the screen saver behavior (from within the GUI, DE= xfce 4.10) several times, and each time with disastrous results: the windows cannot be moved, the windows top bars disappear, etc. Once I chose 'black screen saver'. The next session, what I discribed happened. Another I chose 'Disable screen saver'. Result: the same. So I was forced to erase all hidden files in the home directory. I no longer care about that message, for now. Truly, I would like to be able to disable the screen saver without these side effects.

xfce4-session manager, the xfce session manager, is running. Pehaps running the DE without it?
 
Old 03-29-2016, 12:40 PM   #9
Fibonacchoz
LQ Newbie
 
Registered: Mar 2016
Posts: 3

Rep: Reputation: Disabled
I am having the same error as the original poster , this is not a new user account and was just working fine last night ,and turn on my laptop today and get the error message , it will continue to load and when X ( I'm using fluxbox) loads it's just a blank screen, startx is working fine with root and I even went to my users home folder and saw the .serverauth file so confused as to why it's saying it does not exist , also notes after it states that file doesn't exist it say /home/user/.Xauthority not writable ,changes will be ignored , timeout in locking authority file

Last edited by Fibonacchoz; 03-29-2016 at 12:43 PM.
 
Old 03-29-2016, 12:52 PM   #10
offgridguy
Member
 
Registered: Nov 2015
Location: Alberta Canada
Distribution: Windows10, Debian
Posts: 833

Rep: Reputation: 119Reputation: 119
Quote:
Originally Posted by Fibonacchoz View Post
I am having the same error as the original poster , this is not a new user account and was just working fine last night ,and turn on my laptop today and get the error message , it will continue to load and when X ( I'm using fluxbox) loads it's just a blank screen, startx is working fine with root and I even went to my users home folder and saw the .serverauth file so confused as to why it's saying it does not exist , also notes after it states that file doesn't exist it say /home/user/.Xauthority not writable ,changes will be ignored , timeout in locking authority file
Welcome to the forum. If you don't get any results here, perhaps you should start your own thread which would get more exposure.
 
Old 03-29-2016, 01:05 PM   #11
bassmadrigal
Senior Member
 
Registered: Nov 2003
Location: Newport News, VA
Distribution: Slackware
Posts: 2,538

Rep: Reputation: 1107Reputation: 1107Reputation: 1107Reputation: 1107Reputation: 1107Reputation: 1107Reputation: 1107Reputation: 1107Reputation: 1107
If .Xauthority is not writeable, you probably started a program or X session as root using su from your normal user and screwed up permissions in your home directory. Try doing chown -R Fibonacchoz:users /home/Fibonacchoz (replacing Fibonacchoz with your normal username).
 
Old 03-29-2016, 01:23 PM   #12
przemo
Member
 
Registered: Feb 2016
Location: cork.ie
Distribution: Slackware 14.2, Debian 8.3
Posts: 81

Rep: Reputation: Disabled
http://www.linuxquestions.org/questi...st-4175576123/
is there chance that both topic`s can be joined as it is same problem and i bet same solution.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] /usr/bin/xauth: creating new authority file /home/username/.Xauthority rjo98 Linux - Newbie 9 12-21-2010 07:27 PM
[SOLVED] x broken: .serverauth does not exist 2handband Slackware 3 11-17-2010 10:01 PM
RHEL 3 problems with XAUTH on shared $HOME dahacker Linux - Desktop 1 05-05-2008 11:03 AM
RHEL3 XAUTH problems with shared home dahacker Linux - Enterprise 0 05-05-2008 10:10 AM
Xauth will not unlock a file at /home/username javpra Linux - Newbie 3 09-08-2004 07:36 PM


All times are GMT -5. The time now is 06:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration