LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-03-2005, 04:26 AM   #1
Andriy
Member
 
Registered: Dec 2005
Distribution: Slackware, SLAX, Redhat, Fedora
Posts: 133

Rep: Reputation: 15
Still can't establish a pppoe connection


I have read other threads regarding this and I still dont get it why I can't connect to the internet using pppoe.

I have read the manual too and set it up through using netconfig, pppoe-setup and checking my device using ifconfig -a.

My ethernet card is a SURECOM EP-320X-R and my ADSL router is a zyxel 650-31R. I don't have a static ip so I set it up to use DHCP. I noticed during shutdown that /sbin/dhcpcd is not running. Even if I execute it manually and get the MAC address of my ethernet card, I still cant connect using pppoe-start. I always get a Timed Out message.

Btw, I am relatively new to Linux and I chose Slackware as my learning ground. Hope someone can shed light regarding my problem. Thanks.
 
Old 12-03-2005, 05:00 AM   #2
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
First question, do you actually have to login to your ISP using a PPPoE client or does the modem does that for you? (I checked and your modem supports that feature).
If that's the case, you just need to setup netconfig to get a DHCP address.
 
Old 12-03-2005, 09:18 PM   #3
Andriy
Member
 
Registered: Dec 2005
Distribution: Slackware, SLAX, Redhat, Fedora
Posts: 133

Original Poster
Rep: Reputation: 15
In windows, I have to login first. My ISP supplied me with a username and pass. I hope that additional info will help you help me. =(
 
Old 12-04-2005, 05:28 AM   #4
carboncopy
Senior Member
 
Registered: Jan 2003
Location: Malaysia
Distribution: Fedora Core, Slackware, Mac OS X, Debian, OpenSUSE
Posts: 1,210
Blog Entries: 4

Rep: Reputation: 45
I assume you are using a ADSL modem. If you are using a router, then the username and password goes into the router. But since, you got to logom first in windows, I assume it is ADSL modem.

First of all, you do not need dhcp client when using pppoe.
So, you do not need to set any settings for your NIC connected to the modem. You can clear the settings in your /etc/rc.d/rc.inet1.conf. The following is how it looks like for my NIC which is connected to the modem.

Code:
# Config information for eth1:
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]=""
DHCP_HOSTNAME[1]=""
Give pppoe-start a try and see what the results is.
 
Old 12-04-2005, 08:26 AM   #5
Andriy
Member
 
Registered: Dec 2005
Distribution: Slackware, SLAX, Redhat, Fedora
Posts: 133

Original Poster
Rep: Reputation: 15
I tried to set it as you said in the above post. Unfortunately, It still doesnt work. I still get the same timed out message. Are there any configurations that I need to check or alter? By the way that would be a direct connection and I am not in a LAN.
 
Old 12-04-2005, 11:53 AM   #6
carboncopy
Senior Member
 
Registered: Jan 2003
Location: Malaysia
Distribution: Fedora Core, Slackware, Mac OS X, Debian, OpenSUSE
Posts: 1,210
Blog Entries: 4

Rep: Reputation: 45
Does your modem have a Ethernet activity LED indicator?
If yes, when you dial (pppoe-start) was there blinking to indicate activity?

You can check the log file for signs of what when wrong.

Code:
grep pppoe /var/log/syslog
Do you see such entry?
Code:
Nov 17 09:38:45 carboncopy pppoe[3139]: Timeout waiting for PADO packets
Or you can dump the output here.

You can also tail -f /var/log/syslog in one terminal while you connect using pppoe-status in another terminal.

By the way can you post ifconfig output here as well?
 
Old 12-04-2005, 09:35 PM   #7
Andriy
Member
 
Registered: Dec 2005
Distribution: Slackware, SLAX, Redhat, Fedora
Posts: 133

Original Poster
Rep: Reputation: 15
Yes. There is an activity LED on both the ethernet and the modem. DSL led is also present. This is what I got from my syslog:

Nov 29 12:31:14 Bratwurst pppoe[2699]: read (asyncReadFromPPP): Session 9106: Input/o
utput error
Nov 30 09:10:30 Bratwurst pppoe-sniff: recv (receivePacket): Network is down
Nov 30 09:12:06 Bratwurst pppoe[1554]: read (asyncReadFromPPP): Session 55478: Input/ output error


and here is what happened sometime after trying pppoe-start and pppoe-status command:

bash-3.00# pppoe-start
bash-3.00# pppoe-start
pppoe-start: There already seems to be a PPPoE connection up (PID 1569)
bash-3.00# pppoe-statu
bash: pppoe-statu: command not found
bash-3.00# pppoe-status
pppoe-status: Link is down -- could not find interface corresponding to
pppd pid 1597


here is my ifconfig -a:

eth0 Link encap:Ethernet HWaddr 00:02:44:8F:88:6F
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:2360 (2.3 Kb)
Interrupt:10 Base address:0xb000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
 
Old 12-04-2005, 11:10 PM   #8
Kristijan
Member
 
Registered: Sep 2003
Location: Melbourne, Australia
Distribution: NetBSD 3.0.1, Slackware 10.1
Posts: 394

Rep: Reputation: 30
Andriy,

Can you post the output of;

Code:
route -n
You should have the address of your aDSL modem set as the default gateway.

If it's not, try the following and see how you go;

Code:
route add default gw 192.168.0.1
NOTE:- Change the IP address to your aDSL modem.

Let me know how you go.

Good luck,
Kristijan
 
Old 12-04-2005, 11:52 PM   #9
Andriy
Member
 
Registered: Dec 2005
Distribution: Slackware, SLAX, Redhat, Fedora
Posts: 133

Original Poster
Rep: Reputation: 15
This is what I got upon running route -n:

bash-3.00# route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
bash-3.00#


This is what I got upon running route add default gw 192.168.0.1

bash-3.00# route add default gw 192.168.0.1
SIOCADDRT: Network is unreachable


By the way, in MS Windows I have this ipconfig:

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : SURECOM EP-320X-R 100/10/M PCI Adapt
er
Physical Address. . . . . . . . . : 00-02-44-8F-88-6F
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Autoconfiguration IP Address. . . : 169.254.199.116
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :


So my question is: should I set my ip address the same way as displayed with the autoconfigured ip add (169.254.199.116)? I dont even know if that is for the ethernet or the modem or both. But one thing I know is that this modem is acting as a bridge to my ISP.
 
Old 12-05-2005, 01:53 AM   #10
Kristijan
Member
 
Registered: Sep 2003
Location: Melbourne, Australia
Distribution: NetBSD 3.0.1, Slackware 10.1
Posts: 394

Rep: Reputation: 30
Andriy,

The 192.168.0.1 address that I put in was just an example. You need to change this address to the internal IP address assigned to your aDSL modem.

Looking at the output from your Windows ipconfig, it's tell me that you don't have a DHCP server running at all. The 169.254.*.* address is automatically assigned to the interface when it cannot locate a DHCP server. This would explain why in Linux you are getting a time out message.

How do you have your modem connected to you PC, is it via an Ethernet cable...or something else like USB? I'm just trying to visualize how you have everything hooked up. Maybe you can draw up a quick diagram or how your set up is currently working on Windows and post the URL here?

Regards,
Kristijan
 
Old 12-05-2005, 01:58 AM   #11
Andriy
Member
 
Registered: Dec 2005
Distribution: Slackware, SLAX, Redhat, Fedora
Posts: 133

Original Poster
Rep: Reputation: 15
Yes, via an ethernet cable. My workstation is connected to an ADSL router/modem that acts as a bridge to my ISP.

PC ---> eth0 ---> ADSL modem/router ---> INTERNET

I thank you in advance for your patience.
 
Old 12-05-2005, 02:15 AM   #12
Kristijan
Member
 
Registered: Sep 2003
Location: Melbourne, Australia
Distribution: NetBSD 3.0.1, Slackware 10.1
Posts: 394

Rep: Reputation: 30
Andriy,

Your best bet would be to configure the DHCP server for your modem. Log into the modem (web) interface and enable the DHCP server. Never used a Surecom modem/router, but I'm sure it wouldnt be that difficult. Just fill in all the necessary details and restart.

This should hopefully eliminate your DHCP timeout issues.

The other option would be to assign a static IP address to you PC and a static IP address to your modem.

Example:
Code:
           PC               --->            ADSL  
192.168.0.2/255.255.255.0         192.168.0.1/255.255.255.0
Then on your Linux workstation, you will have to apply the following changes.

1. Change the IP address of your eth0
Code:
ifconfig eth0 192.168.0.2 netmask 255.255.255.0
2. Add the default gateway
Code:
route add default gw 192.168.0.1
3. Edit /etc/resolv.conf
In this file you should have the IP address of the DNS servers which your ISP has provided.
Code:
nameserver 203.12.160.35
nameserver 203.12.160.36
A DHCP server will be the easier option, and be more convenient if your network expands. Try the DHCP option first, and let me know how you go. You can always go back and try the static option.

Regards,
Kristijan
 
Old 12-05-2005, 08:22 AM   #13
Andriy
Member
 
Registered: Dec 2005
Distribution: Slackware, SLAX, Redhat, Fedora
Posts: 133

Original Poster
Rep: Reputation: 15
I dont think I can configure my modem's DHCP setting without my ISP's permission. Is there another way to do it without changing my current modem setting? Also, my ISP did not provide me with and IP address for their nameserver. I would also like to clarify that my modem is a zyxel 650 series and not a surecom. surecom is my ethernet card.
 
Old 12-05-2005, 09:59 AM   #14
maginotjr
Member
 
Registered: Aug 2004
Location: BR - Floripa
Distribution: Ubuntu 9.10 - 2.6.x.x
Posts: 661

Rep: Reputation: 34
you dont need permission of ISP to configure your modem....

you can make your modem be a Modem (you dial first then connect, always need a machine to dial first) or router (you are always connected to the internet and you can plug many computer as you want through a switch connected to your router) if you dont know how to configure it just call to your isp and ask for information and they will give.

[ ]'s
 
Old 12-05-2005, 11:11 AM   #15
Andriy
Member
 
Registered: Dec 2005
Distribution: Slackware, SLAX, Redhat, Fedora
Posts: 133

Original Poster
Rep: Reputation: 15
You dont get it. I cant access the configuration menu for my modem. I think my ISP changed it. Until the tech service (which I was requesting for almost a week now)arrives, I will not have a clear cut procedure on what and how to do this on my linux os. So, If there's another way to do this, I would be glad to hear it. Thank you very much for the concern.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
unable to establish connection neerajchaudhari Linux - Software 2 09-14-2005 11:22 PM
I can't establish a connection in my router Murilo Linux - Wireless Networking 1 08-18-2005 03:04 PM
Please help me establish an internect connection AlexBell Linux - Hardware 1 05-23-2005 01:11 PM
cannot establish dial up connection Mr_C Linux - Networking 5 06-03-2004 11:32 PM
cannot establish a connection to my internet Jjurk Linux - Newbie 7 03-05-2004 05:49 AM


All times are GMT -5. The time now is 10:24 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration