LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-26-2008, 05:13 PM   #1
kissfreeman
LQ Newbie
 
Registered: Aug 2007
Posts: 8

Rep: Reputation: 0
Unhappy smokeping Can't locate BER.pm in @INC


I am trying to install smokeping but keep failing because of this error:

Can't locate BER.pm in @INC (@INC contains: /usr/local/smokeping/lib /usr/local/rrdtool-1.2.0/lib/perl/5.8.8/i486-linux-thread-multi /usr/local/rrdtool-1.2.0/lib/perl/5.8.8 /usr/local/rrdtool-1.2.0/lib/perl /usr/lib/perl5/5.8.8/i486-linux-thread-multi /usr/lib/perl5/5.8.8 /usr/lib/perl5/site_perl/5.8.8/i486-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.8/i486-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl .) at /usr/local/smokeping/lib/SNMP_util.pm line 40.
BEGIN failed--compilation aborted at /usr/local/smokeping/lib/SNMP_util.pm line 40.
Compilation failed in require at /usr/local/smokeping/lib/Smokeping.pm line 9.
BEGIN failed--compilation aborted at /usr/local/smokeping/lib/Smokeping.pm line 9.
Compilation failed in require at ./smokeping line 7.
BEGIN failed--compilation aborted at ./smokeping line 7.

Help would be great
 
Old 05-26-2008, 06:08 PM   #2
mRgOBLIN
Slackware Contributor
 
Registered: Jun 2002
Location: New Zealand
Distribution: Slackware
Posts: 999

Rep: Reputation: 226Reputation: 226Reputation: 226
looks like you don't have BER.pm installed. It's a perl module.

You could install with CPAN (as root)
Code:
perl -MCPAN -e "install Convert::BER"
Be prepared to answer a few questions if you have never run CPAN before.

or you might grab and install it manually from here http://search.cpan.org/src/GBARR/Convert-BER-1.3101/ but you may or may not need to satisfy some dependencies with this method.

SmokePing will likely list the required Perl modules and any other dependencies in the README/INSTALL files so probably best to read those first.
 
Old 05-27-2008, 12:51 AM   #3
kissfreeman
LQ Newbie
 
Registered: Aug 2007
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
perl -MCPAN -e "install Convert::BER"
I did that and still getting the same errors.

I also install the rrdtool since that is what smokeping need and still that app won't work
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Smokeping shows latency increase with new kernel! thekillerbean Linux - Software 2 04-16-2007 02:34 AM
ASN.1 BER file decoding maheshdf Linux - Newbie 1 11-29-2006 05:49 AM
smokeping / cgi error djn3xt Linux - Networking 0 12-09-2005 07:13 AM
BER for wireless link legolas_t Programming 1 08-24-2004 08:36 PM
how to get BER legolas_t Programming 0 06-15-2004 09:59 PM


All times are GMT -5. The time now is 03:51 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration