LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 06-13-2003, 11:10 AM   #1
bona
LQ Newbie
 
Registered: Jun 2003
Posts: 1

Rep: Reputation: 0
sis900 module don't load


Hi:
In a integrated motherboard PC (clone) runing zipSlackware 8.0 (file sistem UMSDOS) kernel 2.2.19, I can't load the ethernet module.
When I issued:
insmod sis900 irq=5

the load fail (bad parameter) but in the archive messages I see:

Jun 12 09:22:55 elaf4 kernel: sis900.c: v1.06.07 01/08/01
Jun 12 09:22:55 elaf4 kernel: eth0: SiS 900 PCI Fast Ethernet at 0xd400, IRQ 5, 00:0a:e6:a9:7b:25.
Jun 12 09:22:55 elaf4 kernel: eth0: No MII transceivers found!

What can I do to find a right module?
 
Old 06-14-2003, 10:16 PM   #2
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
Just a guess but you might try a newer kernel. Slack 8.0 is over two years old. So you can compare that with the age of your motherboard.

Other than that, PCI type interfaces normally do not like arguments. The module can normally determine everything from the plug-n-play features. Also, if "insmod" complains then try using "modprobe" instead. The "modprobe" command can load other modules if any are required.

Good luck.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
netinstall cd & sis900 module tib_tib Debian 6 10-30-2004 12:38 PM
Module Auto-Load: module.conf tricks? m_e_perry Linux - Newbie 3 10-07-2004 06:45 PM
Need help getting module to load mitchmiller Linux - Hardware 1 05-16-2004 08:50 PM
SiS900 module in RedHat 8 has a bug pjrobin Linux - Hardware 1 01-07-2003 10:55 PM
Debian - 2 issues: dual booting & SiS900 module glc Linux - General 0 10-22-2001 03:45 AM


All times are GMT -5. The time now is 12:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration