LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   SIP 4.10.0 SlackBuild or Slackware package? Or upgrade Slackware 13.0 to 13.1? (http://www.linuxquestions.org/questions/slackware-14/sip-4-10-0-slackbuild-or-slackware-package-or-upgrade-slackware-13-0-to-13-1-a-819311/)

ShellyCat 07-11-2010 08:19 PM

SIP 4.10.0 SlackBuild or Slackware package? Or upgrade Slackware 13.0 to 13.1?
 
Hello,

Because I want to install Anki on Linux, I need to upgrade my PyQt to 4.7. So I removed the old package. But when I try to install the SlackBuild of PyQt 4.7.3, I get this error:
Quote:

This version of PyQt requires SIP v4.10.0 or later
make: *** No targets specified and no makefile found. Stop.
make: *** No targets specified and no makefile found. Stop.
Now I don't see an SIP 4.10.0 package for Slackware 13.0 (though there is probably one for 13.1). I don't see a SlackBuild for it, either.

Considering I already uninstalled the older PyQt, I don't want to screw up my system. I Googled but only found instructions for Ubuntu or Debian.

I read this http://www.linuxquestions.org/questi...12-1-a-655216/
ut it only makes me nervous because of problems other people had with their config not being found. So...
  1. Is there a SlackBuild of SIP 4.10.0?
  2. Will SIP 4.10.0 (source or SlackBuild) work fine on Slackware 13.0?
  3. Would I be better to wipe my disk and install Slackware 13.1 instead?

larryhaja 07-11-2010 09:31 PM

I had an application that required a newer PyQt then was available on Slackware 13.0. I also upgraded sip to 4.10.0 and PyQt to 4.7.1. I didn't really see any conflicts but I'm not sure if it also requires a newer Qt >= 4.6. I, however, didn't build a newer Qt then what was stock on Slackware 13.0.

I had no problems upgrading to a newer sip and PyQt using the slackbuilds scripts and the associated files available from the Slackware source tree. One thing to note is that once sip and PyQt are built and installed you also need to rebuild QScintilla. Otherwise, you may (will) get a conflict when building applications needing QScintilla. Other then that I don't know of any other issues.

Here are the links for sip, PyQt, and Qscintilla. They need to be built in the order listed.
sip: ftp://slackware.oregonstate.edu/pub/.../source/l/sip/
PyQt: ftp://slackware.oregonstate.edu/pub/...source/l/PyQt/
QScintilla: ftp://slackware.oregonstate.edu/pub/.../l/QScintilla/


All times are GMT -5. The time now is 09:14 AM.