LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 07-11-2010, 09:19 PM   #1
ShellyCat
Member
 
Registered: Jul 2007
Distribution: Slackware 13
Posts: 178

Rep: Reputation: 28
Question SIP 4.10.0 SlackBuild or Slackware package? Or upgrade Slackware 13.0 to 13.1?


Hello,

Because I want to install Anki on Linux, I need to upgrade my PyQt to 4.7. So I removed the old package. But when I try to install the SlackBuild of PyQt 4.7.3, I get this error:
Quote:
This version of PyQt requires SIP v4.10.0 or later
make: *** No targets specified and no makefile found. Stop.
make: *** No targets specified and no makefile found. Stop.
Now I don't see an SIP 4.10.0 package for Slackware 13.0 (though there is probably one for 13.1). I don't see a SlackBuild for it, either.

Considering I already uninstalled the older PyQt, I don't want to screw up my system. I Googled but only found instructions for Ubuntu or Debian.

I read this http://www.linuxquestions.org/questi...12-1-a-655216/
ut it only makes me nervous because of problems other people had with their config not being found. So...
  1. Is there a SlackBuild of SIP 4.10.0?
  2. Will SIP 4.10.0 (source or SlackBuild) work fine on Slackware 13.0?
  3. Would I be better to wipe my disk and install Slackware 13.1 instead?

Last edited by ShellyCat; 07-11-2010 at 09:20 PM. Reason: typos
 
Old 07-11-2010, 10:31 PM   #2
larryhaja
Member
 
Registered: Jul 2008
Distribution: Slackware 13.1
Posts: 293

Rep: Reputation: 76
I had an application that required a newer PyQt then was available on Slackware 13.0. I also upgraded sip to 4.10.0 and PyQt to 4.7.1. I didn't really see any conflicts but I'm not sure if it also requires a newer Qt >= 4.6. I, however, didn't build a newer Qt then what was stock on Slackware 13.0.

I had no problems upgrading to a newer sip and PyQt using the slackbuilds scripts and the associated files available from the Slackware source tree. One thing to note is that once sip and PyQt are built and installed you also need to rebuild QScintilla. Otherwise, you may (will) get a conflict when building applications needing QScintilla. Other then that I don't know of any other issues.

Here are the links for sip, PyQt, and Qscintilla. They need to be built in the order listed.
sip: ftp://slackware.oregonstate.edu/pub/.../source/l/sip/
PyQt: ftp://slackware.oregonstate.edu/pub/...source/l/PyQt/
QScintilla: ftp://slackware.oregonstate.edu/pub/.../l/QScintilla/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
updating slackbuild package in slackware 12.2 jrecortel Slackware 1 02-06-2009 07:23 PM
Rebuilding a Slackware Package With Slackbuild Scripts Woodsman Slackware 11 10-14-2006 06:08 AM
using older slackware package for newer slackware. Is it problematic? hottdogg Slackware 2 12-13-2005 04:57 AM


All times are GMT -5. The time now is 09:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration