LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 07-11-2008, 08:37 PM   #1
shammont
LQ Newbie
 
Registered: Jan 2006
Posts: 4

Rep: Reputation: 0
GNS3 install on slackware 12.1


Anyone got this to work on slackware 12.1?
I have installed requested libs. Everything installs fine. When I run it I get "Can't import Qt modules, PyQt is probably not installed." PyQt4 is installed and Qt4 is installed. I have put qt4 bin directory in path. Not sure what else to try.

Thanks
 
Old 07-13-2008, 03:37 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,947

Rep: Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602
Please tell, which package "PyQt4" you installed.

The answer ""Can't import Qt modules, PyQt is probably not installed.""
from 'gns3' appears only, when no PyQt4 is installed?. Wrong version gives :
Quote:
Traceback (most recent call last):
File "/usr/bin/gns3", line 35, in ?
raise RuntimeError, "Need Qt v4.3 or higher,
but got v%s" % QtCore.QT_VERSION_STR
RuntimeError: Need Qt v4.3 or higher, but got v4.2.2
and it's not about Qt4, but PyQt4. ( My qt4 = 4.3.2 )

Things I did : 1) compile and install sip-4.7.6 from
http://freshmeat.net/projects/python...ease_id=278150
http://www.riverbankcomputing.com/so.../sip/download/

And 2) : compile and install PyQt4-4.4.3
( PyQt-x11-gpl-4.4.3-snapshot-20080705.tar.gz ) from
http://www.riverbankcomputing.co.uk/.../pyqt/download
( version 4.4.2 has a bug, 4.4.3 includes all bug fixes )

Regards

PS : No need to put qt4 bin in the path, pyqt will know it, build
with 'python configure.py --qmake=/usr/lib/qt4/bin/qmake'

Last edited by knudfl; 07-13-2008 at 03:57 AM.
 
Old 07-13-2008, 10:39 AM   #3
shammont
LQ Newbie
 
Registered: Jan 2006
Posts: 4

Original Poster
Rep: Reputation: 0
thanks

after hours of working, deleted all files and reference to sip and reinstalled latest version of sip. fixed it. problem was because python crashed trying to import module sip.

thanks again
 
Old 04-23-2010, 08:44 AM   #4
orgack
LQ Newbie
 
Registered: Apr 2010
Posts: 2

Rep: Reputation: 0
I've got the same problem now. Could you tell me what exactly files did you delete and what versions of the packages did you install at the end? Thanks
 
Old 04-24-2010, 06:59 AM   #5
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,947

Rep: Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602
@ orgack , post #4 : welcome to LQ. .. ..

The latest GNS3 is version 0.7 .

Are you using Debian 5 Lenny ? Please tell.
( May behave different from Slackware 12.1 ).

And a few more words about your errors, please.
..
 
Old 04-24-2010, 12:40 PM   #6
orgack
LQ Newbie
 
Registered: Apr 2010
Posts: 2

Rep: Reputation: 0
Hi! I'm using Debian Squeeze and I've compiled and installed PyQt-4.7.3, sip 4.10.2 and even all Qt libraries 4.6.2 (only take me 5 hours :/). After this I try to run GNS3 and always obtain same error:

../NS3-0.6-src# ./gns3
Can't import Qt modules, PyQt is probably not installed ...

../NS3-0.7-src# ./gns3
Can't import Qt modules, PyQt is probably not installed ...

Quote:
Originally Posted by knudfl View Post
Please tell, which package "PyQt4" you installed.

The answer ""Can't import Qt modules, PyQt is probably not installed.""
from 'gns3' appears only, when no PyQt4 is installed?. Wrong version gives :

and it's not about Qt4, but PyQt4. ( My qt4 = 4.3.2 )

Things I did : 1) compile and install sip-4.7.6 from
http://freshmeat.net/projects/python...ease_id=278150
http://www.riverbankcomputing.com/so.../sip/download/

And 2) : compile and install PyQt4-4.4.3
( PyQt-x11-gpl-4.4.3-snapshot-20080705.tar.gz ) from
http://www.riverbankcomputing.co.uk/.../pyqt/download
( version 4.4.2 has a bug, 4.4.3 includes all bug fixes )

Regards

PS : No need to put qt4 bin in the path, pyqt will know it, build
with 'python configure.py --qmake=/usr/lib/qt4/bin/qmake'
I've also proved this and neither is it my solution.
 
Old 04-24-2010, 03:12 PM   #7
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,947

Rep: Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602
Well, you will have to find out,
which versions fit together, and with GNS.

Why not use the default packages,
that can be installed with 'apt-get install <package>
? ? Please tell the reason. Nobody says, that latest is best !

GNS3-0.6 may not work with those.? Did you try with GNS3-0.7 ?
..
P.S. : GNS3-0.6 and GNS3-0.7 work perfect with these :
(libqt4-devel-4.5.3) , python-qt4-4.5 , python-sip-4.8
............. on PCLinuxOS 2009.2 .............

And....... python-qt4-4.7 , python-sip-4.10
.............. on PCLinuxOS 2010. ...........

No " -dev " packages required.
..

Last edited by knudfl; 04-24-2010 at 04:03 PM.
 
  


Reply

Tags
cisco, emulator, gns3, slackware


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
GNS3 reports wrong Qt version! simsie Linux - Software 1 04-17-2008 04:12 PM
How can I install a slackware-current kernel to slackware 11? bijit1709 Slackware 11 06-13-2007 03:24 PM


All times are GMT -5. The time now is 01:49 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration