LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 05-20-2013, 01:52 PM   #1
Yaakov Ben-Avraham
LQ Newbie
 
Registered: Jan 2013
Location: Vancouver, Canada
Distribution: Slackware 14.0
Posts: 25

Rep: Reputation: Disabled
I can't run X window without network connectivity...


I can't run X window without network connectivity in Slackware 14.0
Previous versions allowed me to run X window without the internet being up and running. Is this by design? Is there a work-around to allow me to run X without requiring internet connectivity?
 
Old 05-20-2013, 02:04 PM   #2
Thor_2.0
Senior Member
 
Registered: Nov 2007
Location: Somewhere on my hard drive...
Distribution: Manjaro
Posts: 2,168
Blog Entries: 23

Rep: Reputation: 275Reputation: 275Reputation: 275
Who claims that it is X that needs Internet? Could it be something that needs X, that needs the Internet? I'd sniff tru the applications that run in your X session and check which ones need the Internet.

By the way, is there a profound reason NOT to connect to the Net? Security can be enforced by other means...

Just thinking-n-typing out loud...

Thor
 
Old 05-20-2013, 02:05 PM   #3
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware-14.0 on a Lenovo T61 6457-4XG
Posts: 3,638

Rep: Reputation: 827Reputation: 827Reputation: 827Reputation: 827Reputation: 827Reputation: 827Reputation: 827
Assuming you start Slackware at run level 3, what happens when you type "startx"?

Please at least attach /var/log/Xorg.0.log to your next post, otherwise it will be very difficult to diagnose your problem.

As far as I know there is no relation between an internet connection and X.

Last edited by Didier Spaier; 05-20-2013 at 04:33 PM. Reason: Typo corrected (thanks BroX)
 
1 members found this post helpful.
Old 05-20-2013, 02:20 PM   #4
Thor_2.0
Senior Member
 
Registered: Nov 2007
Location: Somewhere on my hard drive...
Distribution: Manjaro
Posts: 2,168
Blog Entries: 23

Rep: Reputation: 275Reputation: 275Reputation: 275
Quote:
As far as I know there is no relation between an internet connection and X
(hence my own confusion"...)
 
Old 05-20-2013, 03:58 PM   #5
Yaakov Ben-Avraham
LQ Newbie
 
Registered: Jan 2013
Location: Vancouver, Canada
Distribution: Slackware 14.0
Posts: 25

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Didier Spaier View Post
Assuming you start Slackware at run level 3, what happens when you type "startx"?

Please at least attach /var/log/X0.log to your next post, otherwise it will be very difficult to diagnose your problem.

As far as I know there is no relation between an internet connection and X.
The command "startx" will not run unless the Internet is connected.
The file /var/log/x0.log is not created if "startx" is typed
and the internet is not connected. Slackware 14.0 just
hangs the console until ^C is typed if this is tried.
 
Old 05-20-2013, 04:08 PM   #6
BroX
Member
 
Registered: Oct 2003
Location: Sweden
Distribution: Slackware64-current
Posts: 733

Rep: Reputation: 64
Quote:
Originally Posted by Yaakov Ben-Avraham View Post
The file /var/log/x0.log is not created if "startx" is typed
Just in case: log file is /var/log/Xorg.0.log without typo
 
Old 05-20-2013, 04:14 PM   #7
ttk
Member
 
Registered: May 2012
Location: Sebastopol, CA
Distribution: Slackware
Posts: 168
Blog Entries: 8

Rep: Reputation: 81
I ran into a similar problem a while back, and it was because I had DISPLAY=localhost:0 set in my environment. Changing this to DISPLAY=:0 fixed it. I don't know if that's your problem, but perhaps you could check.
 
Old 05-20-2013, 04:57 PM   #8
Yaakov Ben-Avraham
LQ Newbie
 
Registered: Jan 2013
Location: Vancouver, Canada
Distribution: Slackware 14.0
Posts: 25

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by ttk View Post
I ran into a similar problem a while back, and it was because I had DISPLAY=localhost:0 set in my environment. Changing this to DISPLAY=:0 fixed it. I don't know if that's your problem, but perhaps you could check.
I can find no references to Display or Localhost in my environment table.
 
Old 05-20-2013, 05:29 PM   #9
mrclisdue
Senior Member
 
Registered: Dec 2005
Distribution: Slackware -current, 14.1
Posts: 1,019

Rep: Reputation: 157Reputation: 157
Which wm are you running? Is there anything in your .xinitrc that may yield any clues?

cheers,
 
Old 05-20-2013, 05:31 PM   #10
TommyC7
Member
 
Registered: Mar 2012
Distribution: Slackware, CentOS, OpenBSD, FreeBSD
Posts: 419

Rep: Reputation: Disabled
Are you booting into runlevel 3 or runlevel 4?

Also, how is the connection being made? rc.inet1, NetworkManager or wicd?
 
Old 05-20-2013, 05:38 PM   #11
gsl
LQ Newbie
 
Registered: Jun 2007
Location: Melbourne, Australia
Distribution: Slackware
Posts: 24

Rep: Reputation: 4
Does startx hang forever or does X start eventually (after 10+ seconds)? If you run 'hostname -f' does it take a while to complete while plain 'hostname' completes immediately? That was the cause of the problem for me when I found X would not start promptly when the network was down. I just edited /usr/bin/startx to replace 'hostname -f' with 'hostname'.

Geoff.
 
1 members found this post helpful.
Old 05-20-2013, 06:13 PM   #12
Yaakov Ben-Avraham
LQ Newbie
 
Registered: Jan 2013
Location: Vancouver, Canada
Distribution: Slackware 14.0
Posts: 25

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by gsl View Post
Does startx hang forever or does X start eventually (after 10+ seconds)? If you run 'hostname -f' does it take a while to complete while plain 'hostname' completes immediately? That was the cause of the problem for me when I found X would not start promptly when the network was down. I just edited /usr/bin/startx to replace 'hostname -f' with 'hostname'.

Geoff.
That was indeed the work-around. Remove the -f from `hostname -f` in startx

This begs the question "Why does `hostname -f` complete instantly in Slackware 13.37 and hang for so long in Slackware 14.0?"

Last edited by Yaakov Ben-Avraham; 05-20-2013 at 06:57 PM.
 
Old 05-20-2013, 07:20 PM   #13
gsl
LQ Newbie
 
Registered: Jun 2007
Location: Melbourne, Australia
Distribution: Slackware
Posts: 24

Rep: Reputation: 4
Quote:
Originally Posted by Yaakov Ben-Avraham View Post
This begs the question "Why does `hostname -f` complete instantly in Slackware 13.37 and hang for so long in Slackware 14.0?"
This news thread suggests it might be because hostname on 14.0 supports IPv6 whereas 13.37 and before doesn't? As my /etc/hosts doesn't have an IPv6 entry for localhost, hostname was doing a DNS lookup.

Geoff.
 
  


Reply

Tags
internet, x-windows


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Run Script In New Window & Keep Window Open Ben2K Programming 2 07-06-2010 01:28 AM
No network connectivity detepper Linux - Hardware 2 07-18-2009 07:30 PM
Partial loss of internet connectivity (TCP window scaling?) ojbyer@usa.net Linux - Networking 5 11-30-2008 12:46 PM
No Network Connectivity Nullivex Linux - Networking 5 01-08-2008 02:16 AM
No network connectivity beyond network card linux8 simplimarvelous Linux - Networking 1 02-18-2003 10:22 PM


All times are GMT -5. The time now is 12:11 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration