LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-08-2002, 10:47 PM   #1
busbarn
Member
 
Registered: Feb 2002
Location: Denver, CO US
Distribution: Arch
Posts: 453

Rep: Reputation: 30
ethernet won't work


I just installed Slack 8.1 and I'm slowly getting everything configured. However, I still can't get internet to work. I'm hooked up on a cable modem through eth0. I ran netconfig and set up DHCP, everything looks fine. But when I try to ping anything or access a website, nothing loads. The result of the ping is "Unknown server". I've looked at the slackware website and I've searched all over here and I still can't figure it out. Any help would be greatly appreciated. Thanks in advance.
 
Old 07-09-2002, 12:30 AM   #2
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 197Reputation: 197
Can you ping by IP number ?
Have you checked or added the DNS entries to your /etc/resolv.conf ? In some cases while using DHCP, you still need to specify your DNS entries.
What output do you get when you do a ifconfig eth0 ? Does it display any output for you IP, Netmask.. etc.. ??

Let us know ?
 
Old 07-09-2002, 09:14 PM   #3
busbarn
Member
 
Registered: Feb 2002
Location: Denver, CO US
Distribution: Arch
Posts: 453

Original Poster
Rep: Reputation: 30
My /etc/resolv.conf file looks like this:

nameserver 192.168.0.1
search attbi.com


When I run ifconfig eth0 this is the output:

inet addr: 192.168.0.2 Bcast:192.168.0.255 Mask:255.255.255.0

I know that the ip is wrong because the other computers (windows machines) that are hooked up to the same router (netgear) have an ip that begins with 12. I know that it works because I had Suse 7.3 running just fine. If I have to change my resolv.conf file, what do I add/modify? I know what DNS is but what to enter boggles me. Thanks again.
 
Old 07-09-2002, 09:38 PM   #4
pickledbeans
Member
 
Registered: Jun 2002
Location: Bailey, CO
Distribution: Slackware
Posts: 483

Rep: Reputation: 31
Quote:
Originally posted by busbarn
My /etc/resolv.conf file looks like this:

nameserver 192.168.0.1
search attbi.com


When I run ifconfig eth0 this is the output:

inet addr: 192.168.0.2 Bcast:192.168.0.255 Mask:255.255.255.0

I know that the ip is wrong because the other computers (windows machines) that are hooked up to the same router (netgear) have an ip that begins with 12. I know that it works because I had Suse 7.3 running just fine. If I have to change my resolv.conf file, what do I add/modify? I know what DNS is but what to enter boggles me. Thanks again.
You need to set up /etc/resolv.conf to include
the DNS servers for your work or ISP.

Can you ping 192.168.0.2 ?

Last edited by pickledbeans; 07-09-2002 at 09:40 PM.
 
Old 07-09-2002, 10:47 PM   #5
busbarn
Member
 
Registered: Feb 2002
Location: Denver, CO US
Distribution: Arch
Posts: 453

Original Poster
Rep: Reputation: 30
Yes. The result is:

PING 192.168.0.2 (192.168.0.2): 56 octets data
64 octets from 192.168.0.2 icmp_seq=0 ttl=255 time=0.1ms

the icmp_seq number goes up to 300 and still counting.

How do I tell resolv.conf about dns?
 
Old 07-09-2002, 10:57 PM   #6
pickledbeans
Member
 
Registered: Jun 2002
Location: Bailey, CO
Distribution: Slackware
Posts: 483

Rep: Reputation: 31
Quote:
Originally posted by busbarn
Yes. The result is:

PING 192.168.0.2 (192.168.0.2): 56 octets data
64 octets from 192.168.0.2 icmp_seq=0 ttl=255 time=0.1ms

the icmp_seq number goes up to 300 and still counting.

How do I tell resolv.conf about dns?
This tells us that your network interface is up.
It is used only for you LAN or local network.

How may network cards to you have in this box?
You mentionsed cable modem? Do you have one card point
to the LAN (192.168.0.2) and the second one going directly to the router and out to the internet?
 
Old 07-09-2002, 11:08 PM   #7
busbarn
Member
 
Registered: Feb 2002
Location: Denver, CO US
Distribution: Arch
Posts: 453

Original Poster
Rep: Reputation: 30
Nope...Just one card that goes to the router. My roommates and I share one internet account so there's three boxes (mines the only linux box) plugged into the router. The router then goes to the cable modem. Since all of us are mentally network handicapped, this was the easiest way to set things up.
 
Old 07-09-2002, 11:27 PM   #8
pickledbeans
Member
 
Registered: Jun 2002
Location: Bailey, CO
Distribution: Slackware
Posts: 483

Rep: Reputation: 31
Ok, so each box gets its ip address directly from the ISP?
If that's the case the only ipaddress your eth0 should have (someone correct me if I'm wrong) is the one assigned by your ISP , and eth0 should be set to use DHCP proto.

And you need to set up /etc/resolv.conf to reflect you ISP's DNS servers mine looks like this:

domain wcox.com
nameserver 66.252.192.22
nameserver 66.252.192.11
nameserver 66.252.192.2

The other alternative is a LAN with a single connection
to the internet:
1. Setup of mdoem sharing on one of the Windows boxes.
and route the other boxes threw.

2. Setup a Linux box as a firewall and ipmasq. Send all request threw it.

The advantage of this is you all can connect to the internet and still have you LAN also.

Last edited by pickledbeans; 07-09-2002 at 11:29 PM.
 
Old 07-09-2002, 11:38 PM   #9
pickledbeans
Member
 
Registered: Jun 2002
Location: Bailey, CO
Distribution: Slackware
Posts: 483

Rep: Reputation: 31
Unless we can set up a virutual network interface on eth0 (I way over my head hear) so what we would have is something like this (again a single network card per box):

eth0 --->Router ---->ISP ----->Internet
eth0:1 -->192.168.0.2 --->hub--->LAN

Last edited by pickledbeans; 07-09-2002 at 11:40 PM.
 
Old 07-09-2002, 11:47 PM   #10
busbarn
Member
 
Registered: Feb 2002
Location: Denver, CO US
Distribution: Arch
Posts: 453

Original Poster
Rep: Reputation: 30
LAN isn't important to me...we just want to share internet. I try to change resolv.conf and when I reboot, it always changes back. I can't just plug in an ip address because it isn't static--I don't want to have to enter in a new ip everytime it changes.

Also, during bootup when DHCP tries to initialize, it says that option broadcastAddr can't be found on server. Does that matter?
 
Old 07-09-2002, 11:47 PM   #11
pickledbeans
Member
 
Registered: Jun 2002
Location: Bailey, CO
Distribution: Slackware
Posts: 483

Rep: Reputation: 31
Holly peguim popp this might actually work try this:

in /etc/modules.conf put someting like this:
alias eth0:1 nic_module_name

save and exit

then:

ifconfig eth0:1 192.168.0.2

now do:

ifconfig -a

If you ineternect connection is working
you should see:

eth0 with you ISP ip address
and
eth0:1 with 19.168.0.2

trying ping both ip address
 
Old 07-09-2002, 11:52 PM   #12
busbarn
Member
 
Registered: Feb 2002
Location: Denver, CO US
Distribution: Arch
Posts: 453

Original Poster
Rep: Reputation: 30
okay this is whacky. I plugged straight into the cable modem, rebooted, and it works like a charm. Is the router blocking my box from contacting the service?
 
Old 07-09-2002, 11:55 PM   #13
busbarn
Member
 
Registered: Feb 2002
Location: Denver, CO US
Distribution: Arch
Posts: 453

Original Poster
Rep: Reputation: 30
Now I just plugged back into the router and all is well. So thanks for your help, I have no idea what's happening but it works. Crazy computers.
 
Old 07-10-2002, 12:12 AM   #14
pickledbeans
Member
 
Registered: Jun 2002
Location: Bailey, CO
Distribution: Slackware
Posts: 483

Rep: Reputation: 31
Quote:
Originally posted by busbarn
Now I just plugged back into the router and all is well. So thanks for your help, I have no idea what's happening but it works. Crazy computers.
Oh not you don't your not getting on that easy.
Has anything changes inside the house, did any of you buddies turn off there computers before you reboot/disconnect and reconnect to the router?
 
Old 07-10-2002, 12:34 AM   #15
busbarn
Member
 
Registered: Feb 2002
Location: Denver, CO US
Distribution: Arch
Posts: 453

Original Poster
Rep: Reputation: 30
nope. I just unplugged the router from the modem, plugged into the modem, rebooted, plugged back into the router, and the router into the modem. All 3 computers work fine. Who knows.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot configure ethernet at work mehlkelm Debian 8 07-09-2005 08:13 PM
Getting Ethernet card to work Kensai Linux - Hardware 1 11-17-2004 07:29 AM
Modem and ethernet do not work matevzp Linux - Hardware 2 07-09-2004 03:56 AM
Will an ethernet router work? Sundance Linux - Newbie 5 12-31-2003 07:48 AM
How do I get my ethernet card to work? RJWMU Linux - Newbie 4 05-16-2003 01:27 PM


All times are GMT -5. The time now is 10:48 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration