LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-17-2013, 08:57 AM   #1
johnpuppa
LQ Newbie
 
Registered: Jun 2013
Posts: 28

Rep: Reputation: Disabled
can't suspend, hibernate or switch-user from xfce4 panel


Hello guys, as the name of the topic says, I have this problem and I can't figure out where the problem lies. The three button are completely grey and I have no access to them. pm-suspend and pm-hibernate from command line work fine.
upower,ConsoleKit, and polkit are present:

Here is the output for xfce4-power-manager
Quote:
xfce4-power-manager --dump
---------------------------------------------------
Xfce power manager version 1.2.0
With policykit support
With network manager support
With DPMS support
---------------------------------------------------
Can suspend: True
Can hibernate: True
Can spin down hard disks: True
Authorized to suspend: True
Authorized to hibernate: True
Authorized to shutdown: True
Authorized to spin down hard disks: False
Has battery: True
Has brightness panel: True
Has power button: True
Has hibernate button: True
Has sleep button: True
Has LID: True
The Authorized option were all false before I modified the file:
Quote:
/etc/polkit-1/localauthority/50-local.d/20-plugdev-group-mount-override.pkla
adding, and starting rc.consolekit:
Quote:
[Re-enable hibernate by default]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes
On Xfce4 panel, as I said before the buttons keep to be grey and not accessible.
OS:Slack 14.0
Any Idea?
 
Old 07-18-2013, 12:54 AM   #2
STDOUBT
Member
 
Registered: May 2010
Location: Stumptown
Distribution: Slackware 14.0/32bit + a T60p (2007-YS3) = YES
Posts: 261

Rep: Reputation: 61
Haven't used XFCE much since 4.10 came to Slackware, but are you sure you haven't "played around" with the Panel settings? Each "Launcher" or "Item" on the Panel has it's own preferences settings.
 
Old 07-18-2013, 09:26 AM   #3
titopoquito
Senior Member
 
Registered: Jul 2004
Location: Ruhr Area, Germany
Distribution: Slackware64 14.0
Posts: 1,517

Rep: Reputation: 90
Is your user member of the "power" group? Not sure if "plugdev" is required, too.
 
Old 07-18-2013, 10:12 AM   #4
johnpuppa
LQ Newbie
 
Registered: Jun 2013
Posts: 28

Original Poster
Rep: Reputation: Disabled
Hello guys, and thanks for replying.
Quote:
Originally Posted by titopoquito View Post
Is your user member of the "power" group? Not sure if "plugdev" is required, too.
Yes my user is in the power group. I also tried to add it to the "plugdev". No luck..
 
Old 07-18-2013, 10:22 AM   #5
TommyC7
Member
 
Registered: Mar 2012
Distribution: Slackware, CentOS, OpenBSD, FreeBSD
Posts: 436

Rep: Reputation: Disabled
I found this on a Gentoo forum, but I'm wondering if it helps:

In your sudoers:
Code:
root ALL=(ALL) ALL
%users ALL=(ALL) NOPASSWD: /usr/lib64/xfce4/session/xfsm-shutdown-helper
In /etc/polkit-1/localauthority/50-local.d/power.pkla (if it doesn't exist, feel free to make it but if it does exist, append):

Code:
[Local restart]
Identity=unix-group:power
Action=org.freedesktop.consolekit.system.restart
ResultAny=yes
ResultInactive=no
ResultActive=yes

[Local shutdown]
Identity=unix-group:power
Action=org.freedesktop.consolekit.system.stop
ResultAny=yes
ResultInactive=no
ResultActive=yes

[Local restart - multiple]
Identity=unix-group:power
Action=org.freedesktop.consolekit.system.restart-multiple-users
ResultAny=yes
ResultInactive=no
ResultActive=yes

[Local shutdown - multiple]
Identity=unix-group:power
Action=org.freedesktop.consolekit.system.stop-multiple-users
ResultAny=yes
ResultInactive=no
ResultActive=yes
 
Old 07-20-2013, 05:23 AM   #6
johnpuppa
LQ Newbie
 
Registered: Jun 2013
Posts: 28

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by TommyC7 View Post
I found this on a Gentoo forum, but I'm wondering if it helps:

In your sudoers:
Code:
root ALL=(ALL) ALL
%users ALL=(ALL) NOPASSWD: /usr/lib64/xfce4/session/xfsm-shutdown-helper
In /etc/polkit-1/localauthority/50-local.d/power.pkla (if it doesn't exist, feel free to make it but if it does exist, append):

Code:
[Local restart]
Identity=unix-group:power
Action=org.freedesktop.consolekit.system.restart
ResultAny=yes
ResultInactive=no
ResultActive=yes

[Local shutdown]
Identity=unix-group:power
Action=org.freedesktop.consolekit.system.stop
ResultAny=yes
ResultInactive=no
ResultActive=yes

[Local restart - multiple]
Identity=unix-group:power
Action=org.freedesktop.consolekit.system.restart-multiple-users
ResultAny=yes
ResultInactive=no
ResultActive=yes

[Local shutdown - multiple]
Identity=unix-group:power
Action=org.freedesktop.consolekit.system.stop-multiple-users
ResultAny=yes
ResultInactive=no
ResultActive=yes
Thanks for the post Tommy. I had tried this previously too, and nothing worked out for me.
On this thread seems that the guy had some package that was missing. Maybe it's the same problem for me too. I'm trying to figure out which could be...
https://bbs.archlinux.org/viewtopic.php?pid=1014130
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] xfce4 power management not locking the screen during suspend/hibernate. Arcosanti Slackware 5 08-26-2012 07:33 PM
Suspend/Hibernate at command line as regular user in 13.37: use ConsoleKit? josiah Slackware 8 04-18-2011 10:25 PM
problems with Suspend, hibernate, and switch user marozsas Linux - Hardware 1 03-29-2010 09:55 AM
how to detect system power event(user trigger),suspend,hibernate,resume...? minge.zu Linux - Desktop 1 02-11-2009 08:19 PM
cli hibernate works but gnome panel hibernate fails BCarey Linux - Desktop 1 06-08-2007 10:21 AM


All times are GMT -5. The time now is 07:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration