LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 10-21-2009, 08:06 AM   #1
bennethos
Member
 
Registered: Aug 2003
Location: Belgium
Distribution: -- Slackware for servers -- Debian for desktops --
Posts: 124

Rep: Reputation: 16
can't compile PAM in 13.0 x86_64 kenel 2.6.31.1


Here's what I did :

1- I have a multilib system 32bit & 64 bit libs (see alien's wiki on howto do this)

2- Installed the cracklibs package

3- wgetted & extracted Linux-PAM-0.99.10.0

4 - ./configure --> OK , no errors

5 - make gives :

pam_conv_l.o: In function `yylex':
/usr/local/tars/slackbuild/pam/Linux-PAM-0.99.10.0/conf/pam_conv1/pam_conv_l.c:843: undefined reference to `yywrap'
collect2: ld returned 1 exit status
make[4]: *** [pam_conv1] Error 1
make[4]: Leaving directory `/usr/local/tars/slackbuild/pam/Linux-PAM-0.99.10.0/conf/pam_conv1'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/usr/local/tars/slackbuild/pam/Linux-PAM-0.99.10.0/conf/pam_conv1'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/usr/local/tars/slackbuild/pam/Linux-PAM-0.99.10.0/conf'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/local/tars/slackbuild/pam/Linux-PAM-0.99.10.0'
make: *** [all] Error 2

any idea's ?
 
Old 10-21-2009, 08:15 AM   #2
wildwizard
Member
 
Registered: Apr 2009
Location: Oz
Distribution: slackware64-14.0
Posts: 755

Rep: Reputation: 227Reputation: 227Reputation: 227
Well I did compile Linux-PAM 1.1.0 under Slackware64 13.0 so you might want to try the current version of PAM first.
 
Old 10-21-2009, 08:27 AM   #3
slackd
Member
 
Registered: Sep 2009
Location: Bhubaneswar, India
Distribution: Slackware, Ubuntu, Windows
Posts: 260
Blog Entries: 1

Rep: Reputation: 60
u might wanna check here...
just modify the slackbuild and try.

GO--->>
 
Old 10-21-2009, 09:40 AM   #4
bennethos
Member
 
Registered: Aug 2003
Location: Belgium
Distribution: -- Slackware for servers -- Debian for desktops --
Posts: 124

Original Poster
Rep: Reputation: 16
thx for the slack package, couldn't fine one

I'll try that one
 
Old 11-28-2009, 08:50 AM   #5
ivan73rus
LQ Newbie
 
Registered: Nov 2009
Posts: 1

Rep: Reputation: 0
Hi,

i have fixed the problem with not defined yywrap() by specifying the lidfl path prefix (/usr in my case) to configure executable:

--with-libiconv-prefix=/usr

entire command line looks as follows:

# ./configure --prefix=/user --exec-prefix=/usr --localstatedir=/var --sysconfdir=/etc --disable-selinux --with-libiconv-prefix=/usr

i am using ASPLinux 11.2 (Ladoga) (RedHat based)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
compile kernel for x86_64 henkees Slackware 7 10-10-2008 03:36 PM
compile vsftpd+pam prapatbu Slackware 8 10-19-2007 01:37 AM
Compile Kenel increase performance? kstan Linux - Laptop and Netbook 6 05-16-2006 11:29 AM
how to compile a pam application gatsu Programming 2 04-26-2006 02:48 PM
1st kenel compile problems Howloweener Linux - Newbie 0 05-31-2003 02:08 AM


All times are GMT -5. The time now is 05:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration