LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-06-2006, 03:43 PM   #1
arubin
Senior Member
 
Registered: Mar 2004
Location: Middx UK
Distribution: Slackware64 14.1 (multilib)
Posts: 1,209

Rep: Reputation: 55
*** YOU'RE USING autoconf (GNU Autoconf) 2.60. KDE requires autoconf 2.52, 2.53 or 2.


I have been programming in an amatuer way for years in Pascal, Delphi and Java and thought that as a linux user I ought to have a look at C and programing for kde.

I went to kdevelop and thought I would try a HellowWorld as shown here

http://www.dazzle.plus.com/linux/part01.htm

Straightforward? No I have this error on run automake and friends

*** YOU'RE USING autoconf (GNU Autoconf) 2.60.
*** KDE requires autoconf 2.52, 2.53 or 2.54

Is this a problem with the way kdevelop is set up on slackware. I have never used kdevelop before but shouldn't Helloworld work on Slackware 11.0?

do I need to uninstall autoconf and re-install an earlier version
 
Old 11-07-2006, 01:38 PM   #2
Eternal_Newbie
Member
 
Registered: Jun 2005
Location: The Pudding Isles
Distribution: Slackware 13.37
Posts: 573

Rep: Reputation: 58
Hmm, I've just managed to reproduce the same error:
Code:
cd '/home/andrew/programming/hellokde/hellokde' && WANT_AUTOCONF_2_5="1" WANT_AUTOMAKE_1_6="1" gmake -f Makefile.cvs && mkdir '/home/andrew/programming/hellokde/hellokde/debug' && cd '/home/andrew/programming/hellokde/hellokde/debug' && CXXFLAGS="-O0 -g3" "/home/andrew/programming/hellokde/hellokde/configure" --enable-debug=full && cd '/home/andrew/programming/hellokde/hellokde/debug/src' && WANT_AUTOCONF_2_5="1" WANT_AUTOMAKE_1_6="1" gmake -k hellokde
This Makefile is only for the CVS repository
This will be deleted before making the distribution
<br />
*** YOU'RE USING autoconf (GNU Autoconf) 2.60.
*** KDE requires autoconf 2.52, 2.53 or 2.54
gmake[1]: *** [cvs] Error 1
gmake: *** [all] Error 2
*** Exited with status: 2 ***

I suspect that this is the problem:
Code:
&& WANT_AUTOCONF_2_5="1"
But I have no idea how to change that, I'm only an occasional programmer.

PS: I've occasionally used kdevelop under 10.2 and never encountered this problem.

Last edited by Eternal_Newbie; 11-07-2006 at 02:12 PM.
 
Old 11-07-2006, 02:48 PM   #3
Eternal_Newbie
Member
 
Registered: Jun 2005
Location: The Pudding Isles
Distribution: Slackware 13.37
Posts: 573

Rep: Reputation: 58
Just discovered something that might help:

Open the project in kdevelop, then under the 'Project' menu open the 'Project Options' dialog.

Scroll down until you see 'Make Options', click on that and edit 'WANT_AUTOCONF_2_5' and change the value from 1 to 0.

Hopefully that should solve the problem
 
Old 11-07-2006, 03:22 PM   #4
arubin
Senior Member
 
Registered: Mar 2004
Location: Middx UK
Distribution: Slackware64 14.1 (multilib)
Posts: 1,209

Original Poster
Rep: Reputation: 55
No. I still get the same problem.

It gets odder. Looking at the changelog even Slackware 9.0 was running 2.57

Last edited by arubin; 11-07-2006 at 04:31 PM.
 
Old 11-09-2006, 10:24 AM   #5
ppr:kut
Member
 
Registered: Aug 2006
Location: Netherlands
Distribution: Slackware
Posts: 356

Rep: Reputation: 91
I had the same problem when compiling a qt-app.
It turned out to be autoconf version 2.5x "hardcoded" into the makefile of the project.
I changed the line
Code:
  Autoconf*2.5* | autoconf*2.5* ) : ;;
to

Code:
  Autoconf*2.5* | autoconf*2.5* | Autoconf*2.6* | autoconf*2.6* ) : ;;
that did the job. After that everything compiled just fine.

Last edited by ppr:kut; 11-09-2006 at 10:25 AM.
 
Old 11-09-2006, 02:34 PM   #6
arubin
Senior Member
 
Registered: Mar 2004
Location: Middx UK
Distribution: Slackware64 14.1 (multilib)
Posts: 1,209

Original Poster
Rep: Reputation: 55
I cannot find anything like that in any of the files but I posted this as a bug on the kde site and got this message

Fixed for KDevelop 3.4 and it's possible that it's also fixed for KDevelop 3.3.5 (KDE 3.5.5)

So I will try and upgrade.
 
Old 09-24-2008, 03:31 AM   #7
Eshadow
LQ Newbie
 
Registered: Sep 2008
Posts: 4

Rep: Reputation: 0
The line is in the cvs.sh file. But you have to change the next part for in this file for "autoheader" too.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Autoconf version 2.13 I need 2.52 for kde development ThePenguin Programming 5 09-05-2004 08:02 PM
How to use GNU autoconf to generate a new configure from configure.in ?? vanhelsing Programming 5 08-05-2004 10:02 AM
autoconf 2.54 need HELP !! Baldrick65 Linux - Software 1 08-21-2003 07:56 AM
autoconf 2.52 or 2.53 caleb Conectiva 14 10-08-2002 03:53 PM
Autoconf jISV Linux - Software 2 05-30-2002 01:45 AM


All times are GMT -5. The time now is 11:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration