LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Kernel
User Name
Password
Linux - Kernel This forum is for all discussion relating to the Linux kernel.

Notices

Reply
 
Search this Thread
Old 04-07-2013, 06:24 PM   #1
william_zwd_cn
LQ Newbie
 
Registered: Mar 2013
Posts: 3

Rep: Reputation: Disabled
Xorg cannot be started with video card ati mobility radeon HD 5400


Hi everyone,

I install Linux from Scratch, so everything is compiled from source code. My dell laptop's video card is ati mobility radeon hd 5400 series (hardware information from Windows).

I know there are two Linux drivers, one is 'amd-driver-installer-catalyst-13.1-linux-x86.x86_64.zip' from AMD/ATI website, the other is 'xf86-video-ati-7.1.0.tar.bz2'.

My kernel is Linux 3.8.1, I have to start it with 'radeon.modeset=0', otherwise I will get kernel panic.

I tried both drivers one by one, every time I 'startx', the same error message:

[ 378.669] (EE) No drivers available.
[ 378.670]
Fatal server error:
[ 378.670] no screens found
[ 378.670] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org

according to http://wiki.x.org, it seems to tell there is no proper video driver, with log

PCI:*(0:2:0:0) 1002:68e0:1028:0413 rev 0, Mem @ 0xd0000000/268435456, 0xcfee0000/131072, I/O @ 0x00002000/256, BIOS @ 0x????????/131072

it identifies video card OK, '1028:0413' tells it is dell subsystem with ati mobility radeon hd 5470.

And I tried X -configure, with log message:

Missing output drivers. Configuration failed.


But I also have kubuntu 12.10 installed, the XWindows starts properly every time. And 'lspci | grep VGA' shows

02:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Manhattan [Mobility Radeon HD 5400 Series]

it seems somehow ubuntu can recognize my video card properly.

I am running out of ideas, how can I start Xorg server?
 
Old 04-08-2013, 06:31 PM   #2
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
OK, let's focus on one driver at a time. Since Xorg comes with the open source radeon driver (xf86-video-ati) I would suggest getting that driver working first. However, the radeon driver requires KMS to be enabled, which means you can't boot with radeon.modeset=0. So try to identify why you are getting the kernel panic... Can you show us the exact error you are getting from the kernel panic?

Adam
 
Old 04-10-2013, 04:37 PM   #3
william_zwd_cn
LQ Newbie
 
Registered: Mar 2013
Posts: 3

Original Poster
Rep: Reputation: Disabled
Thank you Adam, I am sorry that I has been busy recently.

Here is panic message:

tick_sched_handle.isra.8 + 0x31/0x40
tick_sched_timer + 0x47/0x70
__run_hrtimer + 0x7b/0x1c0
? tick_sched_do_timer + 0x30/0x30
? wake_up_process + 0x22/0x40
hrtimer_interrupt + 0xef/0x220
? run_timer_softirq + 0x38/0x2a0
hpet_interrupt_handler + 0x11/0x30
handle_irq_event_percpu + 0x5d/0x200
handle_irq_event + 0x3c/0x60
handle_edge_irq + 0x6f/0x110
handle_irq + 0xba/0x150
? irq_enter + 0x16/0x80
do_IRQ + 0x55/0xd0
common_interrupt + 0x6a/0x6a
? panic + 0x17c/0x1b5
? panic + 0xeb/0x1b5
do_exit + 0x947/0xa80
? printk + 0x48/0x4a
oops_end + 0x91/0xe0
die + 0x53/0x80
do_general_protection + 0xca/0x150
general_protection + 0x22/0x30
? kobject_uevent_env + 0x13b/0x4c0
? mempool_create_node + 0x77/0x150
? __kmalloc_node + 0xf5/0x1b0
? __kmalloc_node + 0x5e/0x1b0
? mempool_create_node + 0x77/0x150
? memppol_free_slab + 0x20/0x20
mempool_create_node + 0x77/0x150
? mempool_kmalloc + 0x20/0x20
mempool_create + 0x15/0x20
init_sd + 0xa3/0x122
? spi_transport_init + 0x7a/0x7a
do_one_initcall + 0x11a/0x160
kernel_init_freeable + 0x135/0x1bf
? do_early_param + 0x8c/0x8c
? rest_init + 0x70/0x70
kernel_init + 0x9/0xf0
ret_form_fork + 0x7c/0xb0
? rest_init + 0x70/0x70
[end trace b7d88dfb731feee2]

Until now, I do not understand these kernel information. If you can explain what is going on that will be very help.

William
 
Old 04-11-2013, 07:20 AM   #4
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
Out of curiousity, have you tried with a different version kernel?

Adam
 
Old 04-11-2013, 10:14 PM   #5
william_zwd_cn
LQ Newbie
 
Registered: Mar 2013
Posts: 3

Original Poster
Rep: Reputation: Disabled
I did not try with a different version of kernel.

William
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
s-video VGA compatible controller: ATI Technologies Inc Radeon Mobility M7 LW [Radeon driftboy Linux - Hardware 2 05-25-2009 10:23 PM
Sapphire ATI Radeon X700 Pro video card driver for Xorg ..plz help asilentmurmur *BSD 0 03-17-2006 07:24 AM
Mandrake 10.1(Xorg) hangs on video driver (ATI Radeon mobility 9800) michielmertens Mandriva 33 02-21-2005 08:10 AM
ATI Radeon 9700 Mobility with Xorg? Wich driver? fedivh Linux - Hardware 1 11-07-2004 04:48 PM
Mandrake 10.1(Xorg) hangs on video driver (ATI Radeon mobility 9800) michielmertens Linux - Hardware 1 10-13-2004 10:49 AM


All times are GMT -5. The time now is 05:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration