LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 05-07-2012, 12:55 PM   #1
#28
LQ Newbie
 
Registered: Dec 2011
Posts: 3

Rep: Reputation: Disabled
Eee PC 1015PW, cannot connect wireless with OpenSuse


I just installed OpenSuse on my Eee PC 1015PW and when I go to Network Management Settings the Wireless tab is greyed out.
Ubuntu could connect with wireless on this 1015PW, but OpenSuse cannot. Anyone know how I can fix this please?
 
Old 05-07-2012, 11:18 PM   #2
mdlinuxwolf
Member
 
Registered: Dec 2006
Distribution: Mepis and Fedora, also Mandrake and SuSE PC-BSD Mint Solaris 11 express
Posts: 365

Rep: Reputation: 34
The fix is to test other distros and find one that does. Use unetbootin to make live USB drives to boot from. Then, use the "full size" ISO image for the install. If Ubuntu works, chances are that Mepis or Mint will work too. Try fuduntu or fedora as well.
 
Old 05-14-2012, 10:43 AM   #3
TheBigMing
LQ Newbie
 
Registered: Dec 2008
Location: east anglia
Distribution: SuSE, antiX
Posts: 22

Rep: Reputation: 3
I had some problems with wireless (nothing to do with SuSE.12.1 - more to do with BT or my ISP). I ended up launching it through a terminal (Konsole in my case) with the following alias:

alias uplan="su -c 'ifup wlan0'; ping -c 3 www.example.com"

The 'ping' sends a packet 3 times to www.example.com (which seems to be a site set up purely for the purpose of being 'pinged'). If the connection has been successful, you should get an output that ends like this:

--- a749.g.akamai.net ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time
2003ms
rtt min/avg/max/mdev = 29.860/30.835/31.428/0.724 ms

You can terminate the connection using the alias:

alias dlan="su -c 'ifdown wlan0'"

If this doesn't work, something is wrong!

Best of luck.

Ming

Last edited by TheBigMing; 05-14-2012 at 10:51 AM. Reason: slightly ambiguous about 'ping'
 
Old 05-16-2012, 04:37 PM   #4
thorkelljarl
Senior Member
 
Registered: Jun 2008
Posts: 1,722

Rep: Reputation: 195Reputation: 195
Gnome...

Probably the easiest solution is to search "Software Management" in Yast for "NetworkManager", remove the package "NetworkManager-kde4-libs" and replace it with "NewworkManager-gnome" Then follow the steps in the enclosed web-link. Polish may not be your language, but the SUSE GUI is the same, just follow the pictures.

When you're done, this will allow you to start the Gnome applet by typing "nm-applet" in the search box at the top of the menu that opens when you click on the SUSE Kickoff gecko. An icon may, or at times, may not appear in the panel. Even if it is not visible, you will see a space created. Click on the space and you will see the applet settings.

I omitted the step changing the appearance to QtCurve, which may be why the launch icon sometimes doesn't show.

KDE4 has had a problem with its net-manager applet for a long time, too long.

http://susestarter.blogspot.com/2011...use-gnome.html

Last edited by thorkelljarl; 05-16-2012 at 04:42 PM.
 
Old 05-16-2012, 05:21 PM   #5
mdlinuxwolf
Member
 
Registered: Dec 2006
Distribution: Mepis and Fedora, also Mandrake and SuSE PC-BSD Mint Solaris 11 express
Posts: 365

Rep: Reputation: 34
Good point

Sometimes individual desktops misbehave more then others. You can easily have multiple desktops on SuSE. Heck, just install Gnome itself via ethernet. Get LXDE & xfce while you're at it. If one gets online, usually the others can also use that connection. God knows why...
 
Old 05-16-2012, 05:35 PM   #6
thorkelljarl
Senior Member
 
Registered: Jun 2008
Posts: 1,722

Rep: Reputation: 195Reputation: 195
You may have many but...

The applet alone is enough to solve the problem, and its dependencies aren't so extensive that they amount to an installation of most of Gnome along with KDE.
 
Old 05-16-2012, 09:54 PM   #7
mdlinuxwolf
Member
 
Registered: Dec 2006
Distribution: Mepis and Fedora, also Mandrake and SuSE PC-BSD Mint Solaris 11 express
Posts: 365

Rep: Reputation: 34
In general though, its best to have more then one desktop. Connecting to printers, DVD burners, handling different file types & modifying the commands in desktop icons all are handled very badly or very well depending on what desktop you use. In linux, there is more then one way to skin a cat.
 
Old 05-16-2012, 10:15 PM   #8
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
Run "lspci -v" to determine what the wireless device is. Run "lspci -n" for the manufacture's ID for the devices controller. This info will provide information on the kernel module needed. Then you may need to locate firmware for the kernel module to operate. For atheros devices, you usually don't.

A kernel module is needed before you can even try to authenticate. The yast2 network configuration tool can guide you through the rest.

Post the relevant output from the lspci commands I listed. We can help you more with that info.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenSUSE 11.3 and Orinoco Silver Wireless Card - Won;t Connect cornwallav8r Linux - Laptop and Netbook 1 01-11-2011 10:50 PM
Can't connect with wireless Linksys card - using OpenSuse Whatshisface Linux - Networking 1 12-10-2009 12:31 PM
Cannot connect to wireless network from opensuse holy_polaris Linux - Newbie 4 11-09-2008 06:11 PM
openSuSE Wireless Card Connect on Boot darkhammer81 Suse/Novell 1 06-20-2007 04:11 PM
opensuse 10.2 recognises wireless card, but won't connect nmsuaussie Linux - Newbie 3 05-24-2007 03:21 AM


All times are GMT -5. The time now is 03:39 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration