LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 03-01-2004, 01:46 PM   #1
jrhessey
LQ Newbie
 
Registered: Feb 2004
Location: NW Ohio
Distribution: Red Hat 9.0 Mankdrake 9.2
Posts: 13

Rep: Reputation: 0
broadcom 802.11g and mdk 9.2 can't connect to LAN


first off I am using the ndiswrapper method, which appears to me that it is running right now. I have the wifi network monitor built into gnome running, which tells me N/A, and when I type in the loaddriver command wifi and four little red dots appear. So to me that tells me its loaded. When I boot, eth0 (wired) and eth1 (wireless) both boot up to ok, unless the eth0 doesn't have a cable plugged in. Other than that nothing seems to look wrong. I type in vi /etc/sysconfig/network-scripts/ifcfg-eth1 to edit that... here it is...

Quote:
DEVICE=eth1
BOOTPROTO=dhcp
ONBOOT=yes
TYPE=Wireless
ESSID=tribefans
KEY=87E146422170FA648C7168483A0
CHANNEL=11
GATEWAY=192.168.0.1
I figured that was all I needed... I moved onto the iwconfig and get this...

Quote:
lo no wireless extensions.

eth0 no wireless extensions.

eth1 IEEE 802.11g ESSID:""
Mode:Managed Frequency:2.462GHz Bit Rate=54Mb/s Tx-Power:16 dBm
RTS thr=2347 B Fragment thr=2346 B
Encryption keyff
Power Managementff
Link Quality:0 Signal level:246 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
in order for me to change anything with a command like:
iwconfig eth1 essid tribefans
it must be set to mode: Ad-Hoc. Managed will not let me change anything. This is what I get....

Quote:
[root@localhost don]# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

eth1 IEEE 802.11g ESSID:""
Mode:Managed Frequency:2.462GHz Bit Rate=54Mb/s Tx-Power:16 dBm
RTS thr=2347 B Fragment thr=2346 B
Encryption keyff
Power Managementff
Link Quality:0 Signal level:246 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

[root@localhost don]# iwconfig eth1 essid tribefans
[root@localhost don]# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

eth1 IEEE 802.11g ESSID:""
Mode:Managed Frequency:2.462GHz Bit Rate=54Mb/s Tx-Power:16 dBm
RTS thr=2347 B Fragment thr=2346 B
Encryption keyff
Power Managementff
Link Quality:0 Signal level:246 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
I tried typing ifup eth1 and got this error...

Quote:
Error for wireless request "Set Frequency" (8B04) :
SET failed on device eth1 ; No such device.
Error for wireless request "Set Encode" (8B2A) :
SET failed on device eth1 ; Operation not permitted.
Determining IP information for eth1... failed; no link present. Check cable?
I am like 15 feet away from my wireless router...

and now.... I'm stuck...

My lan setup is based on WIN XP ICS. The router is not DHCP, The "Server" is the dhcp. If I hook up eth0 linux works like a charm.

I have no idea what to do now... I've searched and couldn't find anything that seemed to help.... Any ideas??? Thanks!!
 
Old 03-01-2004, 02:11 PM   #2
beyer42
Member
 
Registered: Dec 2003
Location: San Jose
Distribution: Redhat WS 3
Posts: 410

Rep: Reputation: 30
not sure why Managed would give problems.

try for KEY syntax
KEY="restricted [1] xxxxxxxxxx"

Maybe also try 64 bit key (10 hex digits) instead for testing.

Also try adding NETMASK and BROADCAST settings
NETMASK=255.255.255.0
BROADCAST=192.168.0.255

Last edited by beyer42; 03-01-2004 at 02:39 PM.
 
Old 03-01-2004, 03:06 PM   #3
jrhessey
LQ Newbie
 
Registered: Feb 2004
Location: NW Ohio
Distribution: Red Hat 9.0 Mankdrake 9.2
Posts: 13

Original Poster
Rep: Reputation: 0
here is what I get...

Quote:
[root@localhost don]# iwconfig eth1 KEY="restricted [1] 87E146422170FA648C7168483A0"
Error : unrecognised wireless request "KEY=restricted [1] 87E146422170FA648C7168483A0"
This one doesn't return anything...
Quote:
[root@localhost don]# KEY="restricted [1] 87E146422170FA648C7168483A0"
Quote:
[root@localhost don]# iwconfig eth1 KEY="restricted [1] 64e2861d28" Error : unrecognised wireless request "KEY=restricted [1] 64e2861d28"
I added the netmask and broadcast to the file ifcfg-eth1 file

when I add just Key ### whatever I get this now...

Quote:
[root@localhost don]# iwconfig eth1 key 87E146422170FA648C7168483A0
Error for wireless request "Set Encode" (8B2A) :
SET failed on device eth1 ; Operation not permitted.

p.s. this is what the ad-hoc'd eth1 looks like...

Quote:
eth1 IEEE 802.11g ESSID:"tribefans"
Mode:Ad-Hoc Frequency:2.462GHz Cell: D6:A2:B4:FF:13:4D
Bit Rate=11Mb/s Tx-Power:16 dBm
RTS thr=2347 B Fragment thr=2346 B
Encryption keyff
Power Managementff
Link Quality:0 Signal level:199 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
 
Old 03-02-2004, 01:41 AM   #4
delvsional
LQ Newbie
 
Registered: Jan 2004
Location: california
Posts: 1

Rep: Reputation: 0
I'm just a newbie, but I got this to work on my Fujitsu. try typing
iwconfig eth1 ap any
ap will force it to connect to the nearest router.
If you are using the linuxant wrapper another thing that works sometimes is to go to 127.0.0.1:18020 in your browser and then click on settings - advanced and then save.
 
Old 03-02-2004, 11:10 AM   #5
jrhessey
LQ Newbie
 
Registered: Feb 2004
Location: NW Ohio
Distribution: Red Hat 9.0 Mankdrake 9.2
Posts: 13

Original Poster
Rep: Reputation: 0
thanks.... I'll give that a try tonight when I get home...
 
Old 03-03-2004, 09:43 AM   #6
jrhessey
LQ Newbie
 
Registered: Feb 2004
Location: NW Ohio
Distribution: Red Hat 9.0 Mankdrake 9.2
Posts: 13

Original Poster
Rep: Reputation: 0
that didn't work either...

I removed the wep access key and when I booted up and typed in iwconfig, the essid read "tribefans" with out any editing. However I couldn't get it to pick up an IP addy. So I turned on the dhcp on the netgear router, to see if I could get an IP addy from that. That didn't work either. When I turned dhcp off however, it know says tribefans in the essid and I have to add that, which I can only do in ad-hoc mode.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
broadcom BCM94306 802.11g NIC mewgle Linux - Hardware 3 03-15-2005 06:53 AM
Broadcom 802.11g built in wireless klfreese Linux - Hardware 6 07-01-2004 12:30 AM
Installing Broadcom 802.11g drivers in Mandrake 10 mrminator Linux - Wireless Networking 1 06-10-2004 01:11 PM
2580US Broadcom 802.11g Problem Zephirus Linux - Laptop and Netbook 3 05-04-2004 11:10 PM
Broadcom 802.11g linuxant redhat 9 help gwbyrd Linux - Laptop and Netbook 2 11-27-2003 05:27 PM


All times are GMT -5. The time now is 08:51 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration