LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices



Reply
 
Search this Thread
Old 10-22-2007, 07:10 AM   #1
ckob
LQ Newbie
 
Registered: Aug 2007
Posts: 22

Rep: Reputation: 15
upgraded apache and php now php breaks on ' and special characters


I upgraded apache and php and now some of my websites break on special characters mainly ' . I tried using the php setting Magic quotes but that did nothing. If someone could shed some light on this I would appreciate it.
 
Old 10-22-2007, 09:10 AM   #2
wolfperkins
Member
 
Registered: Oct 2007
Location: Val-des-Monts, Québec, Canada
Distribution: CentOS, RHEL, Fedora
Posts: 109

Rep: Reputation: 16
Are there parse errors in the apache logs?

What version of PHP?

What version of Apache?
 
Old 10-22-2007, 09:34 AM   #3
ckob
LQ Newbie
 
Registered: Aug 2007
Posts: 22

Original Poster
Rep: Reputation: 15
none that i can see.

apache 2
php 5.16

an example would be if I do this.

query ("my hat's");

i'll get an error because "'" is in there if I take it out it works fine im sure its a setting somewhere I missed.
 
Old 10-22-2007, 09:18 PM   #4
stickman
Senior Member
 
Registered: Sep 2002
Location: Nashville, TN
Posts: 1,552

Rep: Reputation: 53
Check the value of the various magic quotes variables in your php.ini file.
 
Old 10-22-2007, 10:28 PM   #5
TheZodiac
LQ Newbie
 
Registered: Oct 2007
Posts: 13

Rep: Reputation: 0
What's your "php.ini" config look like? I'll have a look at it to see what's wrong.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
php/shell script to install mysql,apache and php automatically stranger_6_7 Linux - General 2 08-11-2009 03:07 AM
How to support special characters in the URI with Apache 2.0.52 in Slack fmordhorst Linux - General 3 05-26-2006 04:21 PM
Upgraded PHP from 4.3.4 to 4.3.10 and now it won't read php.ini gregmcavoy Linux - Software 11 01-22-2005 01:16 PM
php apache or php cgi - php learner rblampain Linux - Security 3 12-18-2004 12:10 AM
Apache and PHP upgraded jeremy LQ Suggestions & Feedback 0 02-27-2002 09:26 PM


All times are GMT -5. The time now is 04:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration