LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 01-12-2008, 04:19 PM   #1
aleksPL
LQ Newbie
 
Registered: Jan 2008
Posts: 7

Rep: Reputation: 0
Wireless First newbie's Try with WPA2


Hi,

I've never used wireless at all, thats why I have no idea how to fix it.

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=20

network={
ssid="APname"
scan_ssid=1
key_mgmt=WPA-EAP
password="APpass"
}

I used ndiswrapper to install driver because my wifi card is Zonet or so
I cant even past here my whole config files and iwlist
without internet
because no-one knows why I cant use floppy and i cant write on RW disk

Can somebody tell me what is important to just somehow start this connection when my card's MAC is added in router's conf and there is WPA2 encryption

My system is debian
I've of course installed wpasupplicant
 
Old 01-12-2008, 05:00 PM   #2
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
Is this a personal setup at home using a plain store bought wireless router?

Brian
 
Old 01-12-2008, 06:19 PM   #3
aleksPL
LQ Newbie
 
Registered: Jan 2008
Posts: 7

Original Poster
Rep: Reputation: 0
its personal AccessPoint - router Linksys

i cleaned up a little bit mess in my config files
thats how it looks like now:

interfaces
Code:
iface wlan0 lo loopback
wpa-driver ndiswrapper
wpa-config /etc/wpa_supplicant.conf
wpa-bssid AP_Mac
wpa-proto WPA RSN
wireless-essid MySsid
pre-up wpa-supplicant -B -Dndiswrapper -wlan0 -c/etc/wpa_supplicant.conf
pre-down killall -q wpa_supplicant
wpa.supplicant.conf
Code:
section network:

ssid="myssid"
scan_ssid=1
key-mgmt=WPA-PSK
pairwise=CCMP TKIP
group=CCMP TKIP
psk=mypsk
i copied those two files above by hand
thas why there isn't a whole file just important part


EDIT:

and im still curios why the power of that connection is sa weak
when i connected once it was about 15%

and now when I it in NetworkManager (but i still cant connect)
that blue stripe is really short
its strange because AP is in room next to mine (about 10 meters)
and its not AP's fault because my cousin on his laptop w/ winXP has really good connection
even when she is downstairs (AP is upstair) ;p

it's pretty annoying I cant start using that computer without net ;/
I'll appreciate any help

EDIT:

i dont know why but know even in networkManager its gone
but its still shows up after iwlist scan

Last edited by aleksPL; 01-12-2008 at 07:17 PM. Reason: misprints, extensions
 
Old 01-13-2008, 10:09 AM   #4
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
The very first thing I would do is disable any security on the router. No WEP, WPA, WPA2, mac or IP filtering. Then enable dhcp if not enabled. Now make a plain connection to the router and see if it works. If it does then ndiswrapper is configured and working fine. Now you can start enabling WPA from here.

I don't use NetworkManager so I can show you as manually setup would go.
First generate the passphrase like so. If essis is capital be sure to use capital letters there. Must be exact case for characters.
/usr/sbin/wpa_passphrase YOUR_AP_SSID “YOUR_WPA_PSK_PASSPHRASE”

Place generated output in wpa_supplicant.conf.
Example of what would be in wpa_supplicant.conf
Code:
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel
# update_config=1

network={
        ssid="Your ESSID"
        #psk="unencrpyt passphrase here if wanted"
        psk=generate passphrase here
        proto=RSN
}
The proto line is WPA for WPA and RSN for WPA2.

Next I would disable NetworkManager. /sbin/service NetworkManager stop
Now bring wlan0 up. I would make sure if you have a wired nic to disable since only one can be up if both use a defined or get their own gateway.
/sbin/ifdown eth0
/sbin/ifdown wlan0
/sbin/ifup wlan0

Now start wpa_supplicant.
Code:
/usr/sbin/wpa_supplicant -dddd -Dwext -iwlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf &
Now ping the routers lan side IP. ping -c5 xxx.xxx.xxx.xxx

Does it ping? If so then you may need to do the following if you wish to forget about NetworkManager and also disable eth0 if present.

Edit /etc/sysconfig/network-scripts/ifcfg-eth0. In this file change ONBOOT=yes to ONBOOT=no

Then to disable NetworkManager on reboot.
/sbin/chkconfig --level 345 NetworkManager off

Then edit /etc/sysconfig/network-scripts/ifup-wireless and add the this to the end of it.
Code:
/usr/sbin/wpa_supplicant -dddd -Dwext -iwlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf &
Brian

Last edited by Brian1; 01-13-2008 at 10:11 AM.
 
Old 01-13-2008, 05:18 PM   #5
aleksPL
LQ Newbie
 
Registered: Jan 2008
Posts: 7

Original Poster
Rep: Reputation: 0
I disabled any security on router, then I tried connect but -
after "iwconfig wlan0 essid "APname"
i tried iwconfig to see if is ok but there wasn't my AP
I says im not associated

so i tried once again install driver (actually i tried two different drivers) but any of them did work

im still "not associated"

Its my 3rd or 4th day working on fix that wireless and i cant see any results
first time im so frustrated that i really want give up and install winXP
 
Old 01-29-2008, 10:59 PM   #6
Lexcel
LQ Newbie
 
Registered: Jan 2008
Posts: 1

Rep: Reputation: 0
Smile Fixed

Brian1 - thanks for your assistance. Your WPA2 guidance got me on perfectly.
 
Old 01-30-2008, 05:34 AM   #7
aleksPL
LQ Newbie
 
Registered: Jan 2008
Posts: 7

Original Poster
Rep: Reputation: 0
I don't really know why but I had to change wireless card
when I was was trying to locate problem and I turned off all security like wpa2 and mac
It still hadn't work
It was brand new car but I return it (send back to store) and bought new one TP-Link which is great
compatible with madwifi so configuration took me just awhile
 
Old 09-23-2010, 01:18 AM   #8
David_Slimp
LQ Newbie
 
Registered: Sep 2010
Location: Austin, TX
Distribution: Fedora
Posts: 1

Rep: Reputation: 0
Brian1 - another thanks here!

I did a lot of searching the web to try and move away
from NetworkManager on a laptop in always in the livingroom,
to a setup where the wireless network would automatically
come up at boot time, and connect via WPA2 to the home-router.

After trying to follow several other methods (pages) over
the last few days, your guide here is exactly what I needed
for Fedora 13.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
scripts (kommander and command line) to start wireless devices with wpa/wpa2/wpa-aes Fluxx Linux - Wireless Networking 4 06-28-2010 02:51 AM
Fedora 7 - Intel 3945ABG wireless - WPA2 parkerdt Fedora - Installation 8 10-05-2007 04:44 AM
CNet Wireless-G USB Dongle 54 Mbps 802.11g, WPA/AES/WPA2 compatible to SuSe 10.1? ungua Linux - Hardware 2 06-14-2007 05:31 AM
Newbie's newbies attempt at wireless jartzh Linux - Wireless Networking 5 11-19-2005 06:07 AM
Wpa2 in linux hyapadi Linux - Wireless Networking 1 06-29-2005 01:50 AM


All times are GMT -5. The time now is 07:51 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration