LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 01-07-2009, 01:59 PM   #1
bluedragontao
LQ Newbie
 
Registered: Jan 2009
Posts: 3

Rep: Reputation: 0
Exclamation CUPS in Slack 12.1 : 'foomatic failed'


Hallo all,

I'm a newbie to slackware (a week at most), and i've managed to pick up the basics of Linux from playing around with a Knoppix distro on the systems, but i'm trying to get my desktop set up with a proper system.

I'm running Slackware 12.1.

Hardware:
AMD64 1.99GHz processor
1 gig RAM
1.5 TB Seagate SATA-3.0 Hard-drive

Have no pity, even though it's an Emachine D-series.

My problem is that CUPS continues to fall down and go boom every time I try to print. I'm trying to send it to a Konica Minolta PagePro 1350W, through a USB port on the box itself, and not through a different system.

When I set it up in CUPS, everything goes smoothly. But when i click the 'print test page' button, it says the job's failed and i get
Quote:
/usr/lib/cups/filter/foomatic-rip failed
as the status. Currently, I'm getting a bit annoyed.

Please note that I've been using Windoze for most of my computing life, so go easy on me. Explanations of what exactly i'm to do would be most useful, as I'm always looking for more pointers.
 
Old 01-07-2009, 04:58 PM   #2
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,231

Rep: Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039
My guess is you don't have an appropriate driver for that printer.

So I suggest you try this:

1) Using Firefox, go to this page
2) Near the bottom of the page choose "Minolta PagePro 1350W" in the drop-down list, then hit the "Generate PPD file" button next to it.
3) When asked choose "Save file". Check in Firefox menu (Edit => Preferences ==> "Save files to") the location where the file has been saved.
4) Check that you printer is up and connected to the computer
5) type localhost:631 in Firefox's address bar to configure CUPS
6) Choose "Add Printer"
6) Choose e.g. Minolta as name for the printer-- you may leave alone the two other fields, then hit Continue.
7) On the next page choose your device on the drop-down list (should be USB something)
8) As no driver for your printer is available in the distribution, you'll provide the file you downloaded at step #3 instead. So click Browse and go to the location where you saved the file downloaded at step #3 , highlight the file's name (<something>.ppd) and hit Open, then hit Add Printer.
9) Upon request, give the credentials needed to continue : user root, password <root_password>
10) Then you should be asked to setup printer options. Usually, only Paper Size matters. Choose it then hit Set Printer Options.
11) If all did go as expected you should be able to print a test page.

Last edited by Didier Spaier; 01-07-2009 at 05:00 PM. Reason: Typo
 
Old 01-09-2009, 03:55 PM   #3
bluedragontao
LQ Newbie
 
Registered: Jan 2009
Posts: 3

Original Poster
Rep: Reputation: 0
Didier, thanks, but I'm afraid that's what I did before.
However, at no point did it ask me for the root password. Might be because I added myself
to the proper group.

It didn't work this time either, I'm afraid.
 
Old 01-10-2009, 03:29 AM   #4
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,231

Rep: Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039
Quote:
Originally Posted by bluedragontao View Post
However, at no point did it ask me for the root password. Might be because I added myself
to the proper group.
Seems strange. I added all "power" groups to a regular user account and still, I can't add or delete a printer if I don't give root's credentials.
So may be another software you have installed messed up your files permissions ??
If you are sure you followed all installation steps, would you mind removing then re-installing all cups-related packages, as shown in the Slackware Package Browser ? If it won't help, at least it won't hurt
PS when you re-install the packages, take cups-1.3.9 as it is an official upgrade.
PS2 Hope you did install foomatic-filters package. If missing, this could be another explanation of the issue ??

Last edited by Didier Spaier; 01-10-2009 at 03:35 AM. Reason: Typo
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Printing Problem - Cups, Foomatic and HP LaserJet Jude Lucien Debian 3 02-23-2006 10:23 AM
CUPS-Foomatic-gimp-print problem Osborne1934 Linux - Newbie 1 07-23-2005 03:54 PM
CUPS not 'talking' to foomatic? gjhicks Debian 7 07-22-2004 08:33 AM
Why is printing so complicated? (HP, FOOMATIC and CUPS problems.) Jefficus Linux - General 1 02-04-2004 06:36 PM
gentoo+cups+ghostscript+foomatic=nothing works busbarn Linux - Software 1 04-30-2003 11:28 AM


All times are GMT -5. The time now is 09:45 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration