LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 04-14-2010, 03:47 PM   #1
lilou_b
LQ Newbie
 
Registered: Apr 2010
Posts: 11

Rep: Reputation: 1
Exclamation can't differentiate system language from keyboard language?


i recently got a french msi wind U100x running on linux suse enterprise 10 sp1. (i am french and wanted a light netbook with french keyboard)

i am totally new to linux and i believe that msi wind is not helping.

because i am more used to english for settings, i set the main language to english, but it seems that it automatically reconfigures my keyboard mapping to english as well, so that azerty becomes qwerty.
i reset it back to french, so now my keyboard is french, but so is the system.

is there a way to differentiate keyboard from main user setting language? how?

thanks!!
 
Old 04-14-2010, 04:29 PM   #2
ekj
Member
 
Registered: Apr 2007
Location: Sweden
Distribution: openSUSE
Posts: 37

Rep: Reputation: 16
I use openSuse 11.2, but I assume that it's the same.

Anyway, I use a Swedish keyboard layout and have English as system language. It works perfectly for me. During the installation the keyboard layout and the system language were two separate choices, that's where I set it.

I took a look in yast trying to find where to set the default settings, but as you said I only saw one language setting, and that was the primary language (system language I guess).

However, I found a user-specific setting for the keyboard layout. In Configure Desktop (find it in the menu or start it with the command "systemsettings"), click on the "Regional&Language" button, click on "Keyboard Layout". Here you can change the keyboard layout, but it has to be done for all users separately.

There really should be a way to set keyboard layout that isn't user-specific, but I cannot find any at the moment.
 
Old 04-14-2010, 05:09 PM   #3
lilou_b
LQ Newbie
 
Registered: Apr 2010
Posts: 11

Original Poster
Rep: Reputation: 1
thanks!!

it was under
- administrator settings
- system
- keyboard layout.

now i have system setting as english and keyboard layout as french, but somehow the screen resolution has changed!
 
1 members found this post helpful.
Old 04-14-2010, 05:47 PM   #4
lilou_b
LQ Newbie
 
Registered: Apr 2010
Posts: 11

Original Poster
Rep: Reputation: 1
Thumbs up

reset the correct screen resolution,
and it is now all sorted, merci!
 
  


Reply

Tags
language, msi


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Keyboard language problem maokc Linux - Newbie 2 01-11-2010 04:31 AM
Good linux chinese language language program? darsunt Linux - Software 1 04-10-2009 12:06 PM
Keyboard language Tanglo Linux - Software 1 04-14-2005 04:42 AM
Keyboard and Language under KDE fiod Linux - General 0 09-12-2003 07:37 PM
keyboard language in X windows Frustin Linux - Hardware 1 08-12-2003 02:37 AM


All times are GMT -5. The time now is 04:49 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration