LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 12-21-2004, 11:48 AM   #1
rblampain
Member
 
Registered: Aug 2004
Location: Western Australia
Distribution: Debian 7
Posts: 837

Rep: Reputation: 35
mount to NFS server '192.168.1.13' failed: server is down


I had NFS/NIS working on 2 fedora2 machines on a LAN. I had to reinstall the OS on both (plus the changed configuration files) because neither was rebooting properly and I find now the "client" is giving the following error messages when rebooting:

mount to NFS server '192.168.1.13' failed: server is down

The '/etc/fstab' on the client had been extended by a number of lines to match the entries in the server "/etc/exports" file and I gave them the following format:

192.168.1.13:/home /mnt nfs ro 0 0

and the error messages are given for each of those entries in the client's "/etc/fstab"

This client is 192.168.1.6 and the server is 192.168.1.13. I spent half a day checking and
google-ing but I can't figure out where the problem might be.
Where should I look? Any hint welcome.


Due to the volume, I am a bit reluctant to paste a copy of all the relevant files in this post.
Here is a script I ran on the server and its result.
#!/bin/bash
# nfs.sh
/etc/rc.d/init.d/nfs start
/usr/sbin/exportfs -ra
/usr/sbin/rpc.mountd
/usr/sbin/rpc.nfsd
/sbin/rpc.statd
/sbin/rpc.lockd
/usr/sbin/rpc.rquotad

# set up NIS on server
nisdomainname nobla.org
nisdomainname
/etc/init.d/portmap start
/usr/sbin/ypserv start
/usr/sbin/rpcinfo -u localhost ypserv
/usr/lib/yp/ypinit -m
/etc/rc.d/init.d/yppasswdd start

[root@lt bin]# ./nfs.sh
Starting NFS services: [ OK ]
Starting NFS quotas: [ OK ]
Starting NFS daemon: [ OK ]
Starting NFS mountd: [ OK ]
nobla.org [ OK ]
Starting portmapper: [ OK ]
program 100004 version 1 ready and waiting
program 100004 version 2 ready and waiting

At this point, we have to construct a list of the hosts which will run NIS
servers. lt is in the list of NIS server hosts. Please continue to add
the names for the other hosts, one per line. When you are done with the
list, type a <control D>.
next host to add: lt
next host to add:
The current list of NIS servers looks like this:

lt

Is this correct? [y/n: y] y
We need a few minutes to build the databases...
Building /var/yp/nobla.org/ypservers...
Running /var/yp/Makefile...
gmake[1]: Entering directory `/var/yp/nobla.org'
Updating passwd.byname...
Updating passwd.byuid...
Updating group.byname...
Updating group.bygid...
Updating hosts.byname...
Updating hosts.byaddr...
Updating rpc.byname...
Updating rpc.bynumber...
Updating services.byname...
Updating services.byservicename...
Updating netid.byname...
Updating protocols.bynumber...
Updating protocols.byname...
Updating mail.aliases...
gmake[1]: Leaving directory `/var/yp/nobla.org'

lt has been set up as a NIS master server.

Now you can run ypinit -s lt on all slave server.
Starting YP passwd service: [ OK ]
=================================================================
And a copy of /etc/hosts.deny and /etc/hosts.allow
#
# hosts.deny This file describes the names of the hosts which are
# *not* allowed to use the local INET services, as decided
# by the '/usr/sbin/tcpd' server.
#
# The portmap line is redundant, but it is left to remind you that
# the new secure portmap uses hosts.deny and hosts.allow. In particular
# you should know that NFS uses portmap!
portmap:ALL
lockd:ALL
mountd:ALL
rquotad:ALL

#
# hosts.allow This file describes the names of the hosts which are
# allowed to use the local INET services, as decided
# by the '/usr/sbin/tcpd' server.
#
portmap: 192.168.1.6
lockd: 192.168.1.6
rquotad: 192.168.1.6
mountd: 192.168.1.6
statd: 192.168.1.6
ALL: localhost
rpc.mount: ALL
===================================================================
Here is the relevant part of /var/log/messages
Dec 21 22:43:58 lt nfs: Starting NFS services: succeeded
Dec 21 22:43:58 lt nfs: rpc.rquotad startup succeeded
Dec 21 22:43:58 lt nfs: rpc.nfsd startup succeeded
Dec 21 22:44:08 lt nfs: rpc.mountd startup succeeded
Dec 21 22:44:08 lt rpcidmapd: rpc.idmapd -SIGHUP succeeded
Dec 21 22:44:28 lt rpc.statd[2838]: Version 1.0.6 Starting
Dec 21 22:44:28 lt portmap[2851]: cannot bind udp: Address already in use
Dec 21 22:44:28 lt portmap: portmap startup succeeded
Dec 21 22:44:28 lt ypserv[2856]: ypserv already running (pid 2342) - exiting
Dec 21 22:44:36 lt yppasswdd: rpc.yppasswdd startup succeeded
Dec 21 22:44:36 lt rpc.yppasswdd[3027]: rpc.yppasswdd already running (pid 2513) - exiting
 
Old 01-13-2005, 06:12 PM   #2
mmahoney
LQ Newbie
 
Registered: Jan 2005
Location: Queensland
Distribution: FC3,RH8,7.3,7.1
Posts: 4

Rep: Reputation: 0
Did you get this sorted?
I have a similar problem trying to mount NFS shares on RH7.1 servers with an FC3 client.
Works fine with RH8.0 server
The error I get is:
[root@holly src]# mount -v -t nfs -o nfsvers=2,udp lala:/atoll /atoll
mount to NFS server 'lala' failed: server is down.
RPC Error: 14 ( Port mapper failure )

I have used rpcinfo to try track down the differences:
For the 7.1 server:
[root@holly local]# /usr/sbin/rpcinfo -p lala
program vers proto port
100000 2 tcp 111 portmapper
100000 2 udp 111 portmapper
100024 1 udp 32768 status
100024 1 tcp 32768 status
100021 1 udp 32769 nlockmgr
100021 3 udp 32769 nlockmgr
100021 4 udp 32769 nlockmgr
100011 1 udp 751 rquotad
100011 2 udp 751 rquotad
100005 1 udp 32770 mountd
100005 1 tcp 32769 mountd
100005 2 udp 32770 mountd
100005 2 tcp 32769 mountd
100005 3 udp 32770 mountd
100005 3 tcp 32769 mountd
100003 2 udp 2049 nfs
100003 3 udp 2049 nfs

For the 8.0 machine:
[root@holly local]# /usr/sbin/rpcinfo -p winnie7
program vers proto port
100000 2 tcp 111 portmapper
100000 2 udp 111 portmapper
100024 1 udp 32768 status
100024 1 tcp 32768 status
100021 1 udp 32769 nlockmgr
100021 3 udp 32769 nlockmgr
100021 4 udp 32769 nlockmgr
100021 1 tcp 32769 nlockmgr
100021 3 tcp 32769 nlockmgr
100021 4 tcp 32769 nlockmgr
391002 2 tcp 32770 sgi_fam
100011 1 udp 738 rquotad
100011 2 udp 738 rquotad
100011 1 tcp 741 rquotad
100011 2 tcp 741 rquotad
100003 2 udp 2049 nfs
100003 3 udp 2049 nfs
100003 2 tcp 2049 nfs
100003 3 tcp 2049 nfs
100005 1 udp 32770 mountd
100005 1 tcp 32771 mountd
100005 2 udp 32770 mountd
100005 2 tcp 32771 mountd
100005 3 udp 32770 mountd
100005 3 tcp 32771 mountd

The difference seems to be nfs running over TCP as well as UDP on the RH8 server.
Have searched man and google but can't figure out how to set up NFS over TCP on RH7.1
But I could be on the wrong track altogether.
Any clues anyone?
 
Old 01-14-2005, 02:19 AM   #3
rblampain
Member
 
Registered: Aug 2004
Location: Western Australia
Distribution: Debian 7
Posts: 837

Original Poster
Rep: Reputation: 35
To mmahoney,
This is some time ago, i can't remember exactly what the solution was but it was simple, as you can see there was no reply to this and I managed to solve it and I am only a beginner. What follows was done on Fedora C2 but I would think it would apply as far back as RH 7. If not you may have to locate some file on your distro.

A few useful 'tricks' I found:
Run /sbin/ntsysv and make sure Apache and NTFS are started at boot time. If you don't know, this is a GUI interface and all you have to do is go up and down in the menu and make sure the options you want started at boot time are marked with an asterisk, else you can use chkconfig as follows

/sbin/chkconfig httpd on
/sbin/chkconfig nfs on
/sbin/chkconfig nfslog on

then reboot

It is easy to get confused if one of the parameters is not satisfactory, for example I kept adding lines in config files and changing them as I went, only to make things worse, I found all that was unnecessary. Now I've got things working smoothly with a minimum of work as explained in howto's and as follows:
/etc/exports on the server
/etc/fstab on the client
and that's it, it should go, the only thing that could still stop it is permissions (files or firewall or hosts.allow hosts.deny IF YOU have changed them from the default ones).

Everything else is commands that you can use as shortcuts, (like changing the file /etc/exports and re-reading it) that
make things worse if not used properly, at least that was my case. I ended up with big useless and incorrect files.

If you need some examples, let me know and I'll post my files.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ProFTPD - "500 Sorry, no server available to handle request on 192.168.1.103" - what? orange400 Linux - General 15 05-21-2013 03:59 PM
mount to NFS server 'ip addr' failed: server is down. timvand Linux - Networking 1 04-22-2005 03:03 PM
Is someone on my network?! ::ffff:192.168.0.10:ssh ::ffff:192.168.0.:38201 ESTABLISHE ming0 Linux - Security 4 04-12-2005 02:04 AM
192.168.2.1 network with 192.168.0.1? Micro420 Linux - Networking 2 02-27-2005 07:59 AM
Iptables is converting -s 192.168.1.0/8 into 192.0.0.0/8 why !? qwijibow Linux - Security 2 01-26-2005 10:57 AM


All times are GMT -5. The time now is 01:56 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration