LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 07-30-2005, 12:01 PM   #1
kmierle
LQ Newbie
 
Registered: Jul 2005
Posts: 1

Rep: Reputation: 0
Can't turn off RF Kill switch on Asus Z33A with Intel 2200BG wireless


I can't for the life of me turn off the stupid RF Kill switch on my brand new Asus Z33A. I'm running Debian, but I don't think this is a Linux problem. After modprobe ipw2200, I get:

ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.0.4
ipw2200: Copyright(c) 2003-2004 Intel Corporation
ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
ip2200: Radio Frequency Kill Switch is On:
Kill switch must be turned off for wireless networking to work.

# cat /sys/bus/pci/devices/*/rf_kill
2

which means the ip2200 driver detected a HW RF switch. I've tried Fn+F2 (which has the little wireless icon in blue), but that doesn't seem to do anything. The wireless LED on the laptop is off. I also tried opening the back and pressing on the RF connectors to make sure they were connected, but they seemed pretty secure to me.

# iwlist eth1 scan
eth1 No scan results

which is clearly wrong, as my laptop is literally 2 feet away from my wireless router.

I also tried:
# modprobe asus_acpi
# echo 1 > /proc/acpi/asus/wled

then reloading the ipw module. This has no effect, the kill switch is still on

Has anyone else had this problem?

Thanks in advance,
Keir
 
Old 07-30-2005, 06:20 PM   #2
MattD82
LQ Newbie
 
Registered: Jun 2005
Location: Norfolk, VA
Posts: 5

Rep: Reputation: 0
Had the same problem (Asus Z33A also)

Heres how I fixed it:

1) Install ipw2200 (http://ipw2200.sourceforge.net/)

2) Install ipw2200 firmware (from the above site)

3) Upgraded to the latest BIOS www.asus.com


-Matt
 
Old 09-22-2005, 10:11 PM   #3
filex
Member
 
Registered: Sep 2004
Posts: 56

Rep: Reputation: 15
I use to type "setkeycodes" command follow by pressing "Wireless Button" to make it change to rf_kill = "0"
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel PRO/Wireless 2200BG henriette Linux - Laptop and Netbook 5 05-20-2007 02:50 PM
Intel PRO/Wireless 2200BG wfischer Linux - Wireless Networking 3 10-25-2006 09:20 AM
Intel 2200BG wireless problems idahoakl Suse/Novell 4 03-12-2005 08:24 AM
Intel PRO 2200BG doesn't turn on motovoi Linux - Wireless Networking 0 10-10-2004 10:42 AM
FC2 not recognizing the Intel PRO/Wireless 2200BG wireless card mdslf Linux - Laptop and Netbook 2 08-24-2004 02:25 AM


All times are GMT -5. The time now is 01:10 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration