LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
LinkBack Search this Thread
Old 08-26-2010, 08:21 AM   #1
ayush.27
LQ Newbie
 
Registered: Aug 2010
Location: Pune, India
Distribution: Ubuntu, Lubuntu
Posts: 29

Rep: Reputation: 0
Suspend/Sleep mode doesn't work in any linux distro


I've tried ubuntu, kubuntu, fedora and linux mint. all 64 bit versions.

I've also tried to suspend through applications like acpitool. But nothing works.
When I click on Suspend, the screen goes blank but the computer is still running. The wireless network adaptor gets disabled for a second and then comes back on. All I have to do is press a key and I get the unlock screen prompt. Basically, suspend works like 'Lock Screen'.

I have a HP Pavillion laptop. Core 2 Duo @ 2 GHz and 4 GB RAM.

Can anyone help me please?
 
Old 08-26-2010, 08:46 AM   #2
lylemwood
Member
 
Registered: Jan 2008
Location: Toronto, Canada
Distribution: Slackware, CentOS
Posts: 45

Rep: Reputation: 18
ayush,

In my experience this has been driver-related. When I installed the proprietary driver for my graphics card on my old tablet to get the performance I wanted I noticed this happened to my suspend features...

Did you install the proprietary gfx drivers? Any other kinds of system modifications made?

Which Distribution are you running currently and which model of pavilion are you running?

I found a great ref on the pavilion, but I don't know if it's your model... Here's the link: http://www.linlap.com/wiki/hp+pavilion+dv5-1000+series

Also, there is a notice regarding suspend/hibernate:

Quote:
Other

Suspend/Hibernate aren't working on this laptop. See [https://bugs.launchpad.net/ubuntu/+s...ux/+bug/301353 this bug] to follow the issue.
 
Old 09-01-2010, 06:04 AM   #3
ayush.27
LQ Newbie
 
Registered: Aug 2010
Location: Pune, India
Distribution: Ubuntu, Lubuntu
Posts: 29

Original Poster
Rep: Reputation: 0
Thanks for replying

Quote:
Originally Posted by lylemwood View Post
ayush,

In my experience this has been driver-related. When I installed the proprietary driver for my graphics card on my old tablet to get the performance I wanted I noticed this happened to my suspend features...

Did you install the proprietary gfx drivers? Any other kinds of system modifications made?
How can I do that?

Quote:
Which Distribution are you running currently and which model of pavilion are you running?
I'm running Ubuntu 10.04 64 bit on HP Pavillion dv4-1125nr.
The website you mentioned does not have an entry for this laptop.
 
Old 09-01-2010, 06:07 AM   #4
ayush.27
LQ Newbie
 
Registered: Aug 2010
Location: Pune, India
Distribution: Ubuntu, Lubuntu
Posts: 29

Original Poster
Rep: Reputation: 0
In windows, if I go to Device Manager(control panel) and look in "System devices", I see something called "ACPI Sleep Button". Also, sleep/suspend mode works fine on Windows Vista 64 bit.

Does anyone have a clue as to what the problem might be?
 
Old 09-02-2010, 01:29 PM   #5
lylemwood
Member
 
Registered: Jan 2008
Location: Toronto, Canada
Distribution: Slackware, CentOS
Posts: 45

Rep: Reputation: 18
let's check Ubuntu

Hi Ayush,

Let's eyeball Ubuntu for a sec. I know typically these settings are pre-set and working fine, but let's just make sure there isn't something funky with this hardware and Ubuntu...

Check here https://wiki.ubuntu.com/PowerManagement for the info about the packages. Let's just make sure you've got all the acpi packages. I know, the kernel is supposed to be handling it all, but let's make sure you have the /etc/acpi... stuff to handle everything.

Please have a read at that and make sure it's all set (settings as well as packages).

Also, in your BIOS, is the ACPI section listed? Any chance you could publish those settings?

Anyone else have specific experience with Ubuntu and this kind of hardware/issue?
 
Old 09-02-2010, 01:32 PM   #6
lylemwood
Member
 
Registered: Jan 2008
Location: Toronto, Canada
Distribution: Slackware, CentOS
Posts: 45

Rep: Reputation: 18
Does this article look like an accurate description of your problem?

https://bugs.launchpad.net/ubuntu/+s...ux/+bug/605133

From what I see, they are using fglrx drivers. Are you using the fglrx gfx drivers as well?
 
Old 09-02-2010, 11:10 PM   #7
ayush.27
LQ Newbie
 
Registered: Aug 2010
Location: Pune, India
Distribution: Ubuntu, Lubuntu
Posts: 29

Original Poster
Rep: Reputation: 0
Thanks lylemwood. But suspend now works on linux. I did three things :-

1. Updated the BIOS to the latest version
2. Switched to 32-bit even though my the processor is 64-bit
3. Switched to Linux Mint (I doubt this would have made any difference as Mint is based on Ubuntu)
4. Installed proprietary drivers for my wireless adapter instead of a free one

Any idea which one of these could have done the trick?
 
Old 09-02-2010, 11:33 PM   #8
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,380
Blog Entries: 3

Rep: Reputation: 169Reputation: 169
it is a simple script that does it seems linux mint has worked on the generic scripts and has pre-setup power modes just a simple script. then it is up to your power settings for resume.
 
Old 09-03-2010, 12:39 AM   #9
SaintDanBert
Senior Member
 
Registered: Jan 2009
Location: Austin, TX
Distribution: Mint-15 with Cinnamon & KDE
Posts: 1,272
Blog Entries: 3

Rep: Reputation: 86
Quote:
Originally Posted by ayush.27 View Post
Thanks lylemwood. But suspend now works on linux. I did three things :-

1. Updated the BIOS to the latest version
2. Switched to 32-bit even though my the processor is 64-bit
3. Switched to Linux Mint (I doubt this would have made any difference as Mint is based on Ubuntu)
4. Installed proprietary drivers for my wireless adapter instead of a free one

Any idea which one of these could have done the trick?
I've fought a similar problem and most of my success came after I moved to 32-bit with PAE instead of a 64-bit distro. I still have troubles with all sorts of suspend.

One of the things that troubles(sic) me most is the lack of information about how these features work, how to enable logging of the spin-down processing, how to enable logging of the wake-up processing, how to see what is going on, how to configure details like where "suspend" writes its details. Note: It seems that you must have a properly sized (whatever that means) swap partition. A swap file does not seem to work.

Wishing & Hoping for help,
~~~ 0;-/ Dan
 
Old 09-03-2010, 07:29 AM   #10
lylemwood
Member
 
Registered: Jan 2008
Location: Toronto, Canada
Distribution: Slackware, CentOS
Posts: 45

Rep: Reputation: 18
SaintDanBert,

The issue with the logging component comes from the fact that the system is disabling critical resources during the spin-down and hasn't got them all up during the spin-up...

Logging depends on having a drive available to store, but if you've just powered that drive off you're screwed for logging.

Note to those working on code for this (if they actually read this): It would be nice if the logging could be cached to RAM during the spin-down and then appended during the spin-up and dumped to the log file after reload, but that would only work if the system actually recovered... If you have a faulty process, which is pretty much the only reason you'd consult the logs, you'd never have the logs committed so it's a waste of time (I guess that's why they don't bother)...

Regarding the SWAP partition, I usually make it equal to or 1.5x my RAM. This allows for suspend and for the (occasional) overrun in app processing.

I've never heard of a Linux distro that uses a SWAP FILE, only partitions.

I'd recommend using something like System Rescue CD or Knoppix to resize the partitions and give yourself a fairly nice SWAP (1-1.5x RAM) and see if your issues go away...

Any other issues?
 
Old 09-03-2010, 11:30 PM   #11
ayush.27
LQ Newbie
 
Registered: Aug 2010
Location: Pune, India
Distribution: Ubuntu, Lubuntu
Posts: 29

Original Poster
Rep: Reputation: 0
Well, now I've installed 64 bit Linux Mint and suspend is still working fine. So it was either the BIOS update or the switch to Linux Mint from Ubuntu, that made it work.
 
Old 09-04-2010, 10:58 AM   #12
SaintDanBert
Senior Member
 
Registered: Jan 2009
Location: Austin, TX
Distribution: Mint-15 with Cinnamon & KDE
Posts: 1,272
Blog Entries: 3

Rep: Reputation: 86
Quote:
Originally Posted by lylemwood View Post
...
I've never heard of a Linux distro that uses a SWAP FILE, only partitions.
...
In short a swap file is like any other file that just happens to be dedicated to swap (paging) data. Unlike ordinary files, swap files must be contiguous -- all of the segments of the file must be adjacent without any gaps or skips.

Take a look at this
to learn about swap files.

Suspend Logging
Suspend must write the system state somewhere. This situation is similar to the dmesg and related kernel logging. Logging details could be part of that data. (This might be a good place to "require" a swap file ... to be used for suspend logging details.) I'm even willing to stipulate that suspend logging write to a serial port as raw text or similar.

Enjoy,
~~~ 0;-Dan
 
Old 09-23-2010, 04:02 AM   #13
SaintDanBert
Senior Member
 
Registered: Jan 2009
Location: Austin, TX
Distribution: Mint-15 with Cinnamon & KDE
Posts: 1,272
Blog Entries: 3

Rep: Reputation: 86
Suspend-to-disk (hibernate) and suspend-to-ram (sleep) still do not work for me. I have two, almost identical Thinkpad laptops (model 7764-CTO). One runs Jaunty (v9.04) and one runs Lucid (v10.04 LTS). Neither laptop will sleep or hibernate. A laptop without some sort of suspend is a real bear to take walk-about.

I have heard stories about causes:
  • video hardware
  • video drivers
  • network hardware
  • network drivers
  • other configuration -- swap space vs. ram size, etc
  • applications

Does anyone have a clue how to sort this out? I really need to get suspend to work.

Merci d'avance,
~~~ 0;-Dan

Last edited by SaintDanBert; 09-23-2010 at 04:05 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu 10.04 sleep mode won't work cferron Linux - Laptop and Netbook 8 10-24-2010 02:36 PM
Suspend doesn't work on any linux distro Enry211 Linux - Laptop and Netbook 3 03-28-2010 07:56 AM
Sleep mode in Linux? cookie_monster Linux - Desktop 3 03-03-2008 02:54 PM
Linux Sleep Mode? RynoFly Linux - Newbie 1 01-17-2005 01:21 AM
Sleep Mode Doesn't Work RemusX2 Linux - Hardware 1 06-26-2004 07:04 AM


All times are GMT -5. The time now is 08:24 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration