LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 11-21-2005, 11:27 PM   #1
timkarwoski
LQ Newbie
 
Registered: Nov 2005
Posts: 23

Rep: Reputation: 15
Ctrl-Alt-F1 = Black,blank screen?


I was looking at another help topic and I saw that someone mentioned that pressing Ctrl-Alt-F1 will bring up some kind of console window. I tried that out but I got a strange result.

Right when I press it the screen turns off for about a second, and then it comes back on, although it is just solid black. I cannot do anything in this state, theres no prompt or text or anything, just solid black. If I press Ctrl-Alt-F7 again it flashes off a second like before and brings me back to the desktop and everything is fine. (I'm running Mandrake 10.1, Kernel 2.6.14.2 with an ATI x800 graphics card)

Any Ideas? I can supply any relevant console outputs or file contents if it will help, just let me know.
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 11-22-2005, 12:53 AM   #2
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,133

Rep: Reputation: 320Reputation: 320Reputation: 320Reputation: 320
You probably don't have a getty process running on tty1 (the first console). Check your /etc/inittab to see if getty is started on that console in runlevel 5.
 
Old 11-22-2005, 09:10 AM   #3
timkarwoski
LQ Newbie
 
Registered: Nov 2005
Posts: 23

Original Poster
Rep: Reputation: 15
Ok Im not real familiar with getty, heres whats in my /etc/inittab

Code:
#
# inittab       This file describes how the INIT process should set up
#               the system in a certain run-level.
#
# Author:       Miquel van Smoorenburg, <miquels@drinkel.nl.mugnet.org>
#               Modified for RHS Linux by Marc Ewing and Donnie Barnes
#

# Default runlevel. The runlevels used by Mandrakelinux are:
#   0 - halt (Do NOT set initdefault to this)
#   1 - Single user mode
#   2 - Multiuser, without NFS (The same as 3, if you do not have networking)
#   3 - Full multiuser mode
#   4 - unused
#   5 - X11
#   6 - reboot (Do NOT set initdefault to this)
# 
id:5:initdefault:

# System initialization.
si::sysinit:/etc/rc.d/rc.sysinit

l0:0:wait:/etc/rc.d/rc 0
l1:1:wait:/etc/rc.d/rc 1
l2:2:wait:/etc/rc.d/rc 2
l3:3:wait:/etc/rc.d/rc 3
l4:4:wait:/etc/rc.d/rc 4
l5:5:wait:/etc/rc.d/rc 5
l6:6:wait:/etc/rc.d/rc 6

# Trap CTRL-ALT-DELETE

# When our UPS tells us power has failed, assume we have a few minutes
# of power left.  Schedule a shutdown for 2 minutes from now.
# This does, of course, assume you have powerd installed and your
# UPS connected and working correctly.  
pf::powerfail:/sbin/shutdown -f -h +2 "Power Failure; System Shutting Down"

# If power was restored before the shutdown kicked in, cancel it.
pr:12345:powerokwait:/sbin/shutdown -c "Power Restored; Shutdown Cancelled"


# Run gettys in standard runlevels
1:2345:respawn:/sbin/mingetty tty1
2:2345:respawn:/sbin/mingetty tty2
3:2345:respawn:/sbin/mingetty tty3
4:2345:respawn:/sbin/mingetty tty4
5:2345:respawn:/sbin/mingetty tty5
6:2345:respawn:/sbin/mingetty tty6

ca::ctrlaltdel:/sbin/shutdown -t3 -r now
Any suggestions?

Last edited by timkarwoski; 11-22-2005 at 09:11 AM.
 
Old 11-22-2005, 09:17 AM   #4
brainiac
Member
 
Registered: Jan 2005
Location: middle of a cornfield, IL
Distribution: Kanotix HD Install, Debian Testing, XP Pro,Vista RC1
Posts: 145

Rep: Reputation: 15
One of my systems had issues with Ctrl-Alt-F1 terminal. F2-F6 worked just fine, now out of habit I use them only. It appeared to be some sort of system use thing. Sometimes it would display a boot log, sometimes not.
 
Old 11-22-2005, 09:48 AM   #5
timkarwoski
LQ Newbie
 
Registered: Nov 2005
Posts: 23

Original Poster
Rep: Reputation: 15
F2-F6 also do nothing for me. They all just take me to a blank screen. F7 still brings me back to desktop though.
 
Old 12-18-2005, 04:49 PM   #6
jh559
LQ Newbie
 
Registered: Oct 2005
Location: York, England
Distribution: Fedora Core 4
Posts: 4

Rep: Reputation: 0
having the same problem, any luck fixing it

Hi, i've got the same problem as you described and was wondering if you've had any success fixing it and if so, what you did.

thanks
James
 
Old 12-18-2005, 07:31 PM   #7
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,133

Rep: Reputation: 320Reputation: 320Reputation: 320Reputation: 320
From the /etc/inittab file posted, it looks like mingetty should be running on each terminal. Can you verify (using ps) that the mingetty processes are actually running?
 
Old 12-18-2005, 08:39 PM   #8
jh559
LQ Newbie
 
Registered: Oct 2005
Location: York, England
Distribution: Fedora Core 4
Posts: 4

Rep: Reputation: 0
hi. i managed to fix the problem on my computer by updating xorg-x11 (i'm using fedora core 4 so i used yum to update it). hope that helps.
James
 
Old 12-18-2005, 11:28 PM   #9
m_yates
Senior Member
 
Registered: Aug 2003
Location: Upstate
Distribution: Debian, Mint, Mythbuntu
Posts: 1,176

Rep: Reputation: 54
The problem you are experiencing is most likely due to:

(1) the kernel framebuffer video driver. Do you have bootsplash, usplash, splashy, etc for a graphical boot process? If so, you may need to disable it. Look in /boot/grub/menu.lst (if using grub) and look for vga=XXX where XXX is a number, change it to vga=normal or delete vga altogether. If vga isn't listed, look for "silent" or "verbose" and delete that to avoid using graphics during boot up.

(2) the video driver that xorg is using. In particular Nvidia drivers often cause that. The only way I have found to completely get rid of the blank screen problem is to not use the Nvidia drivers, but that means my TV-out functionality is gone I just load the nvidia driver when I want to watch a movie and use "nv" the rest of the time.
 
Old 01-23-2007, 03:34 PM   #10
loxodonta
LQ Newbie
 
Registered: Jan 2007
Posts: 1

Rep: Reputation: 0
Quote:
Originally Posted by m_yates
The problem you are experiencing is most likely due to:

(1) the kernel framebuffer video driver. Do you have bootsplash, usplash, splashy, etc for a graphical boot process? If so, you may need to disable it. Look in /boot/grub/menu.lst (if using grub) and look for vga=XXX where XXX is a number, change it to vga=normal or delete vga altogether. If vga isn't listed, look for "silent" or "verbose" and delete that to avoid using graphics during boot up.

(2) the video driver that xorg is using. In particular Nvidia drivers often cause that. The only way I have found to completely get rid of the blank screen problem is to not use the Nvidia drivers, but that means my TV-out functionality is gone I just load the nvidia driver when I want to watch a movie and use "nv" the rest of the time.
I was experiencing the same problem on a Dell Inspiron 5150 with an Nvidia graphics card, running Ubuntu 6.06 (Dapper) with Grub. What I needed to do was replace the line
Code:
  # defoptions=quiet splash
to
Code:
  # defoptions=""
and run update-grub.
(N.B. simply '# defoptions=' didn't work, it was replaced by the old one.)

Thank you, now it's working!
 
Old 01-30-2007, 09:12 AM   #11
bfg1971
LQ Newbie
 
Registered: Jan 2007
Posts: 1

Rep: Reputation: 0
@loxodonta - Thanks for that tip. I am using Ubuntu 6.1 in a Virtual PC and was having the same issues with blank terminals (ctrl + alt + Fn). I used your suggestion about editing /boot/grub/menu.lst and then changing "# defoptions=quiet splash" to "# defoptions=""" and it worked great for me!!

Since I'm new at linux, could you tell me what I actually did?
 
Old 05-23-2011, 01:34 AM   #12
pr0t0s
LQ Newbie
 
Registered: Oct 2009
Posts: 2

Rep: Reputation: 2
Cool Fixed!: Ctrl-Alt-F1 (or Ctrl Alt F2-F6) for 10.2 Ubuntu

As pointed out in a previous post, this can be as a result of 1)boot splash screen messing up the framebuffer OR 2) nvidia/ati driver issues.

Luckily in my case it turned out to be (1).

However editing grub turned out to be more an ordeal than I imagined. Interestingly there are significant methodology changes in grub2 (which Ubuntu 9.04+ uses by default) vs grub. The easy way to figure out which grub version you have is to check for existence of the menu.lst file in /boot/grub

No menu.lst implies grub2, which will then require more work (not too much though). If you have menu.lst you are using grub v1.x and you can easily remove the vga line or turn it to vga=normal

For grub2 users, the following steps are required:
1. Edit the /etc/default/grub file and change the vga value to vga=normal
2. run sudo update-grub - this will generate/re-gen your grun.cfg file
3. Check the grub.cfg file (under /boot/grub) to ensure that the vga setting is set to nromal

You may need to edit the grub.cfg again to the right value if it ends up appending noslpash to it. This means that you will need to edit it after every kernel launch. But that is okay, now you atleast know how to fix it.

This link may help too http://norootsquash.wordpress.com/20...r-ubuntu-10-2/
 
2 members found this post helpful.
Old 10-22-2011, 04:33 AM   #13
acampbell
Member
 
Registered: Nov 2003
Location: London
Distribution: Debian
Posts: 116

Rep: Reputation: 16
Many thanks for posting this. I'm using Debian Sid and I've struggled with it on my Thinkad Z61M for ages. Working fine now
 
Old 11-20-2011, 09:45 AM   #14
shikha.punyani@gmail.com
LQ Newbie
 
Registered: Nov 2011
Posts: 1

Rep: Reputation: Disabled
Unhappy Need help sap..

Hello All,
I have seen the issue you guys were discussing below.
I just bought dell Inspiron laptop i3 processor, 500GB hard drive and 4 GB ram.
I have installed vmware on my lappy and then Linux RHEL6.
with ctrl+alt+F1, my computer hangs and do weiered things.
As per your discussion in below frum, I checked the file:
/etc/grub.conf/menu.list and I cant see any entry with vga or silent or verbose.
However I can see one entry which is
splash image=(hd0,0)/grub/splash.xpm.gz
Do I need to change here? If yes what do I need enter here?
I cant see my new lappy getting hung because of this . Please help asap..
 
Old 02-03-2012, 04:13 PM   #15
pcardout
Member
 
Registered: Jun 2003
Location: Socorro, New Mexico
Distribution: Debian ("lenny", "squeeze"), Ubuntu ("karmic", "oneiric")
Posts: 214

Rep: Reputation: 24
Ctrl-Alt-F1 gives black screen on Ubuntu Oneiric Ocelot with grub2

I used the advice of pr0to0s above to solve my problem, but it was a bit more involved
so I wanted to add to the pool of good advice on this relatively common problem.

There is general agreement on the net that

1) The problem may be that mingetty or getty are not configured properly in inittab.
2) The problem is most likely a video problem that can often be solved by changing the grub configuration.
3) Nvidia drivers are implicated.

I have a shiny new system with a hot nvidia card and I did not want to go disable the drivers (solution 3).
My experience is it was not necessary ... and I would say in general that it should not be
necessary. Fundamentally, grub is trying to use video modes that don't work. The solution
is not to fix the video modes, but rather to make grub behave in a more basic fashion (it's a ruddy boot loader ... let's
not go overboard with the graphics!).

OK here's what worked and did not work for me.

1) I first discovered that Ubuntu does not use /etc/inittab ... so workaround suggesting modifications thereof are unhelpful.
2) (1) is not a problem if it turns out that getty is running. I did a top and saw that getty was running.
3) To be really sure getty was running, I typed ctrl-alt-f1 and assumed that I was at a login screen even though screen was blank.
I logged in as root (on Ubuntu I always enable root) and typed reboot. It worked. That meant that I did have a functioning
terminal, I just could not see it!
4) I tried to modify /etc/default/grub looking to delete "quiet splash" as has been suggested several places.
There is nothing like that in the file. There was nothing to change. I made no changes.
5) I modified /boot/grub/grub.cfg as follows:

Code:
menuentry 'Ubuntu, with Linux 3.0.0-15-generic-pae' --class ubuntu --class gnu-linux --class gnu --class os {
	recordfail
	set gfxpayload=$linux_gfx_mode
	insmod gzio
	insmod part_msdos
	insmod ext2
	set root='(hd0,msdos1)'
	search --no-floppy --fs-uuid --set=root 244649d8-08c4-426c-a8ae-074abab1d239
#	linux	/boot/vmlinuz-3.0.0-15-generic-pae root=UUID=244649d8-08c4-426c-a8ae-074abab1d239 ro quiet splash  vt.handoff=7
	linux	/boot/vmlinuz-3.0.0-15-generic-pae root=UUID=244649d8-08c4-426c-a8ae-074abab1d239 ro nomodeset
	initrd	/boot/initrd.img-3.0.0-15-generic-pae
}
Note that I commented out the line with quiet splash vt.handoff=7 and replaced it with nomodeset.
I only made the change to one of my boot entries, on the theory that if I messed up I could boot with some other entry.
I got the nomodeset idea by looking at some of my recovery entries. I figured that the recovery stuff would
be the most stripped down. It seemed to have worked. I know have Oneiric Ocelot running with standard nvidia graphics
and Ctrl-Alt-F1 -- Ctrl-Alt-F6 all open terminals as they should.

AFTERNOTE: As noted by impert below, changes to grub.cfg are volatile and will be wiped next time update-grub is run
(as happens when you upgrade your kernel).
I could not figure out how to modify /etc/default/grub to accomplish this task, but using imperts advice I figured it out and
note it two posts further on.

Last edited by pcardout; 02-03-2012 at 06:34 PM. Reason: Incorporate suggestions by impert
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gnome crashes to black screen after boot up (though ctrl-alt-F2 gives a terminal) Gossamer Linux - Newbie 0 10-06-2005 01:32 AM
xscreensaver lock screen with Ctrl-Alt-Del kaon Linux - Software 2 07-13-2005 10:50 AM
dark screen when pressing Ctrl + Alt + Backspace or Ctrl + Alt F1-F6 in Gnome or KDE trinoo Slackware 5 01-28-2005 08:13 AM
Switching window focus (like alt+tab in windows) and Ctrl+Alt+F1 X windows problem... DiZASTiX Linux - Software 3 01-20-2005 04:56 PM
Ctrl-Alt-F* Fiskarn Mandriva 2 10-15-2003 02:44 AM


All times are GMT -5. The time now is 10:14 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration