LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise
User Name
Password
Linux - Enterprise This forum is for all items relating to using Linux in the Enterprise.

Notices



Reply
 
Search this Thread
Old 10-03-2005, 10:33 PM   #1
jwcm98
LQ Newbie
 
Registered: Oct 2005
Posts: 2

Rep: Reputation: 0
Can't boot-up Suse Linux Enterpise Server 9 after I attached external storage.


Hi,

I have the problem of boot-up the Suse Linux Enterpise Server 9, after I attached a external storage.

The problem is because of the following:

Before attached to external storage:
swap is mounted as "/dev/sda1"
root (/) is mounted as "/dev/sda2"

After attached to external storage:
External Storage partitions are mounted as "/dev/sda1", "/dev/sda2", and so on.
swap is mounted as "/dev/sdb1"
root (/) is mounted as "/dev/sdb2"

We can tell BIOS to bootup using the Internal SCSI drive, but after bootup to SUSE, the hardware dectection will dectect external storage first then only dectect local SCSI drive, which make the mapping of devices (/dev/sda1, etc) problem.

I manage to resolve the problem by modify the Grub "menu.lst" and "fstab", but as and when I put in more external storage LUNs, or remove the LUNs, I need to modify again.

Is there anyway I can fix the boot up hardware dectection sequence? To let the local SCSI harddisk to dectect and assign to "/dev/sda1" first before external storage?

Or at least we can fix the "/dev/sda1" to swap partition, and "/dev/sda2" to root partition.

Thanks.

Jimmy
 
Old 10-04-2005, 10:48 AM   #2
duliano
Member
 
Registered: Oct 2004
Location: Clayton, NY
Distribution: SuSE Prof 9.1, 9.2, 9.3Pro X86_64 SLES 8 & 9
Posts: 82

Rep: Reputation: 15
I experienced a similiar situation on compaq hardware. I had a seperate scsi card which would take priority over the other scsi devices during the bios intialization. I ended up using the smart start programs to configure the scsi card and the scsi devices to intialize in the proper sequence. Once I did that, SLES was able to boot and initialize the devices correctly.
 
Old 10-08-2005, 01:06 AM   #3
basemodel
Member
 
Registered: Jul 2003
Posts: 54

Rep: Reputation: 15
There's two things you need to do:
1. Edit modules (modprobe?).conf and change the order in which the modules are loaded. If it loads the external SCSI driver before the internal disk driver, you will see this every time you add storage. Change the module loading order so that your internal disk driver is FIRST.
2. If you are using ext3 partitions, you can label partitions using e2label, and then mount them like 'mount LABEL=mypartition', and set them up the same way in /etc/fstab (just put LABEL=whatever instead of /dev/sda, etc). That way, no matter what changes, it will mount the drive by partition label, not partition device name.
 
Old 10-11-2005, 05:29 AM   #4
jwcm98
LQ Newbie
 
Registered: Oct 2005
Posts: 2

Original Poster
Rep: Reputation: 0
Thanks.

Hi, Guys,

Thanks.

Jimmy
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Network Attached Storage - Project ?? radial Linux - Networking 3 06-13-2006 04:17 AM
help with Network Attached Storage debloxie Linux - Networking 3 09-12-2005 11:39 PM
External storage for Linux/Windows: Samba or USB 2.0 attached Hard Drive? SparceMatrix Linux - Hardware 1 02-04-2005 03:33 PM
Building a cheap network-attached storage system Travis86 Linux - Networking 5 03-14-2003 01:42 PM
Network Attached Storage - Project ?? radial General 0 08-20-2001 06:49 PM


All times are GMT -5. The time now is 01:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration