LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 02-11-2010, 10:17 AM   #1
GrubbySeismic
Member
 
Registered: Jan 2010
Location: Twickenham, UK
Distribution: OpenSolaris2009.06x86 || Linpus Lite 1.2 ||Debian (Lenny kernel 2.6 && Gnome 2)
Posts: 43

Rep: Reputation: 15
Unhappy GEdit: text-files' compatibility with Windows - settings question


Allo!

I am having some trouble making sure that the line-breaks in text-files remain consistent across Win-lose XP && Debian / Gnome 2.22.3 (as well as Gnome/OpenSUSE if possible) but don't know where to start (G)editing re: settings.

I remember there being a "save as ASCII" (not UTF-8) dialogue somewhere, but I'm tired and hungry and can't remember where I left it (awwww, poor baby, etc etc)...

If anyone wants to help out it would be most appreciated!

Apologies if this is in the wrong place, I consider this a Gnome-usage issue rather than directly a GEdit issue (if only because the GEdit preferences menu-system is quite sparse)...
 
Old 02-11-2010, 02:06 PM   #2
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,029
Blog Entries: 52

Rep: Reputation: Disabled
I don't know what to do about Gedit, but one solution would be to get a text editor for XP that recognises the different line endings. I use EditPad Lite on XP, it can open and save a file with the correct line ending, and convert one to the other.

http://www.editpadpro.com/editpadlite.html
 
Old 02-13-2010, 01:48 PM   #3
teckk
Senior Member
 
Registered: Oct 2004
Distribution: FreeBSD Arch
Posts: 1,752

Rep: Reputation: 189Reputation: 189
As I recall, wordpad in windoze diplays .txt files made in gedit correctly. Notepad does not.
 
1 members found this post helpful.
Old 06-11-2010, 12:13 PM   #4
Bobber47
LQ Newbie
 
Registered: Apr 2008
Location: San Francisco, CA
Distribution: Ubuntu, Vector, DSL, Puppy
Posts: 10

Rep: Reputation: 1
find in "save as" or use newline madness plugin

By default, Gedit maintains whatever EOL format the file had when opened. You can change that when saving the file if you use the "save as" option and choose an alternate EOL (Unix/Linux = LF, Classic Mac=CR, Windows=CR/LF). The plugin "NewLine Madness" provides an indicator of the current file format in the status bar, as well as a function under the Edit menu to change the format.

You can then choose whichever file format you prefer with which to maintain your files across systems.
 
1 members found this post helpful.
  


Reply

Tags
ascii, break, gedit, gnome, text


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
gedit: how to indent whole blocks of text linuxqueric Linux - Desktop 1 05-16-2009 04:43 AM
why gedit text editor doesn't work? fm_hyudin Linux - General 9 06-24-2008 11:36 AM
Is gedit the best for text editing? zensunni Programming 9 03-10-2008 04:12 PM
Gedit has no Text encryption Plugin yeehi General 0 11-09-2007 09:45 AM
Nautilus and Gedit fail to open text files zarkon Linux - Software 3 04-06-2005 10:00 AM


All times are GMT -5. The time now is 08:57 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration