LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora > Fedora - Installation
User Name
Password
Fedora - Installation This forum is for the discussion of installation issues with Fedora.

Notices

Reply
 
Search this Thread
Old 06-03-2007, 01:16 AM   #1
WindowsHater001
LQ Newbie
 
Registered: Sep 2006
Distribution: Fedora 7 (trying to)
Posts: 6

Rep: Reputation: 0
Exclamation can't find disk driver on Virtual Machine install on latest MacBook


I have a new MacBook with the latest OS X 10.4.9 and I am trying to install Fedora 7 using Parallels Desktops. As far as I know, i gave it enough memory and stuff when creating the Virtual Machine, but, after i click on my install option, and go through the keyboard layout and language thing, it asks me to select a driver for the drive the install media is on it is a Matshita DVD-R UJ-857E, a.k.a. SuperDrive. and it's not listed on the available drivers. Most of what's listed is RAID controllers and stuff. i seriously have no idea how to fix this, it's the first time i've ever had any problems installing Linux. i am almost positive i have the right achitecture, i got the i386 install dvd and i saw somewhere that my MacBook is i386, but the achitecture wouldn't affect the driver like that would it? unless it couldn't find the driver cuz it was on an i386 but my system is x86_64? Thanx in advance

Last edited by WindowsHater001; 06-03-2007 at 01:24 AM.
 
Old 06-06-2007, 10:49 AM   #2
clarusgoesmoof
LQ Newbie
 
Registered: Jun 2007
Posts: 3

Rep: Reputation: 0
I found this via Google. Hopefully it will help you out.


Quote:
So I downloaded the new Fedora 7 DVD iso last night. (Thanks for hosting it Duke!) Then I used Parallels on my MacBook Pro to make a Virtual Machine. (documentation here)

At first the classic Linux install screen asked me to manually choose a CD-Rom driver. It appears the installer didn’t recognize the virtual cd-rom/iso. After a bit of searching on the web I found that this may be some bug in the new Linux Kernel that is in the new Fedora and Ubuntu. One recommended fix was to fool Parallels by telling it this was a Solaris install. The uber geeks on the thread say this causes Parallels to use a proper driver. After the successfull install I changed it back to Linux and Fedora. Parallels didn’t seem to mind.

Another recommendation was to use only 512mb of RAM. Some folks have experienced crashes with more than that. Seems counter intuitive, but it does prevent kernel panics.

The install went smooth but while it was booting for the first time I got a big black screen with a X cursor. Seems the graphics server was crashing and rebooting. Hmmm.

More google searching led me to new xorg.conf settings. I found these in a Parallels forum for Fedora 7. Thank you unfletch!

Here is the xorg.conf settings I used that worked:

# Xorg configuration created by pyxf86config

Section “ServerLayout”
Identifier “Default Layout”
Screen 0 “Screen0? 0 0
InputDevice “Keyboard0? “CoreKeyboard”
EndSection

Section “InputDevice”
Identifier “Keyboard0?
Driver “kbd”
Option “XkbModel” “pc105?
Option “XkbLayout” “us”
EndSection

Section “Monitor”
Identifier “Monitor0?
ModelName “LCD Panel 1280×800?
### Comment all HorizSync and VertSync values to use DDC:
HorizSync 31.5 - 90.0
VertRefresh 59.9 - 60.1
Option “dpms”
EndSection

Section “Device”
Identifier “Videocard0?
Driver “vesa”
EndSection

Section “Screen”
Identifier “Screen0?
Device “Videocard0?
Monitor “Monitor0?
DefaultDepth 24
SubSection “Display”
Viewport 0 0
Depth 24
Modes “1280×800? “1152×864? “1024×768? “800×600? “640×480?
EndSubSection
EndSection

So how did I get to a command prompt to create a new xorg.conf file?

Another great google search brought me to a fedora faq page. What I needed to do was boot into single user mode so I had a command line interface not a graphic one. Text only mode is Runlevel 3.

So when you start your Fedora virtual machine it shows you the screen of which kernel to use. Instead of hitting enter type the e key. This allows you to edit your grub command.

# While You Are Booting the Computer:

1. When you first start your computer, the GRUB screen (where you choose your Operating System) appears. Select the Fedora that you want to boot into, but press the a key instead of pressing Enter.
2. You will see a line somewhat like the following:

kernel /vmlinuz-2.6.9-1.667 ro root=LABEL=/ acpi=on rhgb quiet

Add the number of your runlevel to the end of that line, and then press Enter. For example, to boot into text-only mode, the line would look like:

kernel /vmlinuz-2.6.9-1.667 ro root=LABEL=/ acpi=on rhgb quiet 3

You will then boot into the new runlevel this time only.

After I logged in as root I did this:

cd /etc/X11
cp xorg.conf xorg.conf.bkup

That made a back up of my old xorg.conf file. Then I did this:

rm xorg.conf

Be careful with the rm command. It deletes stuff forever!

The I used the text editor vi to add the new xorg.conf settings. Unfortunately I couldn’t cut and paste them into a new file. So I typed in the new parts by hand.

Once I saved the new xorg.conf file I shut down the virtual machine. I did this via the command line so the new xorg.conf file would be saved and available for the next boot.

shutdown -h now

Once its shutdown I hit the red stop button on Parallels to tell it to really stop the vm. Then I immediately hit the green start button. Success! A brand new install of Fedora 7 that runs quite fast. Amazing!

(let me know in the comments if I left anything real important out)

Man I LOVE being able to run just about any OS under the sun on my Intel Mac laptop!
 
Old 06-06-2007, 10:53 AM   #3
clarusgoesmoof
LQ Newbie
 
Registered: Jun 2007
Posts: 3

Rep: Reputation: 0
I also found this:

http://forums.parallels.com/thread12257.html

Enjoy.
 
Old 06-07-2007, 12:52 AM   #4
WindowsHater001
LQ Newbie
 
Registered: Sep 2006
Distribution: Fedora 7 (trying to)
Posts: 6

Original Poster
Rep: Reputation: 0
Thumbs up Kudos!!!!

Thank You SOOOOOOO much!!!!!! i actually searched on google after i posted this topic, and apparently i didn't use the right keywords or something cuz my topic was the only hit. This should solve everything. THANK YOU SOOOOO MUCH!!!!!!!!!!!!!!!!!!!!!!!!!!!! I'm a total

EDIT

actually, this didn't fix the X thing, mine still crashes. But however, you did still solve my original problem, so still Kudos. If you know of anything else to help out with the X problem, i would be much obliged. i can currently only use it in runlevel 3 (text only) so it took me a while to start with vi too. anyway, what it said was that there was an error with line 4 the "CoreKeyboard" part. I would assume it didn't know what the xorg.conf file was talking about. and it said something about not being able to find a display also, i think part of that is that i have a MacBook and he was using a MacBook Pro, different displays and screen sizes and such. thanX (lol) for the help. A LOT!

Last edited by WindowsHater001; 06-07-2007 at 02:30 AM.
 
Old 08-22-2007, 12:33 PM   #5
WindowsHater001
LQ Newbie
 
Registered: Sep 2006
Distribution: Fedora 7 (trying to)
Posts: 6

Original Poster
Rep: Reputation: 0
Exclamation Anybody????

Is anybody there? This Did NOT fix the X problem!!! STILL NEED HELP
 
  


Reply

Tags
machine, virtual, vm


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can I use a virtual machine hard disk as a real hard disk, or vice versa? onlineapps Linux - Software 1 02-24-2007 08:40 PM
How to install Java Virtual Machine for Mozilla? JockVSJock Linux - Software 10 05-26-2005 11:16 AM
virtual machine can't find cdrom device bruno buys Linux - Software 0 05-26-2004 06:58 PM
How do I install the latest Nvidia Driver captaincaveman Linux - Software 2 05-03-2004 11:26 PM
how can i install java virtual machine red hat-ziggis Linux - Software 1 10-23-2003 12:43 PM


All times are GMT -5. The time now is 07:54 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration