LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 10-07-2012, 02:32 PM   #3751
larshenric
Member
 
Registered: Aug 2012
Location: Flensburg, Germany
Distribution: Ubuntu 11.04
Posts: 42

Rep: Reputation: Disabled

Hi folks!
Hopefully I can get some help: Now that's postseason I get the message "An error occurred in locating the game stream. BLACKOUT - MLB_NON_US_BLACKOUT"

Why? I'm watching in Germany, so no Blackout restrictions for me...
Can I change something in the config or something...?

Thanks in advance!
Lars
 
Old 10-09-2012, 07:56 PM   #3752
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,744

Rep: Reputation: 76
Quote:
Originally Posted by larshenric View Post
Hi folks!
Hopefully I can get some help: Now that's postseason I get the message "An error occurred in locating the game stream. BLACKOUT - MLB_NON_US_BLACKOUT"

Why? I'm watching in Germany, so no Blackout restrictions for me...
Can I change something in the config or something...?

Thanks in advance!
Lars
Look in the debug section of one of the readme files to produce a log using mlbgameid.py with the event id. Post the log to pastebin.com and the pastebin URL here. There is a possibility that although the response has a blackout code, it is also returning a game URL. If that is the case, I can fix that. Otherwise, you will have to contact MLB.TV support to find out why you are being blacked out.

You may also want to check the MLB.TV or Postseason.TV subscription pages to see if you MLB wants more money from you to see the postseason.
 
Old 10-10-2012, 05:23 AM   #3753
larshenric
Member
 
Registered: Aug 2012
Location: Flensburg, Germany
Distribution: Ubuntu 11.04
Posts: 42

Rep: Reputation: Disabled
Hi daftcat!

Thank you for helping!! :-)
I hope I understood everything right, so you get the right information...
I used mlbgamedl.py to download one of yesterdays games (10-09-12), copied the terminal message and posted it on pastebin.com (never been there before... ). Here's the URL: http://pastebin.com/0vVd0vFK

Hope it helps...

Last edited by larshenric; 10-10-2012 at 05:28 AM.
 
Old 10-11-2012, 11:56 AM   #3754
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,744

Rep: Reputation: 76
Quote:
Originally Posted by larshenric View Post
Hi daftcat!

Thank you for helping!! :-)
I hope I understood everything right, so you get the right information...
I used mlbgamedl.py to download one of yesterdays games (10-09-12), copied the terminal message and posted it on pastebin.com (never been there before... ). Here's the URL: http://pastebin.com/0vVd0vFK

Hope it helps...
Unfortunately, some of the content filtering available in mlbviewer is not in mlbgame.py. mlbgame.py is just test code after all and meant to be quick and dirty. When using just the event-id, the first content-id code that I am picking up is a postseason.tv multi-angle code which is not supported outside the US.

However, you can try again by manually specifying the content-id as the second argument. The content-id is the 8 digit number that precedes the event-id in the preferred media section. For example, using the 'z' key for 10-09-12 Oakland game:

Code:
preferred media for current cursor:
{'audio': ('KGMZ', u'133', '25360695', '14-345598-2012-10-09'), 'video': ('TBS-H
D', '0', '25360699', '14-345598-2012-10-09')}
Under video, the elements decode as

video: (call_letters, teamcode, content-id, event-id)

So the event-id above is 14-345598-2012-10-09 and the content-id is 25360699.

Please create another pastebin.com log with mlbgamedl.py using the following command:

Code:
./mlbgamedl.py 14-345598-2012-10-09 25360699
If that works, you can use that for future games while I try to figure out why the content filtering is not working correctly. If it doesn't the log should help me figure out what's going on. Either way, please post the log so I can see what your response looks like when the correct content is selected.

Thanks!
 
Old 10-11-2012, 02:21 PM   #3755
larshenric
Member
 
Registered: Aug 2012
Location: Flensburg, Germany
Distribution: Ubuntu 11.04
Posts: 42

Rep: Reputation: Disabled
Hi daftcat!

With your described way mlbgamedl.py works. That's fine for me - as I already wrote earlier... ;-)
And I managed to get mlbviewer work, too, doing the following:
I changed the config file by typing a "1" behind "postseason=" and behind "blackout="
 
Old 10-12-2012, 01:53 PM   #3756
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,744

Rep: Reputation: 76
Quote:
Originally Posted by larshenric View Post
Hi daftcat!

With your described way mlbgamedl.py works. That's fine for me - as I already wrote earlier... ;-)
And I managed to get mlbviewer work, too, doing the following:
I changed the config file by typing a "1" behind "postseason=" and behind "blackout="
I'm honestly not sure how either one fixed your problem. Postseason flag should only be used for accessing the US-only Postseason.TV (it gets set automatically when you select a camera angle from the 'P'ostseason screen.

Blackout is not a boolean variable. It should only accept teamcodes listed in the README. And the code that uses the blackout flag only looks at geographic blackouts for US and Canada users living in the blackout region of a team. Really, I believe the only thing that blackout flag does is set the status to "Blackout."

I am willing to accept that there may be a bug in the content filtering code that is incorrectly filtering out valid content during the postseason. Or there may be extra flags in the reply from MLB.TV during the postseason that is marking a stream as 'mlb_multiangle_epg' (an extra camera angle) when it is really just the normal stream.

However, since I am a US user, I can't really do any testing myself. If you could please post the successful log using the content-id I gave in my previous reply, I can try to fix that bug for other international users. I feel a little silly telling them to exploit a bug in my own code by setting postseason=1.

As for blackout, I recommend setting that back to empty (blackout=) Otherwise, having an invalid value of "1" in there might come back to hurt you next season when those regional blackout codes will be used again.

Thanks! And I'm glad it's working for you even if I can't explain how.
 
Old 10-12-2012, 01:58 PM   #3757
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,744

Rep: Reputation: 76
Question for you:

Are you accessing the streams normally or are you using the Postseason.TV ('P' key) camera angles (which shouldn't even be available to you in Germany)?

If you are accessing the streams normally, I'm confused why setting postseason=1 works for you and would love to see a successful log.

If you are accessing the streams through the 'P' screen, then that would explain why postseason=1 works but that also confuses me that it didn't just work without having to set the flag in the config since that 'P' screen code already does that.
 
Old 10-13-2012, 02:49 AM   #3758
larshenric
Member
 
Registered: Aug 2012
Location: Flensburg, Germany
Distribution: Ubuntu 11.04
Posts: 42

Rep: Reputation: Disabled
Okay, that's funny... ;-)

And of course I want to help as much as I can.
First: No, I'm not using Postseason.TV... I've got the ordinary mlb.tv account...
Second: Here's the pastebin URL with the log for the Oakland game download using mlbgamedl.py: http://pastebin.com/en4VkcCz
And here for a successful log of last night's BAL-NYY game 5 using mlbviewer.py: http://pastebin.com/d0vA2Wpk

Lars
 
Old 10-13-2012, 04:40 AM   #3759
chrisVV
Member
 
Registered: Aug 2010
Posts: 108

Rep: Reputation: 1
Quote:
Originally Posted by larshenric View Post
Hi daftcat!

With your described way mlbgamedl.py works. That's fine for me - as I already wrote earlier... ;-)
And I managed to get mlbviewer work, too, doing the following:
I changed the config file by typing a "1" behind "postseason=" and behind "blackout="
Quote:
Originally Posted by daftcat View Post
I'm honestly not sure how either one fixed your problem. Postseason flag should only be used for accessing the US-only Postseason.TV (it gets set automatically when you select a camera angle from the 'P'ostseason screen.
Setting 'postseason=1' is necessary for the international feed to work. See http://www.linuxquestions.org/questi...ml#post4487574 . In fact, I leave it enabled the whole season so that I don't forget when the post season arrives: it doesn't affect regular season parsing.

Chris
 
Old 10-15-2012, 05:25 AM   #3760
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,744

Rep: Reputation: 76
Quote:
Originally Posted by chrisVV View Post
Setting 'postseason=1' is necessary for the international feed to work. See http://www.linuxquestions.org/questi...ml#post4487574 . In fact, I leave it enabled the whole season so that I don't forget when the post season arrives: it doesn't affect regular season parsing.

Chris
Good memory! Better than mine.

Now if only there was a way to convince TBS to carry the NLCS and WS or convince Fox to allow Postseason.TV to work.
 
Old 10-15-2012, 05:35 AM   #3761
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,744

Rep: Reputation: 76
So yeah, international users (outside of North America) can likely leave postseason=1 in config file all year round. Most of the blackout rules are only enforced for US and Canada.

Lars, so Chris found the answer. "postseason=1" is the correct fix for international users due to the way MLB.TV constructs their responses in the postseason. You can blank out "blackout=" in your config to avoid any unintended side-effects in regular season. This config option is not a boolean (1 or 0) but rather takes a teamcode. Since blackout rules aren't going to based on geography in Germany, you don't need this option at all.
 
Old 10-20-2012, 02:55 AM   #3762
larshenric
Member
 
Registered: Aug 2012
Location: Flensburg, Germany
Distribution: Ubuntu 11.04
Posts: 42

Rep: Reputation: Disabled
Hm... mlbviewer doesn't start. This is the message:

lars@X64V:~/mlbviewer2012$ python mlbviewer.py
Traceback (most recent call last):
File "mlbviewer.py", line 1630, in <module>
curses.wrapper(mainloop, mycfg.data)
File "/usr/lib/python2.7/curses/wrapper.py", line 43, in wrapper
return func(stdscr, *args, **kwds)
File "mlbviewer.py", line 500, in mainloop
+ len(coveragetoggle.get(cfg['coverage'])) + 2
UnboundLocalError: local variable 'is_adaptive' referenced before assignment

Any ideas?

Last edited by larshenric; 10-20-2012 at 08:51 AM.
 
Old 10-21-2012, 12:02 PM   #3763
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,744

Rep: Reputation: 76
Quote:
Originally Posted by larshenric View Post
Hm... mlbviewer doesn't start. This is the message:

lars@X64V:~/mlbviewer2012$ python mlbviewer.py
Traceback (most recent call last):
File "mlbviewer.py", line 1630, in <module>
curses.wrapper(mainloop, mycfg.data)
File "/usr/lib/python2.7/curses/wrapper.py", line 43, in wrapper
return func(stdscr, *args, **kwds)
File "mlbviewer.py", line 500, in mainloop
+ len(coveragetoggle.get(cfg['coverage'])) + 2
UnboundLocalError: local variable 'is_adaptive' referenced before assignment

Any ideas?
I can't reproduce it using the SVN version. Anyway, there wasn't a game yesterday. Does it happen today when there is a game in the listings?
 
Old 10-21-2012, 12:20 PM   #3764
larshenric
Member
 
Registered: Aug 2012
Location: Flensburg, Germany
Distribution: Ubuntu 11.04
Posts: 42

Rep: Reputation: Disabled
Today it's working again...
 
Old 01-22-2013, 02:21 AM   #3765
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,744

Rep: Reputation: 76
Sourceforge upgrade: svn repo url changed

Hey guys! Not much to report yet except that Sourceforge did an upgrade and I chose to upgrade my project to their new system (actually, I'm not sure there was a choice. )

2012 has been branched off and what will eventually be 2013 can be checked out from the trunk using the new repository URL. I don't think a "svn up" from your current checkout will work any more.

New command for a checkout:

Code:
svn checkout svn://svn.code.sf.net/p/mlbviewer/code/trunk mlbviewer2013
Cheers!
daftcat
 
  


Reply

Tags
help, install, installation, instructions, seek, vlc, windows


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mlb.com gameday audio stream statmobile Linux - Newbie 6 05-06-2008 10:16 PM
link dies intermittently-seemingly at random- between win<->linux not linux<->linux?? takahaya Linux - Networking 10 03-09-2007 10:37 PM
triple boot linux/linux/linux No Windows involved toastermaker Linux - Newbie 12 03-02-2006 10:40 PM
Redhat (rhel v2.1) bootup problem with linux (linux vs linux-up) namgor Linux - Software 2 06-24-2004 02:49 PM


All times are GMT -5. The time now is 07:25 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration