LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Blogs > DarkFlame
User Name
Password

Notices



  1. Old Comment

    First blog, First Linux, 32 years of computing!

    That night, I sent an EECB (Executive Email Carpet Bomb) to everyone of the UPS executives, members of the board of directors, and their senior managers. I never did get a response from UPS on that, but they DID DELIVER THE BOX ON THANKSGIVING MORNING!!! When we got back home that evening, the UPS sticky was on my door telling me that they'd delivered it to the nice neighbor across the street. She told me the delivery guy had been "very apologetic." I don't know if it was the EECB, or the guy at the distribution center who just took it upon himself to fix the problem, but I was then able to spend my long weekend building the server!!! Needless to say, I responded with another EECB telling the execs that I appreciated having the box and would continue to use them as my preferred carrier. Still, I've gotten no response. One would have been nice, but at least (if doing "the least one could do" is adequate) I was able to get started on it.

    I spent the rest of that weekend doing the physical build - installing mother board & 4 GB RAM, installing hard drives and a left-over IDE DVD player.

    Once I had the hardware physically attached, installed, & connected, I was ready, I thought, to install an OS.

    By that time, I had done some research into server OSs. I REALLY wanted the newest Novel software because I had had such success and bulletproofness from their much earlier NetWare. But, at a price of $3,500 (last time I checked), that was pretty much out of the question. Windows wasn't much better with an XP Server. I'd heard good things about Linux - specifically that it was free & had matured enough to be fairly stable.

    So, I had been trying to digest as much about the various versions of Linux that I could stand. Fedora, Ubuntu, Debian, & on & on & on. Then, when I came across OpenSuSE 11.0 and read that it had been developed with some help from Novel, I figured it would be the right one. So, I downloaded it. Even on my 1.5 Mb DSL, it took 16 hours to download the DVD ISO file. And, I was seriously concerned because I didn't think my DVD burner would burn a DVD - considering that it wouldn't burn a data CD. But, luckily, it burned it successfully, and it worked.

    BIFF, BAM, BOOM! I put the DVD into the server DVD drive, and I was off and running. I did configure the HDD array for RAID10 - the mb controller chipeset (SB700) won't do RAID5, and RAID10 seemed to be the next best thing. OpenSuSE recognized the RAID array as almost 500 GB, so I knew that was working. But, I was intrigued by the fact that I'd found in OpenSuSE the ability to create a RAID5 array.

    And, that's where the ASTID (Another Stupid/Silly Thing I've Done) started to become evident. See, ASTIDs are how I recognize when I've done something wrong. And, in keeping with Murphy's Laws, the more energy I expend trying to solve the ASTID, the simpler the ultimate solution! I spent two days trying to figure out how to get RID of the RAID10 array. I had it turned off in the BIOS, but it still persisted in OpenSuSE. I deleted it in OpenSuSE and it kept returning. I even went so far as to download FreeDOS & burn that to a DVD & boot up in FreeDOS and FDISK'd the 4 drives - to no avail, because the RAID was still present in OpenSuSE - EVEN WITH THE RAID CONTROLLER SET TO SATA!!! Finally, I went into the BIOS RAID setup and started the 3 1/2 hour process of doing a secure erase on one of the drives. As I sat there watching it inch along 1% at a time, I thought maybe I ought to reconfigure the RAID10 array and then unconfigure it. And, THAT was the ultimate solution. I had simply turned off the RAID array, but it was still visible in OpenSuSE. But, I hadn't de-configured it, and that was the simple solution to the two days of serious frustration that I'd endured trying to resolve the ASTID. I guess, if I'm going to rate ASTIDs, they should be rated by how many hours it took before I came up with the right solution. This one was a 48 (hours). The solution took less than 10 minutes to put into effect. Not a bad inversely proportionat ratio!

    So, there I was. The server built, downloaded and installed the newest version (3.2, 3.5? Not sure at this point) of SAMBA, but still couldn't get access to the configured 700 GB data drive. I kept trying the SMBPASSWD command, but was doing it from my ADMIN login & not from the ROOT login. That ASTID rated a 24, tho it took about 25 seconds to fix, once I figured it out.

    Then, it became an issue of being able to share folders with the same read/write/change rights as someone else, and that was a "force" issue which got resolved with the help of someone here.

    I'm still not happy that the OS is on disk "b" and the 4 drive array is disk "a" disk "c" disk "d" & disk "e" - & I'm having trouble because the 1st SATA drive doesn't show up as the 1st one in BIOS, so you have to move it in BIOS to get it to boot. I've got some playing around with it to make it work the way it SHOULD.

    But, the server is working as I need it to - mostly. There still is an issue with the shared drive not showing up in Windows Explorer until we type into the address bar "J:" (because we made it the "J" drive on both our PCs). But, at least we can both create directories and move stuff into them & rearrange the data in them, despite whoever created them.

    My long range plans include
    • Break it down completely and re set it up from scratch, so that I can document for myself exactly what I must do in the event that the Linux OS hard drive crashes (it's installed on it's own, dedicated physical drive).
    • And, once I have that done, I'm going to yank out the 80 GB drive and replace it with one of the other ones that's been untouched, and make sure my instructions to myself will work the way I expect them to.
    • THEN, I'm going to yank out one of the 4 RAID drives and see how much data gets lost, and how hard it is to replace the drive.
    • Finally, when I'm happy that the whole thing is pretty much bullet proof - save for an asteroid falling through the roof - I'm going to take the whole thing & tuck it away someplace far away so that I don't have to lisetn to this frigging tornado of a fan keeping the drive array cool (yes, it was too hot to touch until I installed the two monster fans inside the case!)
    .

    And, that concludes my first Blog, ever! Whew!
    Posted 12-03-2008 at 12:30 AM by DarkFlame DarkFlame is offline

  



All times are GMT -5. The time now is 04:02 AM.

Main Menu
Advertisement

Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration