Review your favorite Linux distribution.
Go Back > Forums > Other *NIX Forums > *BSD
User Name
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.


  Search this Thread
Old 07-07-2007, 09:49 PM   #1
Registered: Apr 2006
Distribution: openSUSE 10.2
Posts: 62

Rep: Reputation: 16
Xorgcfg - undefined symbols and fails to load modules

Greetings to all.

This is my first time out on OpenBSD, although I have had some previous experience with openSuse and Ubuntu.

I have successfully installed OpenBSD 4.1 powerpc version on an old Powerbook G4 400 Mhz, and have also installed KDE without incident. I am having some issues trying to configure xorg, as currently the display looks like ass. When I try to run xorgcfg -textmode, I am bombarded with a large amount of messages such as:

xorgcfg:/usr/X11R6/lib/modules/drivers/ undefined symbol 'resVgaShared'

Followed by messages such as:

dlopen: Cannot load specified object
Failed to load /usr/X11R6/lib/modules/drivers/
Failed to load module "ati" (loader failed, 7)

After a ton of these messages, I can configure Xorg, but when I try to configure the video card, the card database is empty save for the unsupported card option. I am assuming that this is a result of all the modules that failed to load. Checking /usr/X11R6/lib/modules/drivers, I can see many of the files being referenced, including for example.

I need to setup X to use an ATI driver (my powerbook has a ATI 128 RAGE Mobility). How can I accomplish this and why are, what I assume to be the full list of video drivers, failing to load?

Many thanks,

- Perps.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
modules & symbols rhoyerboat Programming 1 02-08-2005 08:10 PM
unresolved symbols while trying to load modules g.ramkumar Linux - Newbie 1 11-24-2004 02:38 PM
Myth2: fear&loathing undefined symbols trollhatt Linux - Games 1 11-08-2004 09:35 AM
Unresolved Symbols in /lib/modules/... dragonlook Slackware 2 05-12-2004 02:28 AM
Unresolved symbols in /lib/modules Kilahchris Linux - Newbie 3 05-10-2004 04:21 AM

All times are GMT -5. The time now is 12:26 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration