LinuxQuestions.org
Help answer threads with 0 replies.
Home Forums Tutorials Articles Register
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > *BSD
User Name
Password
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.

Notices


Reply
  Search this Thread
Old 06-02-2009, 09:24 PM   #1
jus71n742
Member
 
Registered: Apr 2008
Distribution: Ubuntu 8.04 64bit/ 32bit, FreeBSD 8
Posts: 185

Rep: Reputation: 30
editing ~/.vimrc in FreeBSD


I have made it to the file but I am wondering what to do in order to create syntax highlighting. I have added the line
Code:
syntax on
and this has done nothing. I am also running in just TTY1-6
could this be a reason?

thanks
 
Old 06-03-2009, 03:21 AM   #2
Ygrex
Member
 
Registered: Nov 2004
Location: Russia (St.Petersburg)
Distribution: Debian
Posts: 666

Rep: Reputation: 68
does ":syntax on" work when you type it in vim interactively?
 
Old 06-03-2009, 08:46 AM   #3
jus71n742
Member
 
Registered: Apr 2008
Distribution: Ubuntu 8.04 64bit/ 32bit, FreeBSD 8
Posts: 185

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by Ygrex View Post
does ":syntax on" work when you type it in vim interactively?
No, course I was also noticing that I may not have the full version...and one thing that is annoying me is I can not find the way to, for example in Linux
Code:
sudo apt-get install vim-full
and VIM is installed. I can't find what does this in FreeBSD, and I think that may have some bearing in this situation.
 
Old 06-03-2009, 09:31 AM   #4
rsciw
Member
 
Registered: Jan 2009
Location: Essex (UK)
Distribution: Home: Debian/Ubuntu, Work: Ubuntu
Posts: 206

Rep: Reputation: 44
this should be the full vim:
http://ftp2.at.freebsd.org/pub/FreeB...-7.2.166_1.tbz

compared to
vim-lite-7.2.166_1.tbz

does freebsd give you options what to install when you use
pkg_add -i vim
?

vim syntax highlighting:
http://www.vim.org/htmldoc/syntax.html

basically to enable it, it's
:syntax enable
 
Old 06-03-2009, 11:25 AM   #5
Fin7PL
Member
 
Registered: Mar 2005
Location: Finland
Distribution: FreeBSD 9.0
Posts: 59

Rep: Reputation: 17
These are directly from the very useful handbook Press Previous to package method :-) (2 methods: Package method and port method)

http://www.freebsd.org/doc/en/books/...rts-using.html

You can use
Code:
pkg_add -r vim
or then if you have ports tree installed (if not you can get it by)

Code:
portsnap fetch
portsnap extract
If you have portstree you can update it by running

Code:
portsnap fetch
portsnap update

then

goto /usr/ports/editors/vim

Code:
make install clean
This might also require X on its depencies so if you want it without X

if you dont have X installed then i dunno this is a little old article

http://www.tequilafish.com/2005/08/1...out-x-windows/

Last edited by Fin7PL; 06-04-2009 at 12:07 AM.
 
Old 06-03-2009, 05:22 PM   #6
jus71n742
Member
 
Registered: Apr 2008
Distribution: Ubuntu 8.04 64bit/ 32bit, FreeBSD 8
Posts: 185

Original Poster
Rep: Reputation: 30
error: FTP Unable to get ftp://ftp.freebsd.org/etc etc etc No address record.
pkg_add: unable to fetch 'ftp://ftp."""" by URL
 
Old 06-03-2009, 07:46 PM   #7
jus71n742
Member
 
Registered: Apr 2008
Distribution: Ubuntu 8.04 64bit/ 32bit, FreeBSD 8
Posts: 185

Original Poster
Rep: Reputation: 30
seems as though I don't have any internet connection....
 
Old 06-04-2009, 12:08 AM   #8
Fin7PL
Member
 
Registered: Mar 2005
Location: Finland
Distribution: FreeBSD 9.0
Posts: 59

Rep: Reputation: 17
Tried the ports method?

You really have no connectivity to anything in there?

ifconfig?

Btw how old your FreeBSD is?

if its VERY old then

http://lessfaq.wordpress.com/2008/05...ecord-freebsd/

But i dont think that is the case..

Is DNS working (etc/resolv.conf)?

output of
Code:
host ftp.freebsd.org
cat /etc/resolv.conf
Suppose you have no firewall installed/enabled?

Last edited by Fin7PL; 06-04-2009 at 12:17 AM.
 
Old 06-04-2009, 11:09 PM   #9
jus71n742
Member
 
Registered: Apr 2008
Distribution: Ubuntu 8.04 64bit/ 32bit, FreeBSD 8
Posts: 185

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by Fin7PL View Post
Tried the ports method?

You really have no connectivity to anything in there?

ifconfig?

Btw how old your FreeBSD is?

if its VERY old then

http://lessfaq.wordpress.com/2008/05...ecord-freebsd/

But i dont think that is the case..

Is DNS working (etc/resolv.conf)?

output of
Code:
host ftp.freebsd.org
cat /etc/resolv.conf
Suppose you have no firewall installed/enabled?
No No its FreeBSD 7.2, I ran ifconfig and best I could see was it was at least connecting. It showed the ethernet as enabled and active. and inet is shown as home IP (127.0.0.1)

so I am pretty confused right now.
 
Old 06-05-2009, 02:09 AM   #10
Fin7PL
Member
 
Registered: Mar 2005
Location: Finland
Distribution: FreeBSD 9.0
Posts: 59

Rep: Reputation: 17
Seems like you have only the loopback device there (lo0)

Could you post the output of
Code:
ifconfig
also have you done anything to the kernel. What network card /chip you have?

Also if you kindly would post what says
Code:
dmesg
 
Old 06-07-2009, 07:21 PM   #11
jus71n742
Member
 
Registered: Apr 2008
Distribution: Ubuntu 8.04 64bit/ 32bit, FreeBSD 8
Posts: 185

Original Poster
Rep: Reputation: 30
$ ifconfig
Code:
fwe0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500

options=8<VLAN_MTU>
ether 02:e0:18:0e:94:4b
inet 0.0.0.0 netmask 0xff000000 broadcast 255.255.255.255
ch 1 dma 0
fwip0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
lladdr 0.e0.18.0.0.e.94.4b.a.2.ff.fe.0.0.0.0
bfe0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=8<VLAN_MTU>
ether 00:e0:18:e2:38:18
media: Ethernet autoselect (100baseTX <full-duplex>)
status: active
plip0: flags=108810<POINTTOPOINT,SIMPLEX,MULTICAST,NEEDSGIANT> metric 0 mtu 1500
lo0: flags=8049<UP,LOOPBACK,RUNNING,MUTLICAST>metric 0 mtu 16384
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x5
inet6 ::1 prefixlen 128
inet 127.0.0.1 netmask 0xff000000
dmesg
Code:
ums0: 3 buttons and Z dir.
Timecounter "TSC" frequency 2004558132 Hz quality 800
Timecounters tick every 1.000 msec
firewire0: 1nodes, maxhop <= 0, cable IRM = 0 (me)
firewire0: bus manager 0 (me)
and the rest is GEOM_LABEL s
 
Old 06-08-2009, 03:06 AM   #12
Fin7PL
Member
 
Registered: Mar 2005
Location: Finland
Distribution: FreeBSD 9.0
Posts: 59

Rep: Reputation: 17
fwe0 is your wireless ethernet over firewire? you use that or the card. (rj45)

Code:
bfe0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=8<VLAN_MTU>
ether 00:e0:18:e2:38:18
media: Ethernet autoselect (100baseTX <full-duplex>)
status: active
So this bfe0 is your ethernet card. and it is plugged in too.

It seems it doesn´t get any ip, you have static ip or do you normally get it automatically.

try command
Code:
dhclient bfe0
It should try to get some ip bound to your bfe card.

and post the output. thanks.

To get the dhcp work at boottime place this line to your /etc/rc.conf

Code:
ifconfig_bfe0="DHCP"

Last edited by Fin7PL; 06-08-2009 at 06:51 AM.
 
Old 06-08-2009, 10:19 PM   #13
jus71n742
Member
 
Registered: Apr 2008
Distribution: Ubuntu 8.04 64bit/ 32bit, FreeBSD 8
Posts: 185

Original Poster
Rep: Reputation: 30
Kazahh it works....thank you very much.
 
  


Reply

Tags
dhclient, dhcp, ethernet, ip, nic



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
hi i not getting my .vimrc file in this path ~/.vimrc dina3e Linux - Newbie 6 07-31-2012 04:36 PM
FreeBSD wont load after editing /etc/rc.conf JoeC21 *BSD 5 04-20-2007 05:57 AM
Editing data on an NTFS drive? from FreeBSD? Devboy *BSD 9 08-23-2004 06:23 AM
little questoin about vimrc..... chunlee Linux - Software 2 06-22-2004 07:06 PM
screwed up .vimrc ashesh Linux - General 2 08-23-2003 11:00 AM

LinuxQuestions.org > Forums > Other *NIX Forums > *BSD

All times are GMT -5. The time now is 05:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration