LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > *BSD
User Name
Password
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.

Notices

Reply
 
Search this Thread
Old 03-27-2004, 05:08 AM   #1
tmakobu
LQ Newbie
 
Registered: Jan 2004
Posts: 24

Rep: Reputation: 15
Changing system time on FreeBSD 4.8


How do i change the system time? i,ve tried

date 1245

but it doest work. mrtg updates still show the old time. Can anyone help?
 
Old 03-27-2004, 09:01 PM   #2
J_Szucs
Senior Member
 
Registered: Nov 2001
Location: Budapest, Hungary
Distribution: SuSE 6.4-11.3, Dsl linux, FreeBSD 4.3-6.2, Mandrake 8.2, Redhat, UHU, Debian Etch
Posts: 1,126

Rep: Reputation: 58
Strange. That is exactly how I used to change system time on FreeBSD 4.3-4.6. Have they changed this in FreeBSD 4.8? (Try: man date)

Or, an other idea: were you root when you issued that command?
 
Old 03-28-2004, 11:18 PM   #3
tmakobu
LQ Newbie
 
Registered: Jan 2004
Posts: 24

Original Poster
Rep: Reputation: 15
Yes i was root, but it still does'nt work. Immedietly i change i type date and it gives me the old time.
 
Old 03-29-2004, 03:43 AM   #4
rehab junkie
Member
 
Registered: Nov 2003
Location: /var/local/pub/bar
Distribution: OSX 10.4.9
Posts: 259

Rep: Reputation: 30
Weird. Issuing date xxxx as root changes my system time to xx:xx. FreeBSD 5.2.
 
Old 03-31-2004, 08:19 AM   #5
J_Szucs
Senior Member
 
Registered: Nov 2001
Location: Budapest, Hungary
Distribution: SuSE 6.4-11.3, Dsl linux, FreeBSD 4.3-6.2, Mandrake 8.2, Redhat, UHU, Debian Etch
Posts: 1,126

Rep: Reputation: 58
> Immedietly i change i type date and it gives me the old time.

Do you get any error messages when you issue that command?

It may be unrelated, but the "date 1245" command results in error under Linux, too. I suspect that there are different implementations of the date command under different unices. Maybe your FreeBSD version contains a date util that requires a syntax similar to the Linux one? (I am just guessing).

If so, there is an older thread somewhere in this forum, where I posted a message with the syntax of the date command that worked for me on Linux. Maybe you could try that.

Anyway, "man date" should help.

Last edited by J_Szucs; 03-31-2004 at 08:20 AM.
 
Old 03-31-2004, 08:25 AM   #6
tmakobu
LQ Newbie
 
Registered: Jan 2004
Posts: 24

Original Poster
Rep: Reputation: 15
Heey!, i figured it out!, see the thing is using the bios system time, yees, so i just changed the bios time and everything b-came fine!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
changing the time in the system tray alejan74 General 1 06-30-2005 08:55 PM
Changing system date and time from KDE yapp Linux - General 4 04-17-2005 04:40 AM
Changing System Time rjshirts Linux - Software 4 01-24-2005 04:48 PM
Setting System Time: kernel in wrong time zone warrenweiss Linux - General 7 05-15-2004 04:25 PM
Updating System time from some Inet time server Steave Linux - General 6 12-21-2001 03:12 PM


All times are GMT -5. The time now is 06:12 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration