-   Slackware (
-   -   Non-working USB keyboard at LUKS prompt, 14.1 (

Ilgar 11-12-2013 08:43 AM

Non-working USB keyboard at LUKS prompt, 14.1
Hi all,

I'm finally able to type this message from my desktop computer at work. I struggled for a while to get my USB keyboard working at the LUKS prompt for password. What follows below will hopefully help someone:

In the older kernels it was enough to include the usbhid and ehci-hcd (or ohci-hcd or uhci-hcd) modules in the initrd. Apparently there have been some changes (and the Linux documentation in the source tree is terribly out-of-date):

First of all, there is a new "hid-generic" module that has to be included now. The script already suggests this module. Unfortunately, it wasn't enough in my case.

It turned out that I also had to include the new "ehci-pci" module as well. With a Google search I encountered people with a 3.11 kernel requiring an "ohci-pci" module but 3.10 doesn't have it, so I went for ehci-pci and it worked.

metageek 11-14-2013 02:48 AM

This is definitely good information. Thanks!

sardinha 11-14-2013 04:34 AM

mkinitrd-1.4.8-x86_64-2.txz: Rebuilt
I guess you just need hid_generic and usbhid for usb keyboard. You may not need anymore those you mention for using usb keyboard at boot: ehci-hcd, ehci-pci, ohci-hcd or uhci-hcd.
You have upgraded to 14.1? run again /usr/share/mkinitrd/ in 14.1 should clarify the modules you need.

Check the changelog in days before version Slackware 14.1 was been released:

Tue Oct 29 05:03:04 UTC 2013
a/mkinitrd-1.4.8-x86_64-2.txz: Rebuilt.
In, if a USB keyboard is detected add the
hid_generic module (in addition to usbhid). Recent kernels need this.
Thanks to mario.

Ilgar 11-15-2013 02:01 AM

@sardinha: As I mentioned in my original post, I am already aware that suggests hid-generic and of course I tried it (and many other combinations). One *does* need ehci-pci (and/or ohci-pci with 3.11 kernels) in my case. This is due to the restructuring of the Linux kernel code. You can find relevant discussions about this with a Google search.

number22 11-15-2013 12:25 PM

Thanks for this result of "Google search no keyboard " and this thread, just for furture reference for problem with no usb keyboard:

for kernel 3.10.17, it might need modules of follow: ehci_hcd ehci_pci hid_generic usbhid ohci_hcd ssb_hcd for mkinitrd ram disk.

for kernel (13.37) only just following: ehci_hcd ohci_hcde hid usbhid

however both of them will auto load extra related modules pcmcia_core, ssb and mmc_core etc. modules.

number22 05-18-2014 12:48 PM

for kernel: 3.14.4: you might need add ehci-platform ohci-platform

All times are GMT -5. The time now is 08:23 PM.